Welcome to discussions

Quick Suggestions

  • Charlie_v_Braun
    25 posts

    This patch is not working on any of my issues so far, I still have messed up sound, armor is duplicated and if I cannot finish this "Riddles"-quest this game will unfortunately be done for me, I am not retracing almost 7 hours of gameplay from my latest manual save - any autosaves have already been overwritten, because it took a while for me to realize this quest did not finish properly, at least give me a way to restart the questline or something, so frustrating...

  • FlashXAron
    23 posts

    @chrisclement70 ... had around 10 freezes before in 170h ...
    NOW I HAD ALREADY 3 !!!!!!!!!!!!!!!!!!! in 1h [censored] ...................

    @ubisoft WHAT settings to reduce at least to be back that game only crashes/freezes after around 10h, like it was before, playing on PC (980 TI)

  • Fractal009
    64 posts

    Yes this patch is a joke, nothing they said wd be fixed is fixed .
    Ubisoft once again is disappointing..
    The runes menu ?
    The cloak and skull mask glitched on my face ?
    The sound tearing ?
    The aimlock with bow on controller ?
    And so many others ...

    Please @Ubi stop making fun of us and do your fu..ing job

  • SeeHT
    2 posts

    Didn‘t see much difference with the newest patch. The Lunden World Event near the harbour still not working. On top of that I noticed that some wealth disappeared in East-Engla. The Region now is uncompleted because of the missing wealth. Before the patch everything was fine there. A bit disappointed with the newest patch.

  • Sh0ziii
    1 posts

    They still dont fixed mission with bear Njal and mission in Lunden with man who is stuck in magazine. Pathetic..

  • Fractal009
    64 posts


    Pathetic is the word indeed. If i cd insult them i wd, as I am [censored] af

  • geoage095
    39 posts
    This post is deleted!
  • Darkgoan
    28 posts

    patch joke,my hours of play depend on a bookshelf on a wall T.T

  • TwinCipher
    2 posts

    Still waiting for them to patch a brewing storm, literally for the last 50hrs of gameplay all I've wanted to do is be able to kill dag.

  • geoage095
    39 posts

    Strange,my game says that it's in version 1.0.4 yet when i booted up Uplay the game never updated.I did notice small difference though such as the skills on the skill tree are visible now behind the fog and that tattoos,ship and settlement designs are sorted at the vendors. Other than that nothing else.

  • Darkgoan
    28 posts
    @geoage095  They have not solved anything, we have been playing for hours and hours stagnant, some with an npc others with a shelf and know which ones will have stopped playing after any other error

  • Xylovox
    6 posts

    Still not getting Fabric from chest and shop doesn’t sell it in my level 6 town...

  • tnsmongoose
    3 posts

    Anyone not able to pick up tablets after killing zealots needed for exclaibur?

  • Lika_wa
    3 posts

    "The sons of Ragnar"-quest is till broken. Can't talk to Ubbe. This game is the most broken thing I ever played. 😥

  • RA202075
    3 posts


    After installing 1.0.4 in PC the savegame doesn´t work. Neither the fast travel.

    Please fix it!


  • WR3cker_DK
    75 posts

    Unable to "Place Marker" on quests(map)undefined

  • RA202075
    3 posts

    @harmynl SAme to me!!

  • CGFrewboy
    5 posts

    Something seriously wrong with this update, at least on Xbox One X. Screen tearing still present, but at least that wasn’t said to be fixed. Still cannot progress with The Big Finish (more like The Bug Finish amarite), runes are not categorised, still have duplicate armours. Instead of fixing texture issues the new update seems to have introduced them to me, I am now seeing many low resolution textures as if they haven’t loaded properly. And my game took way longer than usual to save which is distressing after people have reported a new save bug. I am going to leave this game for now until someone that has the knowledge can 100% assure me that the update was deployed as intended, because this all seems very odd.

  • SofaJockey
    Original poster 370 posts

    @charlie_v_braun Patches normally fix the problem not happening during a quest.

    They often don't go into your save and retrospectively fix it.

    The best way to fix a bug is to open a prior save and re-play the quest.

  • Darkgoan
    28 posts

    @sofajockey they can erase the object causing the crash if it has nothing to do with the mechanics of the puzzle

Suggested Topics