ubisoft discussions

Quick Suggestions

  • moran1019
    1 posts

    Can't start the Poor Christian Soldier Mission, I gave the codex pages and medallions to Hytham after returning from Norway. Now I can't start the mission to kill the Father.

  • NoL_Altair
    1 posts

    Same here, such [censored] I've done everything and I'm stuck at 5/6 I've done the poor soldier of christ and the Winchester arc. I've done the the daughter's battle and can't move on.

  • UbiKobold
    Ubisoft Support Staff 931 posts

    Hey moran1019! Please check out the thread here that I have recently responded to. Many others are experiencing this same issue and it is something that we are currently looking into. However, I am very sorry for any trouble that this has caused in the meantime!

    Official Response
  • Shadow-Wipeout
    19 posts

    @greywardenqueen if you were issued thors cape thats the bug

    1 posts


    Thank you for trying to help. I did what you posted.

    Ticket number: 13553068

    Kind regards.

  • kairockz
    11 posts

    Finally noticed under the Issue. Hope on a fix for the next patch 🙂

  • EvilSpark1
    4 posts

    Greetings. An unpleasant moment happened. I am not given a final mission for the Father of the Order of the Ancients (The letter). Nothing happens. Everything is complete, but at the same time I understand that I must be given a mission.

  • killbill9191
    18 posts


    Same Issue here on platform PS4 ; 5/6 clues all regions in story mode complete (hamptunshire included) haytham will not leave his place does not spawn outside longhouse on bench outside as 'youtube videos' prove that is where after the conversation takes place you are offered ' A poor fellow soldier' quest; on top of this annoying bug ( which i believe this is far worse than unity for bugs and we got compensated for that so if i already own season pass how will i be compensated; preordered 125 prior 90.00gbp invested so i cant finish the game still no 'end credits' whilst 0 missions/quests remain ). But on top of this reda at my camp but no shop access since 1.04 update ; another bug one of many hundreds i believe if you read them all , no big Bream/Flatfish/Mackerel ever spawn if they do they are too deep to catch (photo mode will prove this)

    Anyway if it gets sorted great, if not i will contact SONY regarding a REFUND because its simply IMPOSSIBLE to make any form of contact with UBISOFT right now probably giving the old CORONAVIRUS excuse!!!!!!!!

  • crowe76
    9 posts

    I’m in the exact same situation the father, the fish same bug for multiple players and no news on a fix ,I think it’s a inventory duplication bug I have all Thor armor Thor’s hammer and 6 order medallions in my inventory I also noticed that I’ll receive random runes when I first log on the poor fellow soldier quest is tied to the order completion the game has allowed us to turn in 45 because they duplicated at some point I technically have 51

  • killbill9191
    18 posts

    I had 2 extra medallions already handed in 13 as 15 if that makes sense what doesnt make sense is that i travelled to vinland and checked my inventory and my medallions went up from 2 to 7 how wierd is that [censored]

    honestly unity bug was less painful ; these bugs are joke due to xbox release title deadline
    they should have held it back and fixed it 1st , this is outrageous trash which some of us bought deluxe or ultimate versions of trash game of the year ; we have to fix it so 90% of people out there cant ACTUALLY finish it , never ever again i preorder this rushed pile of ..... you know the rest

  • killbill9191
    18 posts


    up to 1605 Views now and rising thats not including people who have just simply had enough

  • DVUS_Samael
    2 posts

    I've been having the same issue as well. I have tried several different things and nothing has worked. Has anyone found a way yet?

  • GrumblyBat19
    1 posts

    So I’ve been off work for about a week. Bought the game and completed everything in 66 hours. But the one thing that is [censored] me off the most is the fact that I have alllllllllll of Thor’s armor except for one. I’ve killed 44 /45 order members and I have 14/15 medallions. I can’t get to the father to complete the armor set because it’s saying that I’ve completed the game entirely but the father hasn’t tasted my axe. Why is it that every time Ubisoft might have something good going on they decide to literally [censored] people off for money. I literally cannot complete the game nor can I complete my damn Thor’s armor set to get the hammer. This was the only reason I bought this damn game was to play with Thor’s hammer. I see everyone else glitched with 15 and able to get the hammer but no I lucked out with only 14 medallions and can’t progress any further into the story.

  • RifkinPlayGames
    6 posts

    I have the same issue
    And if i understood it right its Hytham that gives you the last quest in the longhouse....but he gives me nothing and is still in his AC house

  • MR_GONZO83
    1 posts

    "The letter" mission from Haytham is not popping. Its literately the only thing i have to do just to platinum this game. I defeated all members including zealots. This is one of the more annoying game breaking bugs.

  • killbill9191
    18 posts


    @UBISOFT support

    Dont you think we deserve an update on whats going on with regards to fixing all these MAJOR bugs yet?
    I find it hard to believe you will fix these as if you had we'd already have a fix ; so update all of us PROMPTLY!

    Waiting 7 days to kill 1 member of order just like most other people on here no workaround no fix no patch Im personally giving you 48hrs to patch update otherwise im going directly to sony for FULL REFUND.

    This should not be out of beta testing this game , this is my worst experience with a UBISOFT title EVER this pile of garbage overtakes AC UNITY for me personally and we all got dead kings DLC for free (except season pass holders)

    I am a season pass holder for this piece of trash , so what will i get?
    I bet developers are still making bs outfits and themes for helix credits only attainable by real money you scandalous skanking mo.......... you know the rest!!!!

    Really aggitated by this [censored]

  • Alexandru27p
    Original poster 18 posts


    The game is amazing, but this bugs ruin the game fun. Till now I've spend 30h + just for fishing.... and still didn't finish the quest because they don;t spawn.

  • tagger2009
    1 posts

    I have the same issue, this really needs to get fixed.
    Thank you for starting this thread!

  • moriatii
    53 posts

    All Zealots and all Order members, bar the Father completed, but no final clue from Hytham, is there a work around or like most of yu have I just wasted a fair amount of time playing this game.

  • killbill9191
    18 posts
    This post is deleted!

Suggested Topics