ubisoft discussions


  • locked topic_solved [RESOLVED] Unable to start "The Poor Fellow-Soldier" / reveal The Father on the Order tree | POST HERE

    58 likes/1047 replies/77560 views
    ubisoft:x-posts, 4

    @cosolici UPDATE: when returning to the village - after finishing the quest line from Hamtunscire "The prophecies of the king" - Hytham waits for me outside to the town hall and gives me the "Poor fellow soldier" quest.

    Seems the questline is gonna be fixed from now on in a way that will allow me to finish the game. (Yaaaay!)
    So for me it seems that the bug (since November) was "Hamtunscire contract option" not appearing on the alliance map.... (grrrr)

  • Odyss122
    ubisoft:x-posts, 4

    @cosolici Nothing has changed in my game, I still can't start the mission with the father of the Order, even though I have everything done

  • former_user
    ubisoft:x-posts, 0

    Try to travel to Norway and talk to the ex king then back to randvi. She should say Sigurd want to talk to you and that will start his quests.

  • marcbryan
    ubisoft:x-posts, 8
  • Notori_and_Coby
    ubisoft:x-posts, 1

    Same issue. During my first attempt I killed all the order members and zealots, handed in the "15" medallions, and it triggered the dialogue with Hytham as if I had already killed Aelfred. Then I went and completed the endgame in Hamtunscire and Norway (and Modern Day). Came back to town, upgraded the town to Level 6. Did the wedding. Really tied everything else up and the quest wouldn't activate.

    Second attempt. I went back to a save before I killed the remaining order members. Went and did the endgame stuff first. Came back to England. THEN killed the order members and zealots. Went back and Hytham still didn't activate the quest. I tried handing in the "15" medallions again and it went through the same dialogue as before as if I killed Aelfred.

    Completely broken.

  • Odyss122
    ubisoft:x-posts, 4

    @nikoladze85 I did the whole plot, I still have a mission with the father of the order that I can not launch because I have already given all the medallions.

    You probably mean a mission with a sigurd in norway. Where are we going with Sigurd to the Hordafylke region.

  • ThePainTrain69
    ubisoft:x-posts, 1

    Having the same issue, 2 months later.

    Is there going to be a fix?

    The bug only occurs if you talk to hytham after killing every order member except the father, This includes zealots, before you pledge to the last region ( i believe its called hundenscire or something like that)

    Anyways there wont be any conclusion or continuation after the pledge is complete, you cant accept any quest from hytham as the dialogue option never appears.

    Please fix this as it is the only thing holding me and all these people from finishing the game.

  • UplayMacAllen
    ubisoft:x-posts, 9

    No questions in my journal, 100% map completion, I know what's supposed to happen but I run in and out of my lodge and still no advancement. I'd really like to finish the game. Any progress on this bug?

  • D4rKy26
    ubisoft:x-posts, 64

    Is this going 2b a never endng story ubisoft?
    When are we going to get a fix is it even possible to fix this bug, if so please enlighten us.

  • tokajero32
    ubisoft:x-posts, 21

    i hope the guys in technical team fix this soon, i did this quest today, i had no bug at all finding *father*. hytham was outisde the main hall. I spoke to him and all good. i dont get it at all, in the entire game i didnt get any bug at any quest except daughters and cloak bug. I dont get it all what is happening. and they are suppose in 2months or so to release the next expansion with all those problems. god help us!

  • tokajero32
    ubisoft:x-posts, 21


    there is an opened thread weeks ago for this problem , no need to create a new thread, post there and wait for the fix

  • JoannaM95
    ubisoft:x-posts, 3


    Is there ANY update on this? It has been months, and loyal customers and fans are growing frustrated and weary.

    What do you need from us to find a solution to this issue? How can we help?

  • Marvel4425
    ubisoft:x-posts, 1

    The “Poor-Fellow Soldier” quest bug with the Order Medallions! The only quest stopping me from getting Thor’s full gear set. People have been reporting this problem for more than a month.

  • PhoenixFury2211
    ubisoft:x-posts, 11

    Another user to add to the ever-growing pile of bugged games. I'm in the same boat as many above, completed the whole map, killed all the Order members (except the Father), completed all quests, but I haven't received the "Poor Fellow Soldier" mission.

    I was able to give Hytham 15 medallions with two Order members (plus the Father) still remaining, and now the game thinks I've completed the assassinations.

    Even after Eivor continually spawning in drunk, even after my bow getting downgraded and not being able to find fabric to upgrade it, I was absolutely loving this game. Until this point. It's absurd that this still hasn't been fixed after the game has been available for two months. Get your act together please Ubisoft.

  • KingSpawn1979
    ubisoft:x-posts, 4

    I read about that Bug where I can't get the final Hint/Quest for the Father.
    The only Solution I can find on the Web is to load an old Save.
    My only other Save is about 30 Hours back.

    Is there really no other Way to fix that?
    I have invested about 120 Hours into this Game to not be able to get to the final Order Guy?

  • saywhatmo
    ubisoft:x-posts, 1

    I had the same issue..it is not a Bug.
    After screwing around I found the solution. You need to do Brother's Keeper Quest.
    I had 14 medallions, couldn't get the Poor Soldier, so in Ravensthorpe I did a few local quests, the Reda one where you read the translation, upgraded settlement to level 6, the Ubba quest and THEN magically I got a notice that Sigurd wanted to speak with me. Went back to Norway with him, did the quest..which is a huge part of the story.
    Eventually ended up back in Ravensthorpe, talked to Randvi and a new section of Hamutshire opened up again that needs to be done, the map appeared incomplete again.
    Hope this helps, but there is no glitch...except maybe figuring out how to trigger the Brother's Keeper Quest

  • Moosable
    ubisoft:x-posts, 1

    @saywhatmo except that this is not the bug. We have all done the full story, except the final scene. This is after the Gunnar wedding and we'll after the part where you go back to Norway with sigard.

    So yes, it's still a bug and still broken.

  • thegardener25
    ubisoft:x-posts, 198

    @kingspawn1979 I'm in the same boat as you pal. That's just about all I've got to do. I'm keeping the 'Mysterious Berzerker' for later, I've got 5 Hoard maps left which I'm eking out. But the bulk of what I've been doing the past 2-3 weeks is collecting resources to upgrade all my gear. There's Absolutely No Danger of me loading an old save. So if there's no other way to complete the Order. Then the game can stay unfinished.

  • Madeezy
    ubisoft:x-posts, 67

    @saywhatmo thumbs down x10. you haven't read the forum at all.

  • shaiwan43
    ubisoft:x-posts, 54

    The Father is revealed by progressing further in the story; not by killing order members per se.

Suggested Topics