Welcome to discussions

Quick Suggestions

  • Odyss122
    4 posts

    @nikoladze85 I did the whole plot, I still have a mission with the father of the order that I can not launch because I have already given all the medallions.


    You probably mean a mission with a sigurd in norway. Where are we going with Sigurd to the Hordafylke region.

  • Ubi-Woofer
    Ubisoft Support Staff 1029 posts
    Best Answer

    Hello @thefrozencreed - thank you for your reply to this thread.

    Could you please confirm the exact nature of the issue you are having? Are you unable to locate Hytham outside of the longhouse, or are you having a different issue, such as being unable to proceed due to having the incorrect number of medallions? If the former, please be advised that this issue has been considered resolved as of TU 1.3.0, and it could no longer be reproduced in the live game.

    Please refer to the information posted above by my colleague @Ubi-Borealis; can you please confirm that you have completed all of the prerequisites for starting "The Poor Fellow-Soldier", which are the following:

    • You have completed the full game, including the Hordafylke and Hamtunscire arcs
    • You have defeated all of the other Order members, with the exception of the Father


    If you find yourself unable to locate Hytham outside the longhouse and proceed, as previously directed, please send us a video showing the following:

    • Your completed quest log, showing that "Reporting on Hamtunscire" has been completed.
    • Your Order menu, showing that all members have been defeated except the Father.
    • If you have handed the medallions over to Hytham, please can you show us that you are unable to interact with him in front of the longhouse. If you haven't yet handed your medallions over to Hytham, please can you do this to see if this causes him to move in front of the longhouse.


    Thank you in advance for your cooperation and any information that you provide. We'll be happy to reopen the the investigation into this issue if the information needed is received. 🙂

    Official Response
  • ThePainTrain69
    1 posts

    Having the same issue, 2 months later.

    Is there going to be a fix?

    The bug only occurs if you talk to hytham after killing every order member except the father, This includes zealots, before you pledge to the last region ( i believe its called hundenscire or something like that)

    Anyways there wont be any conclusion or continuation after the pledge is complete, you cant accept any quest from hytham as the dialogue option never appears.

    Please fix this as it is the only thing holding me and all these people from finishing the game.

  • UplayMacAllen
    9 posts

    No questions in my journal, 100% map completion, I know what's supposed to happen but I run in and out of my lodge and still no advancement. I'd really like to finish the game. Any progress on this bug?

  • D4rKy26
    64 posts

    Is this going 2b a never endng story ubisoft?
    When are we going to get a fix is it even possible to fix this bug, if so please enlighten us.

  • tokajero32
    21 posts

    i hope the guys in technical team fix this soon, i did this quest today, i had no bug at all finding *father*. hytham was outisde the main hall. I spoke to him and all good. i dont get it at all, in the entire game i didnt get any bug at any quest except daughters and cloak bug. I dont get it all what is happening. and they are suppose in 2months or so to release the next expansion with all those problems. god help us!

  • tokajero32
    21 posts

    @uplaymacallen

    there is an opened thread weeks ago for this problem , no need to create a new thread, post there and wait for the fix

  • JoannaM95
    3 posts

    @ubikobold

    Is there ANY update on this? It has been months, and loyal customers and fans are growing frustrated and weary.

    What do you need from us to find a solution to this issue? How can we help?

  • Marvel4425
    1 posts

    The “Poor-Fellow Soldier” quest bug with the Order Medallions! The only quest stopping me from getting Thor’s full gear set. People have been reporting this problem for more than a month.

  • PhoenixFury2211
    10 posts

    Another user to add to the ever-growing pile of bugged games. I'm in the same boat as many above, completed the whole map, killed all the Order members (except the Father), completed all quests, but I haven't received the "Poor Fellow Soldier" mission.

    I was able to give Hytham 15 medallions with two Order members (plus the Father) still remaining, and now the game thinks I've completed the assassinations.

    Even after Eivor continually spawning in drunk, even after my bow getting downgraded and not being able to find fabric to upgrade it, I was absolutely loving this game. Until this point. It's absurd that this still hasn't been fixed after the game has been available for two months. Get your act together please Ubisoft.

  • KingSpawn1979
    4 posts

    I read about that Bug where I can't get the final Hint/Quest for the Father.
    The only Solution I can find on the Web is to load an old Save.
    My only other Save is about 30 Hours back.

    Is there really no other Way to fix that?
    I have invested about 120 Hours into this Game to not be able to get to the final Order Guy?

  • saywhatmo
    1 posts

    I had the same issue..it is not a Bug.
    After screwing around I found the solution. You need to do Brother's Keeper Quest.
    I had 14 medallions, couldn't get the Poor Soldier, so in Ravensthorpe I did a few local quests, the Reda one where you read the translation, upgraded settlement to level 6, the Ubba quest and THEN magically I got a notice that Sigurd wanted to speak with me. Went back to Norway with him, did the quest..which is a huge part of the story.
    Eventually ended up back in Ravensthorpe, talked to Randvi and a new section of Hamutshire opened up again that needs to be done, the map appeared incomplete again.
    Hope this helps, but there is no glitch...except maybe figuring out how to trigger the Brother's Keeper Quest

  • Moosable
    1 posts

    @saywhatmo except that this is not the bug. We have all done the full story, except the final scene. This is after the Gunnar wedding and we'll after the part where you go back to Norway with sigard.

    So yes, it's still a bug and still broken.

  • thegardener25
    111 posts

    @kingspawn1979 I'm in the same boat as you pal. That's just about all I've got to do. I'm keeping the 'Mysterious Berzerker' for later, I've got 5 Hoard maps left which I'm eking out. But the bulk of what I've been doing the past 2-3 weeks is collecting resources to upgrade all my gear. There's Absolutely No Danger of me loading an old save. So if there's no other way to complete the Order. Then the game can stay unfinished.

  • Madeezy
    67 posts

    @saywhatmo thumbs down x10. you haven't read the forum at all.

  • shaiwan43
    54 posts

    The Father is revealed by progressing further in the story; not by killing order members per se.

  • Petteflet88
    346 posts

    Still not fixed and no reaction. HAHAHAHAH, this ubisoft sucks

  • Petteflet88
    346 posts

    Hahahahahahahahahahahaha, i am laughing so loud, that this company is not capable of reacting nor fixing. 2 months, two!!! 😅😅 and they still want you to have patience. Get the F out of here.

  • thegardener25
    111 posts

    @shaiwan43 Yep! There's no more story left to do. I'm done!

  • shaiwan43
    54 posts

    @thegardener25

    You went back to norway, completed Sigurds arc, then returned to England, and then completed the additional Hamtuncshire arc, then you got the letter from Hytham from poor fellow christian soldier?

  • thegardener25
    111 posts

    @shaiwan43 I've completed all available arcs. I can't even remember the last time I spoke to Hytham. I just checked in & there's nothing. I have zero options to pursue in the game!

Suggested Topics

Community Details

107
Online
192.5k
Users
32.4k
Topics
162.3k
Posts