Welcome to discussions

Quick Suggestions

  • shaiwan43
    54 posts

    @thegardener25

    Well; if you've been stuck for a good long while and can't recall what happened last, it is difficult to know if you can be helped.

    But basically you need to do the ending like so:

    1. Go with Sigurd to Norway
    2. Finish everything with Sigurd/Basim
    3. Do Modern-Day Sequence
    4. Return with Sigurd to England and complete Sigurd's story
    5. Then you start the Hamptunscire arc (it's an extra final and special alliance map section for the very end of the game)
    6. Then you complete part 1 of the hamptunscire
    7. Then you get a second part Basim has a note for you then you go to the final location


    Also you need to have killed every order member but the Father.

  • Ubi-Woofer
    Ubisoft Support Staff 1029 posts
    Best Answer

    Hello @thefrozencreed - thank you for your reply to this thread.

    Could you please confirm the exact nature of the issue you are having? Are you unable to locate Hytham outside of the longhouse, or are you having a different issue, such as being unable to proceed due to having the incorrect number of medallions? If the former, please be advised that this issue has been considered resolved as of TU 1.3.0, and it could no longer be reproduced in the live game.

    Please refer to the information posted above by my colleague @Ubi-Borealis; can you please confirm that you have completed all of the prerequisites for starting "The Poor Fellow-Soldier", which are the following:

    • You have completed the full game, including the Hordafylke and Hamtunscire arcs
    • You have defeated all of the other Order members, with the exception of the Father


    If you find yourself unable to locate Hytham outside the longhouse and proceed, as previously directed, please send us a video showing the following:

    • Your completed quest log, showing that "Reporting on Hamtunscire" has been completed.
    • Your Order menu, showing that all members have been defeated except the Father.
    • If you have handed the medallions over to Hytham, please can you show us that you are unable to interact with him in front of the longhouse. If you haven't yet handed your medallions over to Hytham, please can you do this to see if this causes him to move in front of the longhouse.


    Thank you in advance for your cooperation and any information that you provide. We'll be happy to reopen the the investigation into this issue if the information needed is received. 🙂

    Official Response
  • KingSpawn1979
    4 posts

    I have finished all Story Arcs, all of England is mine, and I killed all Order Members.
    Still no final Quest for the Father.

    The first Reports of this specific Bug are from November. Still no Fix on that...

  • flyinpiranha
    3 posts

    Same issue (Digital XSX version)

    Completed everything but I must have at one point been bugged with too many medallions and turned them in and got Thor's Cape. Honestly can't remember when I did that, a while ago. Now the entire map is completed, wedding over, and I have 3 extra medallions in my inventory and Hytham won't give me the final quest. Aelfred stuck on 5/6 clues and still "hidden".

  • texasredfox
    1 posts

    @flyinpiranha I have 10 medallions still sitting in my inventory after turning them all in before. Also stuck on 5/6 clues for The Father. I just finished burning down Werham with Guthrum, completed that quest, and now my quest log is empty. No Hytham for me, either. Please, @Ubisoft, why aren’t you fixing this?!?

  • retsam89
    3 posts

    !!! SPOILER ALERT !!!

    Just checking in, that I've got the same problem:

    I've just "finished" the game: went back to Norway, done everything with Sigurd -> came back, pledged to Hamtunscire -> -> killed all the Order members (except the Father) -> done everything, the king escaped and I didn't kill his soldier after beating him -> back to Randvi, where I said that everything went fine and the king is also dead ([censored] no.1 ??? - you have just spoiled the whole story, thanks Ubisoft!) , and that's all, I can explore -> ??? ??? ??? -> the Father is sitll grayed out and I can't get the quest from Hytham, so the game has no ending and I've got 140 hours in it, very-very close to full 100%.

    How can this happen? When will you release the patch?

  • blackpit_21
    2 posts

    I have the assassin's creed valhalla in my new PS5.

    I want the platinum trophy but
    "The letter" assignment glitched and I cant find the father of the order... Please tell me if there is any way because i am a trophy hunter and i get everything else..... 91% of the game driving me crazy!!!

  • FISHMANGRANDAD
    4 posts

    @yoitsdougal Yes i have the same problem, i cant finish essex as i cant follow birstan on the boar hunt, i have killed everyone on the game done every single mission mystery and artifact, i know the father is alfred but cant get his key for his office or get one last mission with sigurd to get thors hammer and spear, im stuck and dont have any saves to go back on its doing my head in

  • blackpit_21
    2 posts

    Same issue to me in the PS5 version.

    I want the platinum trophy but
    "The letter" assignment glitched and I cant find the father of the order... I get everything else.....The 91% of the game driving me crazy!!! 132 worthless hours

    Why are you not trying to fix it?

  • Sjaanbright85
    1 posts

    Also have the problem of ps4 and on ps5 both the same.

    - hytham stays in his hut;
    - i have zero quests left;
    - the father still needs 1 clue before he is exposed;
    - i have done all the rest in the game.

    This is so frustrating after 100+ hours.

    Does anyone know if there was a reaction of ubisoft or if there is another solution?

  • retsam89
    3 posts

    @sjaanbright85

    I could load a bit earlier state, where I still had the order medalions, did some other things after the last quest (like some mysteries, maxing out the settlement, 2 daily quests, etc.) and after some fast travel, and saving and reloading, and feasting and sleeping, somehow Hytham appeared in front of my longhouse and gave me the last quest. But I think it was simple pure luck 😄

    Btw. in the meantime I got the quest to celebrate a wedding, which can stuck because to finish it you will have to talk to Randvi, but the "speak" option wont appear in front of her, so... stuck. After the 3rd loading of eariler states, and doing the quest again, I could get out of that and nearly deleted the game. 🙂

  • rorobfo
    38 posts

    @thegardener25 same here, bro. just upgrading gear and hoard maps nd fishing left. stuck at 92% The Father not revealed (missing story progress, but there is no story left). even have some left over order medallions in inventory which i cant turn in.
    guess i gonna wait until there is a game plus before i can finish the game

  • Saint.Balthazar
    19 posts

    Encountering the same issue as well

  • Samhyde1591
    1 posts

    wont let me give Hytham the remaining medallions. I have 9 left over, won’t receive the quest the poor Fellow solider to reveal King Harold

  • Asgardian02
    1932 posts

    @samhyde1591

    ffs massive spoiler just in the title man 😞

  • Saint.Balthazar
    19 posts

    Yo, any update on this one? 😞

  • tommythagun
    1 posts

    This is the only thing that is stopping 100% completion......

  • KingSpawn1979
    4 posts

    It's absolutely ridiculous. I remember them speaking about "Everything will be better from now on" after that Breakpoint Desaster.

  • ziggurcat
    167 posts
  • ziggurcat
    167 posts

    "The Father not revealed (missing story progress, but there is no story left)"

    spoiler

  • Gynnyper
    1 posts

    I killed all the zealots and order members, but Father. It says 5/6 clues. Handed in all but 14 medallions to Hytham. Because he's not in the hidden ones bureau in my settlement. No clue where he is. So I can not progress any further. Can not do the final mission. Been told it is a major glitch. What it is, is a major disappointment.

Suggested Topics

Community Details

105
Online
192.5k
Users
32.4k
Topics
162.3k
Posts