Welcome to discussions

Quick Suggestions

  • ziggurcat
    167 posts

    @diabetic_man97 which bug?

  • Ubi-Woofer
    Ubisoft Support Staff 1042 posts
    Best Answer

    Hello @thefrozencreed - thank you for your reply to this thread.

    Could you please confirm the exact nature of the issue you are having? Are you unable to locate Hytham outside of the longhouse, or are you having a different issue, such as being unable to proceed due to having the incorrect number of medallions? If the former, please be advised that this issue has been considered resolved as of TU 1.3.0, and it could no longer be reproduced in the live game.

    Please refer to the information posted above by my colleague @Ubi-Borealis; can you please confirm that you have completed all of the prerequisites for starting "The Poor Fellow-Soldier", which are the following:

    • You have completed the full game, including the Hordafylke and Hamtunscire arcs
    • You have defeated all of the other Order members, with the exception of the Father

    If you find yourself unable to locate Hytham outside the longhouse and proceed, as previously directed, please send us a video showing the following:

    • Your completed quest log, showing that "Reporting on Hamtunscire" has been completed.
    • Your Order menu, showing that all members have been defeated except the Father.
    • If you have handed the medallions over to Hytham, please can you show us that you are unable to interact with him in front of the longhouse. If you haven't yet handed your medallions over to Hytham, please can you do this to see if this causes him to move in front of the longhouse.

    Thank you in advance for your cooperation and any information that you provide. We'll be happy to reopen the the investigation into this issue if the information needed is received. 🙂

    Official Response
  • calLHimHero
    1 posts

    @ubiwan How can we send you a copy of our saves if we are playing on consoles ? ... it is time to hiver us a solution for this bug

  • Diabetic_Man97
    14 posts

    the bug that you can't have access to the last quest "the poor fellow soldier" to know the father's identity

  • ziggurcat
    167 posts
  • chucksstuntman
    1 posts

    @diabetic_man97 no, I am on the game now after today's update and nothing changed. still bugged.

    4 posts

    @killbill9191 totally 100% agree on this lets boycott them, and i want me money back

  • Diabetic_Man97
    14 posts

    i know that but so many players have the same issue... Hytham doesn't appear near the longhouse (he stays in the Hidden one's Bureau) even if I have complete all territories and complete all arcs! The bug happens when you complete the quest "breaking the Order" before knowing who the father is... BUT does @Ubisoft fixed this bug? This is my question

  • Diabetic_Man97
    14 posts

    Ohh God...
    Thx Pal!!

  • ScabbyTramp
    5 posts

    I've been stuck for months now. It won't let me progress .

    I've got all hidden one codex , I've seen the little boy in the tent and done his quest.

    I've done all quests .
    I've killed all orders .

    I've done all alliance map .
    All of asgard and the other sub story.

    What's going on ?!?!?

    It says there should be someone out the camp longhouse to start the last order quest. But he's always in his house , where you get him codex.

  • LittleYanYay
    7 posts

    @alexandru27p Same here, post 1.1.1 update, attempted to kill final Order member that should reveal the 6/6 clue for The Father and no luck. STILL BROKEN! @ubisoft when will this be fixed. Can't complete order progression, can't get Thor's cape, can't get Mjolnir... really is aggrevating!

  • ziggurcat
    167 posts
  • ScabbyTramp
    5 posts

    Same issue. Can't get last clue

  • ScabbyTramp
    5 posts

    This has bugged for me for months.
    The game is 99% . What the actual monkey [censored] are they drinking.

    Just fix the dam quest.
    Make it a chat option. Or force it on everyone.

    It's not rocket science . If you can add DLC and event quests. Just bloody add the story quest as a click able option . Problem solved.

    I've done all maps . All medallions handed in.
    I have cape. I have thors set and hammer.

    Like the rest . I can't get the last dam.father clue , because you lot can't write code correctly.

    Sort it out, or I'll pray a civil.case.will be brought against you .

  • Frankie_Drums
    12 posts

    Just change the achievement/trophy requirements so it only requires 45/46 member revealed. Boom, game is complete, and we can move on.

  • ajscott819
    9 posts

    First I had the Sons of Ragnar Ubba bug. Spent my time exploring and clearing the map. Now I have this bug. I thought it odd when Hytham gave away spoilers early, but I wasn't aware of this issue. I thought it was poor continuity.
    After over a month of not be able to progress I am stuck again.
    I was really hoping this patch fixed it, but no. I have everything except the last clue. Well everything, but the last clue and the coastal fish.
    Stupid fishing. Fix that too please

  • PhoenixFury2211
    10 posts

    Still not fixed after 1.1.1. Absolutely unbelievable.

  • Valgoerad
    1 posts

    Same problem here. Xbox Series X. Whole England conquered (100% of all dots on the map cleared too), father left with last uncovered clue.

  • eightroadlolz
    1 posts

    Spoiler Alert
    Spoiler Alert
    Spoiler Alert

    i cant proc The father quest becus the number of trinket somehow over droped,i got all gear b4 the father quest start

  • guest-LmWt2ELH
    1 posts

    I have the same problem on XBSX. This is infuriating not being able to finish the game after 120+ hrs in and with 92% completion.
    #PLSFIX Ubisoft!

    My progress went exactly as previously described. Hytham allowed me to give him the medallions and rewarded me Thor's cape without me killing the last member of the order which I didn't even realize I was missing. I can't give him the last medalion now and get the last hint for the Father.

  • Quackable
    3 posts

    @ubikobold It's Jan 15 now, still no update on this?

Suggested Topics

Community Details