Welcome to discussions

Quick Suggestions

  • nuglife22
    26 posts

    @kaks_187 More people with this problem here https://discussions.ubisoft.com/topic/84794/last-order-member-bug-the-father-missing-clue/5 Ubisoft is ignoring this issue.

  • Ubi-Woofer
    Ubisoft Support Staff 1061 posts
    Best Answer

    Hello @thefrozencreed - thank you for your reply to this thread.

    Could you please confirm the exact nature of the issue you are having? Are you unable to locate Hytham outside of the longhouse, or are you having a different issue, such as being unable to proceed due to having the incorrect number of medallions? If the former, please be advised that this issue has been considered resolved as of TU 1.3.0, and it could no longer be reproduced in the live game.

    Please refer to the information posted above by my colleague @Ubi-Borealis; can you please confirm that you have completed all of the prerequisites for starting "The Poor Fellow-Soldier", which are the following:

    • You have completed the full game, including the Hordafylke and Hamtunscire arcs
    • You have defeated all of the other Order members, with the exception of the Father


    If you find yourself unable to locate Hytham outside the longhouse and proceed, as previously directed, please send us a video showing the following:

    • Your completed quest log, showing that "Reporting on Hamtunscire" has been completed.
    • Your Order menu, showing that all members have been defeated except the Father.
    • If you have handed the medallions over to Hytham, please can you show us that you are unable to interact with him in front of the longhouse. If you haven't yet handed your medallions over to Hytham, please can you do this to see if this causes him to move in front of the longhouse.


    Thank you in advance for your cooperation and any information that you provide. We'll be happy to reopen the the investigation into this issue if the information needed is received. 🙂

    Official Response
  • Kaks_187
    17 posts
    • https://imgur.com/a/sEurhxK is where im at, game is finished, all quests completed, 44/45 dead cant seem to trigger the final reveal for The Father, i got a letter from poor fellow soldier of Christ about 50% thru the game, asked me to speak to Randvi for more intel but could never speak to her, it ended up disappearing when i finally took Wincestre was not aware at the time that this was the final reveal quest, so im now stuck at power level 400 + 20 mastery and over 100 hours of gameplay but cannot finish off the order, and i refuse to roll back 40+ hours of game play, please find a way to patch this


  • nuglife22
    26 posts

    That's exactly my situations. Trophies sitting at 91% because this one massive glitch. Dozens of other people in the same spot according to comment sections on trophy guides and youtube videos. That poor fellow soldier quest triggers far too early and then doesn't lead anywhere and never shows up again. I still have 12 medallions in my inventory even though I was able to turn in enough for Thor's Cloak. I've never experienced a game with this many massive bugs.

  • MrLaryBob
    1 posts

    I've completely beaten the game. Found every single wealth, artifact and mystery in the whole game. Also killed every zealot and order member excluding the father. I've turned in the 15 medallions and haven't received the final quest to reveal the father. I've fast traveled and returned and also slept several days ingame. The poor soldier mission won't be activated due to Hytham staying in his hut and not going to to longhouse to give me the option to start it. Is this common and is ubisoft going to do something to fix this problem?

  • Jaydenfisher28
    1 posts

    Since you can get the Thor armor cloak before actually finishing the main story by killing the zealots and the "free" order members.
    This means it messes up the "the poor fellow soldier" quest at the end. Plus you'd have 4 spare medallions left over just in your inventory because of the reward requirement number is low and doesnt take all the medallions.

  • D4rKy26
    64 posts

    @ubi-swaggins please look into this thank u.
    Also it might be a good idea to put this in the megathread and merge everything in on thread i see multiply threads with these order of the ancient problem, most of them are similar.

  • Alexandru27p
    Original poster 18 posts

    @nuglife22 and I have problems with the fishs, I farmed for 10h and I didn't catch almost anything, most of them disappear. And achievement "overdesing II" doesn't pop up, I've made the same thing for 2h.

  • Assassino89NL
    12 posts

    this problem is because we gave the 15 medallions before finishing Hamtunscire and story, game doesn't register it, only if you gave the medallions after Hamtunscire. its stupid indeed, i'm on the same boat

  • Kaks_187
    17 posts

    Will this be patched or at least be acknowledge? i feel this is really game breaking since i cannot close the game out after all that play 😞

  • Soul_Slayer98
    11 posts

    Have the same issue:(

  • D4rKy26
    64 posts

    @kaks_187 i hope so i didnt touch the game for a few days now because of this.

  • Kaanyr_Vhok
    1 posts

    Hello Team, I have completed all regions including Hamtunscire, killed all order memebers and I have only 5 clues regarding the Father.
    I have killed all order members and collected medalions before finishng main story line, and delivered those to Hytham.
    According to youtube walkthroughs, I should receive a new letter from Hytham with last quest to reveal father idenitiy and get achievment.
    Unfortunatlety nothing happens - why?
    Playing on PS4, patch 1.04

  • UplayMacAllen
    9 posts

    Finished the game, got the message that England is pacified, town is level 6, every order member/zealot is dead but the last one. I'm 5/6 of "The Father", no quests in the log, no quests available, 100% completion of every zone. And I'm standing in town with nothing else to do. Hytham has nothing for me. Did some googling and everyone says I should be able to talk to Hytham and get a quest, but there's nothing. Suggestions? Ideas? Help?

  • Anmixx
    21 posts

    Same problem. In postgame after the simulation and Hytham not giving quest for last clue. I've tried leaving and coming back, sleeping nothing triggers the quest.

  • nuglife22
    26 posts

    I doubt Ubisoft will ever fix this. They're probably too busy making more microtransaction armor packs to sell.

    So I went ahead and loaded an old save from before I turned in the "Breaking the Order" quest for Thor's Cloak and tried finishing the game again without ever turning in the quest/medallions. Still had about 14-15 order members to kill. I rushed through 7 or 8 regions as fast as I could on super easy difficulty. Took about 10 hours. Again, the game was allowing me to turn in the quest long before I finished killing off all the order but I just ignored it. I left 11 order members untouched, still alive as I went into the very last region of Hamtunscire. Finished that last region and fast traveled back to Ravensthorpe. As I ran over to deliver some bad news, 11 red icons with "order member eliminated" started flashing on the screen one after another. It just automatically killed off those 11 order members for me. I ran up to talk to Randvi to tell her about Hamtunscire but before I get to her I see Hytham chillin outside the longhouse with the poor fellow soldier quest. So this must be yet another massive glitch but this one worked very much in my favor.

    So this is a pathetic option to try to get the trophy if you really want it bad enough. I'd still like them to fix this since I won't be using this save file.

  • Anmixx
    21 posts

    @nuglife22 so as long as I have medallions to turn in he'll give me the quest?

  • nuglife22
    26 posts

    @anmixx As long as you haven't turned in "Breaking the Order" it seems. Though I don't know anything for sure, this is all a mess. Ubisoft needs to figure out a way to properly trigger Hytham's last quest just based on all order members aside from the father being dead.

  • Anmixx
    21 posts

    @nuglife22 Haven't turned that one in yet. So that can't be it then. Thanks for the reply. Yes, I agree they need to get on these bugs. I really like the game and the quests are all great in how they designed them...if they work.

  • Anmixx
    21 posts

    @anmixx So I went back to the Alliance map and Hamptonshire hadn't been completed. Thought for sure I had done that since the map is cleared but guess not. So running through that Arc now to see if that is the problem.

Suggested Topics

Community Details

68
Online
193.9k
Users
32.8k
Topics
163.9k
Posts