Welcome to discussions

Quick Suggestions

  • zambone
    3 posts

    @alexandru27p I killed Hrothgar but he did not dropped a clue... I now can't find/kill The Oil and therefore also stuck on 5/6 for The Father.

  • guest-xSh0e421
    1 posts

    I have finished all missions and all of the order apart from the father it wont give me the last clue. Iv been to speak to hytham and I cant start nothing gutted I cant finish the game 😑

  • xIFoxHound
    49 posts

    @greattyler unfortunately the only option is to load up a previous safe if you identify what’s bugged...in my case one of my kills hasn’t registered I think because there is a scroll icon instead of the image of the Zealot (but its scored out and it’s saying “defeated” so I guess it did register?) also if you got Thor’s cloak before the quest starts then it’s bugged...which also happened to me but I just thought that was normal to get the cloak before you identify the father...being around 3 months later and yet here we are still 😕

  • catchyaup
    13 posts

    @ike_n_ike I spent $180 of my money on this [censored], and a $30 book only to have the main bad guy run away like a [censored] and not be able to kill him. BAGH how disappointing. Not to mention all the other bugs. And this stupid SEASON rubbish delayed release of content I have paid for. This is not how this franchise should be.

  • zambone
    3 posts

    @xifoxhound Well, I killed him more than a week ago so finding that save is not an option for me... also my saves corrupted a while back and I lost about 5-6 hours gameplay. I bet that's when it went wrong.

  • Madeezy
    67 posts

    @kopfsmertzz Not buying DLC until it's fixed. Everyone should draw that line in the sand. Everyone who's viewed this post or commented.

  • grantkelleher
    3 posts

    @xifoxhound thanks no i didnt get the poor fellow soldier mission jus have to wait for bug to be fixed hopefully

  • Josh10muir
    2 posts

    By the sound of things to fix this problem I have to go back and not give Hytham the Medallions until I have finished every settlement arc and I will then be able to get the clue for the Father. Is this true? Pain in the [censored] having to go back so many hours of game play!

  • mrtmd747
    6 posts

    @josh10muir I can confirm this is 100% the case as i just finished doing this today and managed to get him discovered and got the associated 'poor fellow soldier' quest too. It's ok if you give him some medallions but not the stage where it's 15 of them. I had to go back about 5-6 hours of gameplay, luckily had a save where i still had 11 medallions not turned in. Did the arc with Sigurd then the arc for Hamtunscire with the final battle and after Hytham was there waiting for me next to the longhouse. Hope this helps..

  • Josh10muir
    2 posts

    @mrtmd747 Aw thanks. I just tried this though, still didn’t work for me unfortunately,Im left with The order and settlement level 6 quest. When I give Hytham the 11 medallions, still nothing happens. Hytham stays in house anddont have the option for Sigurd, glowsecestrescire or Hamstunscire, and I don’t even have option to give him the medalions as I only have 14. So annoying, they need to fix this bug ASAP!

  • Froggyv86
    3 posts

    @ubiwan Yess please ive been stuck on this for a while now would love to finish and get the season pass

  • guest-jNVsF2Qo
    1 posts

    I have killed all 44 members of the order and completed the full story. Hytham wont give me the quest to find father. I turned in my medalliona before cometing story which I think glitched. Is there any fix?? Please help.

  • Ubi-Wan
    Ubisoft Support Staff 636 posts

    @guest-jnvsf2qo Hello there! I'm happy to let you know our teams were made aware of this issue and a solution has been discovered! This solution will be implemented within a future patch, thus we ask you stay tuned to our public channels such as the official Assassins creed twitter, and the dedicated forum page for the game, where all the latest information is posted!

    Official Response
  • semplerfi
    8 posts

    Sorry to complain but, power level 434 with 265+ hours in. Picking up what little small stuff is left now. I will not purchase any DLC or any other shiny stuff until this bug is fixed. Spent $$ on this thing and three months later no fix. We just had a Tuesday pass with no goodies. Com-on man... 😉 😉

  • guest-JOPA5hip
    4 posts

    February now.

    Sad, I really enjoyed this game. When I encountered the ‘can’t complete the Order of Ancients’ bug, I was disappointed. It became frustrating to realize that I cannot complete the game. Then when I discovered Ubisoft has known about this for nearly three months and done nothing, I was disgusted. My neighbour was going to buy this game, when I told him about the bug, he didn’t buy it.

    we need to spread the word.

  • crowe76
    9 posts

  • xrayspex_73
    155 posts


    They certainly seem to be prioritizing the MTX store over actually patching the game... when was the last patch anyways?

  • Ryankeeton1
    3 posts

    2/12/21 I have the same problem. All quests done. Literally nothing in quest que but can't access the last member of the order. Says 5/6 clues. I can' believe I can't finish the game. You would think a bug that won't allow you to complete a game after putting so many hours in to it would be addressed, but I think they are too busy focusing on more pay to play expansions. This is quite frustrating.

  • Ryankeeton1
    3 posts

    @tyleremma2015 This bug is still not fixed. I wish I had known that I wouldn't be able to finish this game before I started it.

  • Ryankeeton1
    3 posts

    @dreadfullydark Did the same today. I am having this issue on PC and to have them just say "We dont' know when it will be fixed but be assured we are working on it" is not enough nearly three months after this bug was first reported. Say what you will about CyberPunk but at least i could finish it. And I did, 3 times. Guess it will be back to that game for time 4.

Suggested Topics