Welcome to discussions

Quick Suggestions

  • Madeezy
    67 posts

    Same as of 2-22-21

  • Ubi-Woofer
    Ubisoft Support Staff 1042 posts
    Best Answer

    Hello @thefrozencreed - thank you for your reply to this thread.

    Could you please confirm the exact nature of the issue you are having? Are you unable to locate Hytham outside of the longhouse, or are you having a different issue, such as being unable to proceed due to having the incorrect number of medallions? If the former, please be advised that this issue has been considered resolved as of TU 1.3.0, and it could no longer be reproduced in the live game.

    Please refer to the information posted above by my colleague @Ubi-Borealis; can you please confirm that you have completed all of the prerequisites for starting "The Poor Fellow-Soldier", which are the following:

    • You have completed the full game, including the Hordafylke and Hamtunscire arcs
    • You have defeated all of the other Order members, with the exception of the Father

    If you find yourself unable to locate Hytham outside the longhouse and proceed, as previously directed, please send us a video showing the following:

    • Your completed quest log, showing that "Reporting on Hamtunscire" has been completed.
    • Your Order menu, showing that all members have been defeated except the Father.
    • If you have handed the medallions over to Hytham, please can you show us that you are unable to interact with him in front of the longhouse. If you haven't yet handed your medallions over to Hytham, please can you do this to see if this causes him to move in front of the longhouse.

    Thank you in advance for your cooperation and any information that you provide. We'll be happy to reopen the the investigation into this issue if the information needed is received. 🙂

    Official Response
  • PeterBolinder
    2 posts

    This might not be the case for all of you who still have this issue, but I thought I was stuck as described in this thread. But, going into Sigurds room (next to Randvi) started a new quest to progress further.

    There was nothing suggesting I had to go into his room, but that solved it for me, hopefully a few of you will benefit from that knowledge.

  • Hermes20052006
    3 posts

    Just now I've received the mission "the letter". After completing "King's prophecy" and before "Hampshire information". On arriving to the settlement, Hytham was waiting for me at the entrance of the communal house and gave the letter and "Christ poor soldier" mission appeared.

  • Dcgdavies
    7 posts

    Just installed the latest patches and tried again, Still not fixed for me. Guess it's back to not playing this and waiting to see if another "fix" comes out

  • Haldonir
    1 posts

    Alright so, first let me say that I had thought I was stuck in the same situation as everyone listed in this thread. This morning I decided to turn on the game and mess around a bit, hoping that someway the mission would trigger itself. I spoke with a few characters to move things along, then went and spoke with Randvi to see if she had anything for me, nothing prompted, so I opened up the map hoping something would show up and absolutely nothing. But then, here is what I did, I move the cursor over Wincestre, and clicked the "A" button on my Xbox controller, nothing happened, then all of a sudden I some how moved the cursor over Hamtunscire and bam, I get the quest to continue, I was like [censored] is going on here. The map wasn't showing any marker, there was absolutely no prompt at all, it just started the mission and I was able to proceed and complete the rest of the story line.

    I think at least for me, part of the confusion was, that the region marker that is used for Wincestre, is the same marker for Hamtunscire, therefore when you talk to Randvi, Randvi never gives you the option to select that from map...

  • Madeezy
    67 posts

    @haldonir Sounds like your user error. This is not the bug discussed in this forum.

  • iwajabitw
    23 posts

    Patch 1.1.2 has fixed this for me. Hytham was outside the longhouse.

  • OmniOnslaught
    2 posts

    I believe the problem is that it allowed me to do the Father mission earlier in the game but never gave me credit for the clue received. How do I fix this Ubisoft?

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts

    Hello all!

    Thank you all for continuing to update this thread with your reports and experiences with "The Poor Fellow-Soldier". I've reached out to the development team, who have provided me with this update.

    If you have not received the letter from Hytham to begin this quest, can you please let us know if you have completed the following:

    • Killed all other available order members with the exception of the Father
    • Have completed the Hamtunscire arc (the last quest is named "Holy Day")

    If you have met these requirements and Hytham has not yet provided you with the letter, please can you send us a video that shows your active quest log, your current quest log, and your Order menu. We can then pass this along to the development team for further investigation.

    If you have been able to complete "The Poor Fellow-Soldier" and "Breaking the Order," but the Father still shows as hidden in your Order menu, please can you send us an image that shows your completed quest log, and that the Father is still hidden. We can then pass these along to the development team for a closer look.

    @PeterBolinder - Thanks for sharing that going into Sigurd's room helped you to trigger a new quest. From my knowledge, this can trigger the Horadfylke arc, which you will need to complete before being able to receive the letter from Hytham.

    Thanks all! 😊

    Official Response
  • JDL2025
    18 posts

    @ubi-borealis i re did al areas and after completing all i got the letter and met with the father awesome sound track at the end of that rather moving actually.

  • Mirek285
    2 posts

    @ubi-borealis If I look on Alliance map, I have dagger on Hordafylke area (which I think i completed already, good ending with Sigurd in Ravensthorpe longhouse, Hordafylke on Alliance map is not completed. Alsto Hamtunscire area is not completed - i do not see check mark next to name and when i move cursor over the area, its not glowing on the map as other Area.

    If I look on completed quest in menu i see one quest without Name and description (maybe quest Holy Day?). I killed all other available order members with the exception of the Father.

    I am on PS4PRO, 180+hours played - frustrating. ALso after last update i cant talk with some NPC in settlement 😄 But thats another thread.

  • JDL2025
    18 posts

    So have you completed the quest In the halls of the slain by going back to Norway in Hordafylke with Sigurd? Then returned to England and completed the Kingdoms End and Holy day quests, it happens after these,

  • heimdaloz
    6 posts


    Any update on this issue. I have already restarted, due to another bug. Certainly don't want to have to do it again.

  • heimdaloz
    6 posts

    Is there any update on a fix for this glitch. I had to restart after a previous glitch but not prepared to do it again. Seem to have been reported a few time but is not listed in current issues list.

  • Ubi-Viral
    Ubisoft Support Staff 287 posts

    @heimdaloz Hey! Thank you for reaching out about the Poor Fellow Soldier issue you are having. Could you provide more information about the issue you are having?

    If possible a video of the issue would be most appreciated please.

    Official Response
  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @jdl2025 Pleased to hear you enjoyed the soundtrack and were able to get past this issue!

    @Mirek285 If possible, would you be able to send over the requested footage as Ubi-Borealis mentioned above showing your active quest log, your current quest log, and your Order menu please?

    @heimdaloz Similarly, can you also provide this footage so we can take a closer look at this with you?

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    This post is deleted!
    Official Response
  • Madeezy
    67 posts

    @ubi-borealis I already submitted this information in November. With videos and screenshots. None of the patches have fixed my issue. The only active quest I have is Breaking the Order, and now the River Raid one's. Going into the alliance map room does nothing.

  • Giergenlim
    1 posts

    After Killing all the orders members, I went to Hytham the mission The Poor Fellow Soldier of Christ won't appear. So, i can't get the Key to Kill the last member.

  • WhoCares78
    112 posts

    @giergenlim Did you finish the Hamtunscire story arc?

Suggested Topics

Community Details