ubisoft discussions

Quick Suggestions

  • DeathJudge89
    2 posts

    @madeezy Not for me. I just started the game up, last time being 4/27 and it still is not fixed. I am at my wits end now and I refuse to buy any of the dlc until they fix this crap. This is ridiculous... How do they allow a game breaking bug like this go on for this long?

  • UbiKobold
    Ubisoft Support Staff 895 posts

    @deathjudge89 I am so sorry that this is still continuing to occur in your game! Thank you for letting us know. Just to make sure, have you updated the game to 1.2.1? If so, and you are still stuck at 5/6 clues and are unable to reveal The Father, please provide the platform that you play on and forward your most recent manual save to the cloud. Additionally, provide a full-screen and un-cropped image of your Order page. Thanks so much.

    Official Response
  • slaakhash
    2 posts
    This post is deleted!
  • Nazgul1948
    3 posts

    @ubikobold Hello i have the same problem 1.2.1 latest. I've been trying any posible sideways to continue but with no progress.
    Playing on PS5 - Hytham is still in assassins house and won't come to longhouse to start talk about this quest. Also when i entered in Hytham house and give him the medalions, a broken animation appears.undefined

  • Nazgul1948
    3 posts

    @ubikobold Unfortunately my account from Sony is not linked with the account wich i am registered here. And i im unable to do that, because my Sony acc is linked with different ubi account here wich i did not remember.
    But i assure you that the issue is still present with latest possible update on PS5, even after Wrath of the druids update and installed.
    My Sony account is Cvetun ([REDACTED]) if this will help. Please fix the issue because we are blocked STILL.

  • coombayah
    1 posts

    Same problem. Holding 14 medals yet all order members are slain. Is this still actually a problem? It’s been 8 months.

  • Flocoobio24
    1 posts


    I also cannot access The Poor Fellow Soldier quest. I also cannot submit a ticket to ubisoft, nor contact them any other way than here. Hopefully you can help me.

    I have seen that this is what we have to do if our game is fully patched, and we are still not getting the Poor Fellow Soldier quest starter from Hytham.

    I have killed all 44 order members, I have updated my game, and I still cannot start The Poor Fellow Soldier.

    It will not allow me to upload my screen shot, the file is too big.

    Please help me get my 45th murder.

  • FirefighterCody
    1 posts

    Hey guys, I've searched several times over the last few months for a way to kill the father. My bug is that I am stuck at 5/6 clues. I turned in all of my medallions as I acquired them, and now Hytham won't give me the final quest. I've eliminated the rest of the order including the zealots.

    My game is up to date to 1.2.1, I do not have any previous saves I can revert back to. All of my saves are cloud uploaded, this is on xbox series x. Please let me know if there is anything else I can do or if a fix has been found. I have 75 hours of play invested in the game and I do not want to start over.

  • Pppppppp555
    1 posts

    I managed to get around this problem by connecting online and on the my second restart, I was able to continue with the story - finish Hamtunscire (which had been marked as 'committed' only) and then get the letter from the 'poor fellow solider'. Shame we can't finish the game truly off-line. (Also found the ending rather underwhelming).

  • Ubi-Borealis
    Ubisoft Support Staff 6043 posts

    Hello there!

    @Nazgul1948 - I'm sorry to hear that you've been unable to start "The Poor Fellow-Soldier" after defeating all members of the Order. In future, please refrain from sharing your email address in public forums. This helps to keep your account safe and secure. I've now removed this information from your post.

    Just to confirm, have you also completed all of the story arcs, including Hordafylke and Hamtunscire? You can check this by ensuring that "Reporting on Hordafylke" and "Reporting on Hamtunscire" have been marked in your completed quest log.

    If you have met these requirements, please can you send us a video that shows the following:

    • Your current quest log and your completed quest log.
    • Your Order menu, showing that all order members except The Father have been killed
    • That you are unable to interact with Hytham to begin the quest.

    We can then pass your report along to the development team for further investigation.

    @coombayah, @Flocoobio24 & @FirefighterCody - Would you be able to confirm that you have completed all of the story arcs as well? If so, please can you send us a video with the information we have requested above?

    @Pppppppp555 - I'm glad to hear that you were able to proceed with "The Poor-Fellow Soldier" after completing your Hamtunscire pledge. Thank you for updating us, and for sharing how you were able to trigger this quest 😄

    Thank you 😊

    Official Response
  • Nazgul1948
    3 posts

    @ubi-borealis Hello there, here is the video link. Link because forum did not allowed me to attach it from the comment section. I show you all of the information and explain everything. I also attached screenshot from Randvi's map to see that all is completed.
    If you want turn sound on for the video because i explained every step. Thank you.

    Video: https://streamable.com/ukq1g0: (https://streamable.com/ukq1g0)

    Screenshot: undefined

  • Ubi-Borealis
    Ubisoft Support Staff 6043 posts

    Thanks for sharing a link to your video, @Nazgul1948, and for including all of the requested information. I've now passed this report, as well as your video and screenshot, to the development team for further investigation.

    If we require any additional information, we will reach out within this thread.

    Thanks! 🙂

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 6043 posts

    Hello again @Nazgul1948!

    The team has taken a closer look at your video, and would like you to check if Hytham has teleported to outside of the long house. When all the medallions have been handed in, this is where he can be found to being "The Poor-Fellow Soldier."

    Just to confirm, have you only handed in the 11 medallions (as shown in the video), and you're unable to deliver the rest? Or have you handed in all 15 medallions and the quest does not proceed?

    Thanks! 🙂

    Official Response
  • WongaFGA
    2 posts

    So I’ve completed the whole of the game, story line, all side quests, killed all zealots and order members, everything.
    But I still don’t get Hytham outside of the long house to start the poor fellow solider and to find the last order member, I’ve given hytham all the medallions, all the codex pages and nothing.
    I’ve got 160 hours of gameplay here and I literally can’t complete, I swear in the new update it said it would be fixing the breaking the order quest but it still won’t let me complete.

    is there any way around this at all or is it going to be waiting more months until this is actually fixed? Or even worse have I just wasted all those hours in game to be told to start over.

    I know this issue has gone on for a while now and there doesn’t seem to be a fix anywhere that I can see which is so annoying.

  • Ubi-Borealis
    Ubisoft Support Staff 6043 posts

    Hello there @WongaFGA! Welcome to the forums 🙂

    I'm sorry to hear that you've been unable to proceed with "The Poor Fellow Soldier" quest. Thanks for letting us know that you've collected all of the medallions and defeated all of the Order. To help us to investigate this further, please can you send us a video that shows the following:

    • Your completed Order Menu, that shows everyone but the Father has been defeated
    • Your current quest log
    • Your completed quest log, showing that all regions have been completed. You can verify this by looking for the "Reporting on _____ " quests.

    We can then pass this along to the development team for further investigation.


    Official Response
  • WongaFGA
    2 posts

    @ubi-borealis it’s saying I don’t have enough privileges to upload the videos to you?
    I can’t even upload screenshots of the video I took.

    yes I have every order even including zealots eliminated except the father it says I have 5/6 clues
    the quests I have open right now is

    • breaking the order
    • Irish trade (as I’ve just brought wraith of the druids)
    • The cryptic tutelage of hildiran

    that is the only quests I have, everything else is completed, all quests and regions done.

    ubisofts recent known issues list as not long gone live and the poor fellow solider is not on there even though one of your agents told me that it WAS a known issues and it was being worked on. So that doesn’t make sense.

  • Feclez
    1 posts

    When is a fix going to happen for the Order of Ancients

    I am still after like 100 hours played and dont want to continue as i have not killed the final person in the Order due to the bug that has been known about for months and months (heck since release)

    I am not going to do another play through just to avoid a BUG that is there that you guys seems to just be ignoring and its a MAJOR BUG at that

  • Ubi-Mark.
    Ubisoft Support Staff 2363 posts

    Hello @feclez,

    Thank you for bringing this to our attention!

    Can you please provide us with a full description of this bug, so I can check it for you?

    Many thanks and if you have any additional questions, please let us know.

    Official Response
  • Nokk_is_a_frog
    1 posts

    I look to have encountered this bug as well.

    1. I have defeated all members of the Order, including zealots, except for "the Father".
    2. I have 5/6 clues for the Father.
    3. I have 14 medallions of the 15 required to turn in to Hytham.
    4. Hytham does not have a quest for me to learn the Father's identity.

    I cannot continue my game 😞

  • Ubi-Borealis
    Ubisoft Support Staff 6043 posts

    Hello there @Nokk_is_a_frog! Welcome to the forums 🙂

    Please note that you won't be able to start "The Poor Fellow-Solider" if you haven't completed all of the regions in-game, including Hordafylke and Hamtunscire.

    If you have completed these regions and are still unable to start this quest, please can you send us a video which shows the following:

    • Your completed quest log, showing that "Reporting on Hamtunscire" has been completed.
    • Your Order menu, showing that all members have been defeated except the Father.
    • If you have handed the medallions over to Hytham, please can you show us that you are unable to interact with him in front of the longhouse. If you haven't yet handed your medallions over to Hytham, please can you do this to see if this causes him to move in front of the longhouse.

    We can then forward this video to the development team for further investigation.

    Thanks! 😊

    Official Response

Suggested Topics