Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • benzy4792
    30 posts

    @benzy4792 oh and I got all the medallions automatically. I can skip the last quest even.
    1.1.0 patch ruined A LOT of the game.
    Audio bugs
    Quiver bugs
    Quest bugs
    Please someone fix this

  • RicardVieira
    5 posts

    @petteflet88 its ridículous, the game crashed during the cutscene, and the mission get bugged! I played 70h after that and nothing Change! Good job [censored]!

  • Petteflet88
    346 posts

    @ricardvieira yeah i have been stuck before. 34 days on Sons of Ragnar. When I learned I also had this bug, i was just laughing.

  • Madeezy
    67 posts

    @petteflet88 Why can't they just reverse engineer this themselves? It's obviously an issue. Go check your code.

  • Frankie_Drums
    12 posts

    It's now listed as an official known bug and the other thread has a lot of activity:

    https://discussions.ubisoft.com/topic/84794/the-father-not-revealed-after-killing-all-order-members-and-zealots-post-here

  • Blackflagdritt
    2 posts

    @alexandru27p https://www.fanbyte.com/news/a-bug-is-preventing-players-from-completing-assassins-creed-valhallas-final-quest/

    This story that tells u about this bug was written 3 weeks ago and you claim you still are looking into this??

  • scaramouche54
    2 posts

    We sound like a broken record but it's the game that's jacked. I'm in the same boat no Father quest no meeting Hytham at the Longhouse just stuck without a finish and don't want to restart a new game until I can finish the first attempt!

  • A_o_c.92
    2 posts

    I've been having the same issue and it's still not resolved.. Which is disappointing as the first mention was over a month ago.. Has anyone been able to figure out what the last clue is or how to reveal the father?

  • Alexandru27p
    Original poster 18 posts

    @blackflagdritt
    No, started a new save game. But there are a lot of more bugs in the game, like big fish are missing and despwaning, fabric (stuck at 7 of 12) material missing so I can't upgrade my arrow size capacity and many more.

  • Jsand0
    1 posts

    I've completed the main storyline, killed all the Zealots and Order members, turned in all my medallions to Hytham, and the game is supposed to give me a quest that reveals the Father of the order. I never get that quest. I talk to Hytham, nothing happens. I have 5/6 clues for the Father and it says "continue the storyline to find the next clue" I've beaten every major storyline but this one. Help this is annoying.

  • EnForce58
    6 posts

    @madeezy
    I don't know why they just can't make the last missing clue of the Poor Fellow Soldiers of Christ letter respawn somehow to re-trigger the mission and reveal the Father.

    Either spawn a copy in you can read again in the Hytham's hut or have it respawn in Eivor's mailbox in an update. Seems like either would re-trigger the clue as being found, reveal the Father's identity, and allow you to access the mission.

  • Petteflet88
    346 posts

    @enforce58 the solution(s) to all these bugs are pretty simple, that is what bothers me the most.

    I was stuck at Sons Of Ragnar for 34 days when they released the hotfix. It seemed like the problem had to do something with the automatic saving. I heard that most of the bugs have to do with it... The cloud system is totally broken. This game is an open world game (sandbox) but the technical saving / behaviour behind it can't handle an open world (sandbox). They tell you, you have the freedom to do everything whenever you want to do it but if you do not follow the red line (missions without exploring) you get all kind of bugs... I have never seen a game with more gamebreaking and annoying bugs then this. The worst thing is, is that Valhalla was probally a 9/10 without all these destroying bugs. For me, now it is a 4/10.

    But... now, I am stuck at this and I bet you that it has to do with the 'open world' / saving issue again. But we will have to wait for weeks to get this solved. And they just tell us to stay patient etc. It is annoying as f. "Here you have our game but we will not let you fully experience it and fi you encounter something gamebreaking, wait for 30+ days and stay patient! :)".

  • nuglife22
    26 posts

    Yet another helix armor+ pack released today and there's still no update or fix for this massive bug? Ubisoft is officially the most greedy and shameless developers in the business. I think there's now more armor/weapons in the helix store than in the base game lol. The time spent on making microtransactions towers over the time spent fixing this massively broken game.

  • Wolf_Wilder
    2 posts

    We have the same issue. Have finished all the Story Arcs, have killed all the other order members and zealots, and handed everything in. Inventory still says we have 6 order medallions which we can't have - because we handed them in. Hyman won't leave his room and won't let us offer anything to him. Very frustrating!

  • Petteflet88
    346 posts

    @nuglife22 yeah society 2020 has their priorities straight. Man, I miss the 90's.

  • Petteflet88
    346 posts

    @wolf_wilder it is my last throphy. After that I am putting away this game forever. I was stuck before (34 days on Sons Of Ragnar) and promised myself to never buy a Ubi/Ac game again. That promise stands. My creed has ended and I started with Altair, but I just want this game at 100%.

  • guest-tNwUkcaJ
    1 posts

    My God, this is one of the worst bugs I have encountered in my entire gaming live. With the huge spoiler Hytham gives you it ruins the unveiling of The Father's identity. I am a completionist and not being able to complete the game is just [censored] annoying.

    It completely ruined my experience playing AC Valhalla. I hope they fix this so I can COMPLETE the game and finally burn this game in the trash can.

  • EvilSpark1
    4 posts

    @puertoricanpunk
    It is very sad all this, because I watch videos from YouTubers and then I did not see this mission in the correction lists. I also wanted to write to technical support, but I live in Russia, and Ubi's technical support in our country responds more slowly. Another new forum, a little not used to it. I really hope that the mission problems will be fixed soon.

  • EvilSpark1
    4 posts

    @rifkin76
    Yes, Hytham must give a mission and he must be at the long house.
    The bottom line is, when you hand over the medallions of the Order of the Ancients one by one, the mission is bugged. That is, they need to be collected all and handed over at once, so as not to get bugged. understood it this way.

Suggested Topics

Community Details

36
Online
129.0k
Users
22.2k
Topics
115.1k
Posts