Welcome to discussions

Quick Suggestions

  • SteveDude94
    1 posts

    It appears that somehow I was able to give all the order medaillons to Hytham before killing all the order members and before ending the main story. Eivor told him who the "Father" was and I was pretty shocked, not knowing how Eivor figured it out. But I thought: hey maybe I opened a note and didn't read it and thats how Eivor knows. So I kept playing and it's only after many more hours and finishing the main story that I found out it was a bug. Now Hytham won't give me the quest "The Poor Fellow Soldier" and I can't uncover the last member of the order...

  • Petteflet88
    346 posts

    Is Ubisoft still celebrating new year? They are reacting to nothing hahaha, what a joke.

  • drekken2010
    16 posts

    @petteflet88 i have tried severall times to open a ticket but everything is blocked by Bugisoft, absolutely everything. Sad, really sad, greedy bastards:(

  • xRaY_SCoPeZz
    1 posts

    I have just come across this now. I have completed all arcs and killed all order members including zealots, except the father. I still have 8 medallions left but I have Thor's cloak. Hytham is in his building with no relevant dialogue options. I just need to get and complete the final mission and I will have 100% completed the game.

    Since the Yuletide festival has been on, whenever I load the game Eivor is drunk.

    I have also fully upgraded the quiver and now have a max of 12 arrows.

  • Nikoladze85
    5 posts
    This post is deleted!
  • Nikoladze85
    5 posts

    (Attention for spoilers) Guys, did you complete Sigurd quests first?
    You have to complete those ones (fake Valhalla), kill Basim and become new jarl. After that, speak to Ranvi and Hytham will appear outside long house.

  • cosolici
    4 posts

    Hmmm... I checked today the state of my game, which was very similar to everyone's bad experience (mentioned so far on this thread) since November.

    • Hytham stays in his house, "Give 15 medalions option" is disabled, no other option, all Zealots killed, only Father left in the order tree, Basim is "gone", all alliance map areas done.

    However today I see that the alliance map (at Randvi) shows a "pledge contract to Hamtunscire" option, which was not there before.
    I don't know how that option got there - I went to Randvi and spoke to her, and also chose the "break up" option. After that I checked the alliance map to see that Hamtunscire area is available for conquest. I don't know if breaking up with Randvi triggered it, or if this was already fixed/triggered by the Yule Festival update - just saying.

    This new quest line which is available is called "The Prophecies of the King". I don't remember doing any of the quests before.

    So I started it, I'm curious where it leads - and of course - if it fixes my problem...

  • cosolici
    4 posts

    @cosolici UPDATE: when returning to the village - after finishing the quest line from Hamtunscire "The prophecies of the king" - Hytham waits for me outside to the town hall and gives me the "Poor fellow soldier" quest.

    Seems the questline is gonna be fixed from now on in a way that will allow me to finish the game. (Yaaaay!)
    So for me it seems that the bug (since November) was "Hamtunscire contract option" not appearing on the alliance map.... (grrrr)

  • Odyss122
    4 posts

    @cosolici Nothing has changed in my game, I still can't start the mission with the father of the Order, even though I have everything done

  • Nikoladze85
    5 posts

    Try to travel to Norway and talk to the ex king then back to randvi. She should say Sigurd want to talk to you and that will start his quests.

  • marcbryan
    8 posts
    This post is deleted!
  • Notori_and_Coby
    1 posts

    Same issue. During my first attempt I killed all the order members and zealots, handed in the "15" medallions, and it triggered the dialogue with Hytham as if I had already killed Aelfred. Then I went and completed the endgame in Hamtunscire and Norway (and Modern Day). Came back to town, upgraded the town to Level 6. Did the wedding. Really tied everything else up and the quest wouldn't activate.

    Second attempt. I went back to a save before I killed the remaining order members. Went and did the endgame stuff first. Came back to England. THEN killed the order members and zealots. Went back and Hytham still didn't activate the quest. I tried handing in the "15" medallions again and it went through the same dialogue as before as if I killed Aelfred.

    Completely broken.

  • Odyss122
    4 posts

    @nikoladze85 I did the whole plot, I still have a mission with the father of the order that I can not launch because I have already given all the medallions.

    You probably mean a mission with a sigurd in norway. Where are we going with Sigurd to the Hordafylke region.

  • ThePainTrain69
    1 posts

    Having the same issue, 2 months later.

    Is there going to be a fix?

    The bug only occurs if you talk to hytham after killing every order member except the father, This includes zealots, before you pledge to the last region ( i believe its called hundenscire or something like that)

    Anyways there wont be any conclusion or continuation after the pledge is complete, you cant accept any quest from hytham as the dialogue option never appears.

    Please fix this as it is the only thing holding me and all these people from finishing the game.

  • UplayMacAllen
    9 posts

    No questions in my journal, 100% map completion, I know what's supposed to happen but I run in and out of my lodge and still no advancement. I'd really like to finish the game. Any progress on this bug?

  • D4rKy26
    64 posts

    Is this going 2b a never endng story ubisoft?
    When are we going to get a fix is it even possible to fix this bug, if so please enlighten us.

  • tokajero32
    21 posts

    i hope the guys in technical team fix this soon, i did this quest today, i had no bug at all finding *father*. hytham was outisde the main hall. I spoke to him and all good. i dont get it at all, in the entire game i didnt get any bug at any quest except daughters and cloak bug. I dont get it all what is happening. and they are suppose in 2months or so to release the next expansion with all those problems. god help us!

  • tokajero32
    21 posts


    there is an opened thread weeks ago for this problem , no need to create a new thread, post there and wait for the fix

  • JoannaM95
    3 posts


    Is there ANY update on this? It has been months, and loyal customers and fans are growing frustrated and weary.

    What do you need from us to find a solution to this issue? How can we help?

  • Marvel4425
    1 posts

    The “Poor-Fellow Soldier” quest bug with the Order Medallions! The only quest stopping me from getting Thor’s full gear set. People have been reporting this problem for more than a month.

Suggested Topics

Community Details