Welcome to discussions

Quick Suggestions

  • rorobfo
    38 posts

    @thegardener25 same here, bro. just upgrading gear and hoard maps nd fishing left. stuck at 92% The Father not revealed (missing story progress, but there is no story left). even have some left over order medallions in inventory which i cant turn in.
    guess i gonna wait until there is a game plus before i can finish the game

  • Saint.Balthazar
    19 posts

    Encountering the same issue as well

  • Samhyde1591
    1 posts

    wont let me give Hytham the remaining medallions. I have 9 left over, won’t receive the quest the poor Fellow solider to reveal King Harold

  • Asgardian02
    1932 posts

    @samhyde1591

    ffs massive spoiler just in the title man 😞

  • Saint.Balthazar
    19 posts

    Yo, any update on this one? 😞

  • tommythagun
    1 posts

    This is the only thing that is stopping 100% completion......

  • KingSpawn1979
    4 posts

    It's absolutely ridiculous. I remember them speaking about "Everything will be better from now on" after that Breakpoint Desaster.

  • ziggurcat
    167 posts
  • ziggurcat
    167 posts

    "The Father not revealed (missing story progress, but there is no story left)"

    spoiler

  • Gynnyper
    1 posts

    I killed all the zealots and order members, but Father. It says 5/6 clues. Handed in all but 14 medallions to Hytham. Because he's not in the hidden ones bureau in my settlement. No clue where he is. So I can not progress any further. Can not do the final mission. Been told it is a major glitch. What it is, is a major disappointment.

  • Jace_beleren
    1 posts

    Final Order of the Ancients mark not being revealed, yet still given Thor’s Cloak and obtained Mjolnir. Game is 99% complete except that last mission.

  • Asgardian02
    1932 posts
  • iwajabitw
    23 posts

    I am like many posted in other threads. I got the poor fellow quest mid game, met you know who. Now with all members dead and all quests/ regions completed, i cant get the last clue. Hytham is in the hut, completed missions does not show the poor fellow quest at all. Actually have zero in the quest key.

  • Quarkomat
    2 posts

    @madeezy Thank you! I started the second game with 1.04.

  • ziggurcat
    167 posts

    @asgardian02 I don't see any spoiler?

  • sp4rt4n1984
    1 posts

    Has Ubisoft mention anything about working on a fix for this glitch? I'm on ps5, killed everyone except the father, and can't get the final quest.

  • crowe76
    9 posts

    I was all in! purchasing the game and season pass via pre-order playing the game since day one of launch logging over 200 hours into this game .I experienced this bug in mid November ,reported this bug and received no feedback came to this thread shortly after and realized I was not alone. Over the course of a couple months more and more players have reported this bug and still no feedback so if you are just now experiencing this bug let me tell you DON’T EXPECT A ANSWER ANY TIME SOON!!! They have avoided this for around three months I will never buy Ubisoft again customer support is a joke.

  • Funtimes323
    1 posts

    I completed the main story and killed all of the other Order of Ancients members, but the mission to hunt down the Father still won't pop up for me. What do I do? Side note, could it have something to do with me getting the Thor Armor before killing everyone from the Order?

  • AfloatDevotee06
    1 posts

    Is this sorted yet? I'm 200h into this game, settlement at level 6 and all pledges. Still the father remains on 5/6 clues with no way of proceeding.

  • Petteflet88
    346 posts

    They still not reacted/ fixed? HAHAHAHAHAHAHA

Suggested Topics

Community Details

97
Online
190.5k
Users
31.6k
Topics
160.1k
Posts