Welcome to discussions

Quick Suggestions

  • chucksstuntman
    1 posts

    @diabetic_man97 no, I am on the game now after today's update and nothing changed. still bugged.

  • FISHMANGRANDAD
    4 posts

    @killbill9191 totally 100% agree on this lets boycott them, and i want me money back

  • Diabetic_Man97
    14 posts

    @ziggurcat
    i know that but so many players have the same issue... Hytham doesn't appear near the longhouse (he stays in the Hidden one's Bureau) even if I have complete all territories and complete all arcs! The bug happens when you complete the quest "breaking the Order" before knowing who the father is... BUT does @Ubisoft fixed this bug? This is my question

  • Diabetic_Man97
    14 posts

    @chucksstuntman
    Ohh God...
    Thx Pal!!

  • ScabbyTramp
    5 posts

    I've been stuck for months now. It won't let me progress .

    I've got all hidden one codex , I've seen the little boy in the tent and done his quest.

    I've done all quests .
    I've killed all orders .

    I've done all alliance map .
    All of asgard and the other sub story.

    What's going on ?!?!?

    It says there should be someone out the camp longhouse to start the last order quest. But he's always in his house , where you get him codex.

  • LittleYanYay
    7 posts

    @alexandru27p Same here, post 1.1.1 update, attempted to kill final Order member that should reveal the 6/6 clue for The Father and no luck. STILL BROKEN! @ubisoft when will this be fixed. Can't complete order progression, can't get Thor's cape, can't get Mjolnir... really is aggrevating!

  • ziggurcat
    167 posts
  • ScabbyTramp
    5 posts

    Same issue. Can't get last clue

  • ScabbyTramp
    5 posts

    This has bugged for me for months.
    The game is 99% . What the actual monkey [censored] are they drinking.

    Just fix the dam quest.
    Make it a chat option. Or force it on everyone.

    It's not rocket science . If you can add DLC and event quests. Just bloody add the story quest as a click able option . Problem solved.

    I've done all maps . All medallions handed in.
    I have cape. I have thors set and hammer.

    Like the rest . I can't get the last dam.father clue , because you lot can't write code correctly.

    Sort it out, or I'll pray a civil.case.will be brought against you .

  • Frankie_Drums
    12 posts

    Just change the achievement/trophy requirements so it only requires 45/46 member revealed. Boom, game is complete, and we can move on.

  • ajscott819
    9 posts

    First I had the Sons of Ragnar Ubba bug. Spent my time exploring and clearing the map. Now I have this bug. I thought it odd when Hytham gave away spoilers early, but I wasn't aware of this issue. I thought it was poor continuity.
    After over a month of not be able to progress I am stuck again.
    I was really hoping this patch fixed it, but no. I have everything except the last clue. Well everything, but the last clue and the coastal fish.
    Stupid fishing. Fix that too please

  • PhoenixFury2211
    10 posts

    Still not fixed after 1.1.1. Absolutely unbelievable.

  • Valgoerad
    1 posts

    Same problem here. Xbox Series X. Whole England conquered (100% of all dots on the map cleared too), father left with last uncovered clue.


  • eightroadlolz
    1 posts

    Spoiler Alert
    Spoiler Alert
    Spoiler Alert


    i cant proc The father quest becus the number of trinket somehow over droped,i got all gear b4 the father quest start

  • guest-LmWt2ELH
    1 posts

    I have the same problem on XBSX. This is infuriating not being able to finish the game after 120+ hrs in and with 92% completion.
    #PLSFIX Ubisoft!

    My progress went exactly as previously described. Hytham allowed me to give him the medallions and rewarded me Thor's cape without me killing the last member of the order which I didn't even realize I was missing. I can't give him the last medalion now and get the last hint for the Father.

  • Quackable
    3 posts

    @ubikobold It's Jan 15 now, still no update on this?

  • TylerEmma2015
    76 posts

    Has anyone not given hytham the codex pages yet I got 2/6 I need the rest hopefully that will trigger him to give me the father I don’t know

  • matos2001
    1 posts

    I've finished the main story, killed all the order members/zealots, but I can't access to the final clue to find the Father... Although, the Cola's icon show a parchemin with a question mark under, I don't know If this is related or not:/

  • Petteflet88
    346 posts

    Stupid company should be ashamed. They dont even dare to react.

  • JoePiraino
    2 posts

    After update 2.1 and 1.1.1 I am still unable to finish this game.. I am on the last member of the order and the game insists to continue quests to figure out who the last member is. I have logged over 115 hrs. and cannot believe the recent update did not take care of this problem after seeing a lot of people with the same problem over the past few months. Please reach out.

Suggested Topics

Community Details

133
Online
142.5k
Users
25.2k
Topics
130.7k
Posts