Welcome to discussions

Quick Suggestions

  • Shadow-Wipeout
    19 posts

    @wrath_of_gods the reason the quest won't start is because you have the mission reward which is Thors cape, because Hytham gave that to you before he issues the final quest, the game thinks you have already completed the quest.

    The bug lies in the fact that you can return 44 medallions/medals/tokens or whatever you prefer to call them to Hytham and he will issue the final quest reward which stops him giving the final quest as the game thinks you've already done it

  • Shadow-Wipeout
    19 posts

    @wrath_of_gods and unfortunately no, there is no work around, it requires a fix similar to one they done before by resetting the mission parameters for everyone under the condition that something specific to that mission hasn't already been completed, so those that couldn't do it were able to and those that had completed it wouldn't be effected by this fix

  • Wrath_of_Gods
    2 posts

    Thank you for the reply. I am 100% OCD (205 hours) complete with all minor chests, wealth, mysteries, artifacts, missions, arcs... except whatever is in Aelfred's secret study. With nothing left to do, I retrieved Thor's Hammer & Excalibur. I guess I'll need to wait for a patch. I had hoped that yesterday's update would've fixed it.

  • TylerEmma2015
    76 posts

    Just done all hythams codex pages still can’t get him to go to the longhouse to give me the father mission
    Done the whole campaign pledged every location got Thor’s hammer Thor’s outfit just need to kill the father then I’m done till they bring dlc out 👍🏼 Is there a workaround to get Alfred guessing that’s who father is

  • TylerEmma2015
    76 posts

    Can somebody help me aswell when I upgrade my skills it’s says power level 403 but the mastery parks that are very close to the middle on the skill tree doesn’t show up just says 403 it looks like I’ve got every skill but I’ve noticed other people have the mastery points is that a bug glitch going on too? If someone could help that be cool 🙂

  • TonyH9292
    4 posts

    @diabetic_man97 . I have the same problem, is it going to be fixed.?

  • BayBryant21
    1 posts

    I’m still upset, I’ve killed every order member and zealots, except for the father, and the father does not get revealed. Also along with hytham being stuck in his same spot and not in front of the Longhouse, and not being able to access “The Poor Fellow Soldier” quest. Been waiting for forever for this to be fixed and I Thought this new 1.1.1 patch would hopefully and FINALLY fix this issue for me and many others, but it seems Ubisoft had other things in mind. We need this to be fixed!

  • sacha7885
    9 posts

    @alexandru27p same here. Just finished and stuck not being able to get the father.

  • sacha7885
    9 posts

    My game has done the same as above. Looks like ubisoft really can't fix this or just don't care. Either way load of crap. Still haven't fixed the arrow bug correctly. But look at the length of this thread and ubisoft stopped replying. Well this may be my last assassin's creed game I buy.

    1 posts

    After completing the story and the hamtunsire arch as well as killed all 44 order members and found all codex pages I was left with not having “the Letter”quest pop up after, I can’t even reload to a point where before I handed in all the order medallions which is where the bug thread starts if you defeat all the zealot and order members before completing the story you cannot receive the mission to kill king aelfred at the end and is extremely frustrating replaying hours just to end up right back where I started and now I’m being punished for being a completionist

  • innasauce
    1 posts

    Hey guys, new to Ubisoft discussions but not to the game; is there any sort of common consensus as to, if I were to start a new game to try and avoid this bug and actually kill The Father, what do I need to do / not do to bug the quest? Big surprise I'm going through the same exact problem as people here and killing all the order members is the last trophy I need for platinum 😐 Any advice is appreciated!

  • rorobfo
    38 posts

    @mojosodope42oxx same here. i even have 7 order medaillons left in inventory. Software as a Service & NG+ somehow seems to increase the probability of not being able to finish the game at the first run.
    I just hope NG+ comes soon.

  • TRITONK-175
    32 posts

    My issue is that the 'Disorder of the Ancients' achievement won't unlock.

  • Crowleyman
    1 posts

    @rorobfo my problem is a bit different-I got the Father quest, but the achievement never unlocked. And I currently have Mjolnir quipped, so I definitely got all the Order members. Frustrating

  • KnightofTara
    13 posts

    I am happy to note that the Mari Lwyd bug (one of my two big issues) is fixed. Thank you so much for that, Ubisoft.

    However, I am sad to see no apparent progress on this terrible bug that renders the game unfinishable. I hope that either a fix or a workaround will be available soon. I cannot get Thor's Hammer until that happens.

  • ArKonIte167
    6 posts


    dont give hytham any medallions until you complete all territories.

  • derechtegraf1
    2 posts

    After 1.1.1, I was able to trigger the quest to reveal the father, however, the Disorder of the Acients achievement did not pop after speaking to him (on XBOX Series X).

    After finishing the story I had two Order members left (plus the Father). After killing one, the other was revealed (The Rake), but auto-killed / automatically defeated. I then proceeded to Ravensthorpe to hand in the medallions, but Hytham was waiting for me in front of the longhouse - upon speaking to him, the quest to reveal the father triggered. I went to the location and spoke to the father, but afterwards no achievement popped.

    So three problems: Order member auto-kill, being able to hand in the medallions before the father is defeated, and the achievement not popping.

  • TylerEmma2015
    76 posts
    This post is deleted!
  • ginoongjes
    1 posts

    This bug just happened to me.

    I finished killing the whole Order (except for The Father) and gave the medallions to Hytam. I thought I will be able to kill The Father after the conquering the whole map -- finished that part of the game and still nothing.

    5/6 clues for The Father and the games tells me to keep playing the story to unlock more clues but there are no more quests left on my map.

  • Trybka432
    1 posts

    I have same problem, Hytham stays in his home after killing all order members and finishing main story. 2 months, 2 patches after release, hundreds reports on forums and support pages and still no fix for this issue... dissapointing...

Suggested Topics

Community Details