Welcome to discussions

Quick Suggestions

  • costiaan
    1 posts

    @ubi-borealis cheers mate, finally I can finish the main story, get my 100% and the platinum trophy! 🙂

  • MarcioS10
    1 posts

    Guys can anyone please help me? I did everything in the game and when I get back to camp, there's no dialogue with hytham so there's no way to get the last ocult boss the father. I have no other save 🤦♂️ is this a bug or am I doing something wrong? Thanks everybody

  • xIFoxHound
    49 posts

    @ubi-borealis Thank you for the update, can now reveal all the order members now. Just need the Prophecy pig bug patched and that’s my platinum.

  • TylerEmma2015
    76 posts
    This post is deleted!
  • D4rKy26
    64 posts

    @ubi-borealis does nothing for me still on clue 5 of 6 great 😞 So its not resolved. i am on pc btw alrready got thors hammer and full arrmorr set finished the game, never had the poor soldier quest father stuck on clue 5 of 6.
    I just noticed i am still on patch 1.1.1 so have to wait i gues.


  • Regent_Syhr
    3 posts

    As of the latest patch (1.1.2) this issue is resolved and I was able to get the platinum trophy. Thanks for the patch!

  • Foley412
    2 posts

    The patch worked! The game is better than ever!!

  • xDannyvld
    2 posts

    The new title update says:
    Addressed an issue that prevented the final order member to be revealed. No more Revealio!

    It's still not working for me.

  • Gremista2007
    1 posts

    Those who got it, how was it? after the patch was installed I check the clues and still show 5/6. I went to see Hytham and he was not at his place. I did get a message for a new quest (river raids?)

  • TylerEmma2015
    76 posts

    @gremista2007

    hytham outside the long house bro

  • LottaTronIcs
    12 posts

    Patch 1.1.2 fixes the problem for me. He was at the longhouse and I now have the quest ... thanks for the fix!

  • LottaTronIcs
    12 posts

    @ubi-borealis thank you. confirmed fixed on my system after the patch.

  • D4rKy26
    64 posts

    Its fixed now thx ubisoft.

  • kairockz
    9 posts

    Can confirmed it worked! I am on Pc

  • Mirek285
    2 posts

    Its still not working for me, Hytham is not outside Longhouse, but in his Bureau. Also last area in Alliance map is not completed. Im on PS4, more than 180 hours in game 😞

  • guest-JOPA5hip
    4 posts

    @mirek285 same here. The patch did not fix the bug. (PS4)

  • xrayspex_73
    141 posts

    @kairockz Fixed for me as well on PC. When I loaded my game, Hytham was just sitting near the entrance of my longhouse.

  • Diabetic_Man97
    14 posts

    worked for me !!!! I'm on Xbox

  • crazyglynn
    2 posts

    I have killed all other members of the order and the zealots. I have killed the three witches and have gotten 4 pieces of thor's armor. Haythum is still in his house and I cannot access the poor fellow soldier mission in order to discover the identity of the father. I have closed out of the game and reloaded it. I don't know how to make it work.

  • Tsukiyommi
    2 posts

    @ubi-borealis I went back to playing (Xbox One / V. 1.1.2) after the update and the first thing I did was to go outside the longhouse and to my frustration Hytham still doesn't show up, I went to talk to him at the headquarters of the hidden and the only thing he says is "So go in peace" I sent him to hell but nothing happens. The Winchester Arch is completed, all members of the order have been killed (44) and I have 14 medals in the inventory, 5/6 leads from the "Father", also after establishing an alliance with all the territories of England the message that she was pacified did not appeared. In short, I'm still the same.

Suggested Topics

Community Details

122
Online
143.8k
Users
25.4k
Topics
132.3k
Posts