ubisoft discussions


  • locked topic_solved [RESOLVED] Unable to remove the Mari Lwyd cloak from Eivor | POST HERE

    29 likes/747 replies/81176 views
    ubisoft:x-posts, 2

    So it's been a few days since I've even seen Ubisoft support even check back with anyone on this issue....Like hello guys your game is broken?!
    It's crazy how one bug can really F this game up...

  • cyclone117
    ubisoft:x-posts, 2

    Okay so after I finished the story arc I went back to settlement. Fast traveled. I tried the cloak on with hood/mask on and jumped in water. Poof gone. It resat to my cloak I have equiped.

    How long it will last....who knows. But it is off for now. I would assume to just repeat that untill they fix this...if they fix this.

    Hope this helps some of you. I am just as frustrated.

  • GoingCrabby
    ubisoft:x-posts, 1

    I've tried uncloaking, unequipping, restarting my game, going on my horse and uncloaking/cloaking, pressing l2 and checking the stats and then going back. None of these have worked for me and 6 hours after completing the main quest i'm still stuck with it.

  • rooxon
    ubisoft:x-posts, 6

    well I just wanna say that I also have this problem today - I'm adding a screenshot. I'm in the endgame mission I believe yet it still hasn't gone away. 😕 I did Glowecestrescire as the final region. I hope it gets fixed soon maybe make it as an actual equip item which we can un-equip later by hand or something. I would really, really, really like to change my look sometime soon, I'm nearing 100%... just some side stuff to wrap up after.


  • TylerEmma2015
    ubisoft:x-posts, 76

    @goingcrabby same here I’m on series x playing this and I can’t play the game at all because it’s on a drunk screen even tho I’m just loaded up the game spose I’m just gunna have to wait for a new update before I even start playing again I’m now playing other games because I’m stuck can’t play with the bugs in the game

  • yondernick
    ubisoft:x-posts, 5

    I uninstalled the game and now currently re-installing it as a last ditch attempt. If it doesn't work, I don't know what will?!

  • LSayer92
    ubisoft:x-posts, 12

    @yondernick ive tried this twice and unfortunately didnt work for me

  • LSayer92
    ubisoft:x-posts, 12

    @cyclone117 wierd how as soon as they update the game and leave a load of f ups out there support team chat is all of a sudden turned off too.....

  • ignoreality
    ubisoft:x-posts, 2

    While wearing my any other cloak, I see only the Mari Lwyd cloak, with and without the hood on. This behavior persists through zoning and logging out.

    This is what happens if I unequip my cloak entirely:

  • Hank_Pank
    ubisoft:x-posts, 20

    @ubi-litten This is the most gratuitous instance you will ever see of this glitch

    https://i.imgur.com/2bkwfdc.mp4: (https://i.imgur.com/2bkwfdc.mp4)

    Here you see me wearing the hidden ones Cloak, killing the Gloweceshire Zealot, and immediately having the Mari Lwyd equipped on to me for God knows what reason. I was not even doing that story arc, so I can only guess that the stupid skull hood is programmed to appear in any cutscenes in that region

  • LSayer92
    ubisoft:x-posts, 12

    @hank_pank surely something needs to be down about this now its ridiculous. And to think i actually wanted to buy the season pass aswell as other bits. Ubisoft assured me and a lot of other people it would be fixed as soon as possible and also stated in the patch fix that cloak problems had been fixed.

  • dduttonnc
    ubisoft:x-posts, 5

    @kwizatchz There's no cockiness. I've helped over 50 people clear this bug. While it is a very annoying bug, it's not game breaking. If you don't want my help, then fine, you can just live with it until Ubisoft fixes it.

  • Hyogoko
    ubisoft:x-posts, 4

    I had the same bug right after the samhain questline, fixed it and now, after I have completed the game, it has randomly come back. I don't know what to do anymore....

  • WombatButler
    ubisoft:x-posts, 1

    @guest-icu8r70l this worked for me, thank you!

  • yanpafemy
    ubisoft:x-posts, 1

    Since i did that Halloween Mission, Eivor is not taking off his Cloak anymore. Can't change it at all. I think it's only visually but it's a bit annoying. Even in the tattoo menu, she/he is wearing a cloak.

  • iwajabitw
    ubisoft:x-posts, 23

    @yanpafemy I am at the boss fight for this story arc and still have it on. I dont think you get to take it off until the end of the arc and you get the region as an ally.

  • TheMB2410
    ubisoft:x-posts, 3

    Has anyone else noticed that when you upgrade a cloak with an ingot (after encountering the Mari Lwyd bug) that it doesn’t show the cloak at all? I’ve just done an upgrade and all I saw was a puff of smoke, no cloak whatsoever. Other armour pieces show the change in appearance but it appears that the cloak is affected here too.

    Update: cloaks that have already reached final appearance such as hidden ones cloak do show when upgrading. Only cloaks that change appearance are missing.

  • Damo_77
    ubisoft:x-posts, 15

    why isn't this fixed yet?
    Here's the scripted fix logic
    Run on game load
    Has player finished Glowchesterscire story arc?
    If yes, does player have Mari Lwyd cloak armature equiped?
    If yes, unequip Mari Lwyd cloak armature?

    Seriously, this could have been hotfixed within hours of receiving credible bug reports, but you're going on almost two weeks since this was reported to you.
    Your delay is really taking me from feeling GOTY to feeling [censored] I dropped $120 on a game I can't even play.

  • iwajabitw
    ubisoft:x-posts, 23

    @yanpafemy I can confirm it does not come off until the arc is finished, report to Randvi, then when I left her room it returned to normal.

  • aegy17
    ubisoft:x-posts, 1

    I've completed the Glowecestrescire quest and I still have the deer skull costume "equipped." Everytime I start my game I have to reload in order to "unequip" it. Not sure why yall could not have made this a proper armor piece.

Suggested Topics