Welcome to discussions

Quick Suggestions

  • Pandagama
    1 posts

    @lowerdanny I did this and it's works!

  • pwnage9
    1 posts

    still having the same issue, playing on PC have tried every single suggestion out there.

  • GeminiG0d
    2 posts

    I had the same annoying bug. I fixed it by unequiping all the gear and put the hood that I wanted and put it on cloak and then jumped in water. Surprisingly all my gear was then equipped but the mery lewd mask disappeared. I am on xbox one X.

  • OxIdOAC
    22 posts

    Glowecestrescire cloak bug. PC.
    After i complete story arc, can't remove deer skull cloak.
    Some say that you must place it in front of your bed, but i did that, and there's some kind of head on the shelf and the cloak is still on me.
    To be honest, this is the first real bug i encounter after 130+ hours of gameplay, besides unpickable Opal in Grantebridgescire near Walden (even after 1.0.4 patch)

  • OxIdOAC
    22 posts

    Same here, cloak won't go away...

  • OxIdOAC
    22 posts

    still, here, needs fixing asap...

  • BlackAdder08
    2 posts

    @geminig0d This worked for me too! (PC platform) You need to take all the gear off and then go outside of the region Glowecestrescire "naked" with the Mary cloak on. When you get out of the water, in other region (Oxenefordscire for example) and you "activate" the cloak again your gear comes on automatically (most of it - not weapons and shield) and "somehow" the "bug" seems to disappear when you go back to Glowecestrescire. Try it guys and tell if it works for you. Seems better than other solutions, if it works for you xD

  • BlackAdder08
    2 posts

    Update! Sorry guys... when you enter more in Glowecestrescire " the bug pops up again. Seems that we need to wait for an update xD

  • iMBUE_
    3 posts

    This is totally unacceptable. It's so frustrating to see this stuff in a $60 game. It's truly baffling. Why haven't they fixed this bug? Get your [censored] together, Ubi.

  • LUMB3RizJACK69
    2 posts

    @oxidoac have you tried opening up the menu circle thing (thing with fishing line, torch etc) and using the remove cloak? This worked for me.

  • OxIdOAC
    22 posts

    @lumb3rizjack69 yep, tried everything that i can read here and on reddit (there's a ton of posts about this bug), nothing works...

  • Superfly_Boss
    81 posts

    @guest-whrqw1cf Doesn't work.

  • zombieimpaler18
    1 posts

    @tyler-smith666 hey thanks man, this worked for me first try

  • Lowly-Eidolon
    10 posts

    I was also dissapointed that Gunnar told me that I'd get my clothes back after the festival, but I went back to his beloveds home and my clothes where not there (mainly because they were always in my inventory) but I thought goig back there, I may be able to return the meri lewyd cloak to him and get it back as a seperate cloak to wear

  • Baorwulf
    2 posts

    You need the horse skull later on, seems like a bug butt it's supposed to be there when you meet the druid.

  • SmasH1295
    1 posts

    I followed these steps and it fixed the issue.

    1. If you have your helmet hidden change it to show gear.
    2. Toggle cloak ON/OFF
    3. Default cloak will appear
    4. Hide helmet again


  • key2blade
    1 posts

    I just played through the story line in Gloucestershire and the costume that you have to wear during it is stuck on me. 

    Nothing works to get rid of it

  • Varaelian0
    1 posts

    I completed the gloucestershire story arc and was also stuck in the skull cloak. I read the other solutions and could not clear until, I simply unhooded my cloak then fast traveled again to Ravensthorpe then put hood on and my default cloak returned. so far I have not seen that skull cloak again. not sure if this works for everyone, but sure was an annoying bug.

  • skyforger96
    1 posts

    @raphaelzoren Was having this issue did what you said but I did report to randvi. Once I had done that I put the cloak on and it went back to normal

  • Jay_Otto
    4 posts

    So its been a month and devs haven't fixed this? Jeez. I guess me finishing the boss fight with fenrir is out of the question...

Suggested Topics

Community Details

138
Online
194.2k
Users
32.8k
Topics
164.2k
Posts