ubisoft discussions

quick-suggestions

  • locked topic_solved [RESOLVED] Unable to remove the Mari Lwyd cloak from Eivor | POST HERE

    29 likes/747 replies/81114 views
    Powerburst284
    ubisoft:x-posts, 2

    @ghostguy115 im the same. ive messaged ubi on twitter, facebook and also opened a case, all of which have currently gone unanswered. Ubi also deleted the previous thread on this bug which had nearly 300 comments... I think they are planning on just ignoring it and saying F**k the player base tbh... they dont actually care

  • Powerburst284
    ubisoft:x-posts, 2

    I am also unable to get this damn cloak off. I've tried everything...EVERYTHING! leaving animus, fast travelling, changing gear, sleeping, Vinland, reloading the game, reinstalling the game, toggling cloak on and off, toggling cloak on mount, changing Eivor from male to female.... NOTHING WORKS!! Im 120h into my playthrough and this is completely ruining my immersion and i refuse to start a completely new playthrough and have wasted all that time. I stupidly paid for gear out of the shop and now i cant even view the damn thing!
    I put up with the constant bugs, the falling through the map, the bugged quests, getting stuck places, having saves get corrupted and having to restart (at one point losing nearly 20h of playtime!) But this is the last straw!
    Its ok though Ubi, keep adding packs for people to buy every Tuesday or fix the glitches where players benefit (i.e. skill points and fall damage,) but cant be bothered to fix fundamental flaws that are now causing hundreds if not thousands players to quit until they're fixed! SORT OUT YOUR PRIORITIES!
    If you treat your customers like [censored] and keep shafting them, eventually you don't have any customers! smh.

  • Damo_77
    ubisoft:x-posts, 15

    @ubi-woofer I hope at Ubisoft you all recognize that today is your last chance to push out a bug fix out for this before most of us will walk away from this game with bad memories of how we never finished it because you wouldn't fix a game ruining bug.
    Cyberpunk comes out tomorrow and if you put off for tomorrow what you could do today it'll be too late because we will have moved on.



    @aj_nuvo I never left Glowchesterscire during the story arc. I got that notice about receiving the cloak as an item after finishing one of the quests.

  • Damo_77
    ubisoft:x-posts, 15
    post_is_deleted
  • AJ_Nuvo
    ubisoft:x-posts, 44

    Hi @Ubi-Woofer this is absolutely ridiculous by now. December the 8th and this issue is still not under investigation by the devs? How much more evidence do you need? Is it that difficult for the devs to just look into this and trust that their gamerbase is not taking the [censored] at them?

  • guest-xCrm0zNw
    ubisoft:x-posts, 1
    post_is_deleted
  • AJ_Nuvo
    ubisoft:x-posts, 44

    @guest-xcrm0znw sadly many of us play on console. Thanks for the suggestion though. No excuse for the precious little attention the devs are giving to this.

  • speedynl21
    ubisoft:x-posts, 79

    @guest-xcrm0znw
    they need to fix it, a workaround is just a temp solution, and shoud not be needed
    but no they don't fix it, they trow cashshop [censored] at you when launching the game, thats more importend for them

  • hecatonchires7
    ubisoft:x-posts, 4

    Being a victim to this immersion jolting bug and having tried everything, I noticed when I finished the Gloucestershire arc instead of the mari lwyd cloak going into my inventory they gave me a "turnip" that in it's description says it "banishes evil spirits". Almost like ubisoft is adding insult to injury here...

  • Damo_77
    ubisoft:x-posts, 15
    post_is_deleted
  • speedynl21
    ubisoft:x-posts, 79
    post_is_deleted
  • maxheavelar
    ubisoft:x-posts, 4

    playing on PC

    Cloak is ON

    • underwater
    • every area (Asgard, Jotunheim, etc.)
    • every single time (Cutscenes, Tattoo Shop, even when all other armour piece is turned off)
    • when i am not wearing a cloak piece (Armor), the deer skull is on the face of the character without the hood
    • nothing really helps - even uninstalling the whole game/deleting the save etc. it ALWAYS comes back
    • can't see tattoos in the shop
    • can't properly shoot with predator bow, because the fur blocks half of the screen


    150 gameplay and still almost end game the mary lwyd cloak stuck however change armor or in other region too out from glowescersire

  • PixelTheHero
    ubisoft:x-posts, 1

    @dakotmastaflex This worked for me too! Took off EVERYTHING and all my stuff popped back on.

  • MonroeTheCat
    ubisoft:x-posts, 5

    @ubi-woofer

    Playing on PS4

    Cloak is on after completing Glowecestrescire arc and will not remove even when outside of this area. Shows the Mary Lwyd cloak as ON when:

    • in every area of the map, and remains visible when in Asgard, Jotunheim, etc.; remains on after returning from Vinland
    • loading screen in all areas, all cutscenes, tattoo shop, Inventory; even when all armour pieces are removed and/or hidden
    • when not wearing a cloak piece (Armor), the deer skull remains on the face of the character even without the hood
    • have un-installed and reinstalled and bug persists
    • have tried everything, including moving between regions by fast-travel, walking, or by horse to get the Mari Lwyd visual to trigger off and nothing has worked


    It is killing my enthusiasm for the game since it just will not go away. The skull covering Eivor's face is really not the look I am interested in playing with, and if this can't be resolved I will need to return the game as defective at this stage...
    undefinedundefined

  • AJ_Nuvo
    ubisoft:x-posts, 44

    @Ubi-Woofer is this enough for you? Or at least, for the devs to actually care? Getting quite ridiculous that we have to practically beg for a fix for a game we paid for.

  • Trisaratops90
    ubisoft:x-posts, 1

    Hey I also had the same glitch and if you change eivors gender it fixed the glitch at least for me it did.

  • Ubi-MrM
    Ubisoft Support Staff ubisoft:x-posts, 4172

    Hey everyone,

    I'd like to quickly reiterate after seeing a couple of the recent replies - the issue with the Mari Lwyd cloak appearing over your normal armour / disguises is an issue that we have been looking into, where it happens outside of Glowecestrescire territory! 🙂 Within Glowecestrescire, as I previously mentioned, it is intended to still appear over your regular armour after you have completed the Glowecestrescire arc, so it is not an issue if you are within Glowecestrescire.

    I have forwarded all of the details provided so far that I specified in my previous post - thank you to all of you who have contributed so far! If we can receive further answers to the below questions, as well as videos of the issue and copies of your save files (for PC and PS4 players), these would be massively appreciated and very helpful to the team. I'm currently waiting to hear from them how their investigation is going, and I'll let you all know if I hear anything about a fix. Thank you to those of you who have also shared workarounds that worked for you - I hope that they will help others!

    • Confirmation of the platform you play on
    • Did you complete the quest "The Burning of the Wicker Man" already?
    • A list of the places you have travelled to while still seeing the cloak applied, and how you got there (e.g. by foot, on your mount, fast travel)
    • Confirmation of whether the issue has been present consistently, or intermittently; and also whether it is an issue only in some places, or all outside of Glowecestrescire


    Thank you all again! 🙂

    official-response
  • speedynl21
    ubisoft:x-posts, 79

    @ubi-woofer
    platform pc

    finished the hole main story
    everywhere where she put her hood up this dum thing override her normal hood
    it don't mater how you get to any place fast travel/foot/horse, it always show, when she put up her hood
    as for a save file i don't have any, deleted all, no point in keeping the game/save if you have done the mainline

  • Hypobox
    ubisoft:x-posts, 8

    PC
    Yes completed the Burning Man quest.
    Still playing and pretty far on(80%). Been Vinland, and all other extra locations.
    None of the workarounds have worked for me

  • AJ_Nuvo
    ubisoft:x-posts, 44

    @Ubi-Woofer

    • PS5
    • Completed "The Burning of the Wicker Man". Bloody 80 hours in and not going to restart the entire game for this absolute mess of a bug.
    • Cloak stays on no matter what - in Glowecestrescire, Asgard, Norway and anywhere else in England. If I go to Vinland and return to Norway/England, the stupid cloak comes back. It's on everywhere, after fast-travelling, changing regions by foot or on horseback.
    • If I unequip my cape armour piece, the cloak's ugly-[censored] skull mask gets forced onto Eivor's head without the hood and cape, as seen in some of the pictures provided. The Mari Lwyd cape remains visually equipped as a cape item in loading screens, cutscenes, in the tattoo shop (where Eivor is supposed to be completely topless so you can see the tattoos you have applied), in drinking games, in Orlog - basically everywhere.


    This is so immersion breaking it is absolutely ridiculous. You have a ton of badass looking hoods in the game only for them to be replaced with this disgusting Samhain costume.

    It's worth noting that even after the entire arc in Glowecestrescire, I could still go back and knock on doors in broad daylight in the glitched Mari Lwyd cape and get moldy cheeses for completing rhymes. Not sure if that's intended. Heck, a lot of things seem to be "intended" but I guess the road to glitch-heck is littered with good intentions eh?

Suggested Topics