Welcome to discussions

Quick Suggestions

  • speedynl21
    79 posts

    @ubi-woofer
    platform pc

    finished the hole main story
    everywhere where she put her hood up this dum thing override her normal hood
    it don't mater how you get to any place fast travel/foot/horse, it always show, when she put up her hood
    as for a save file i don't have any, deleted all, no point in keeping the game/save if you have done the mainline

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts
    Best Answer

    Hello everyone! 🙂

    I'm very happy to return to the thread to confirm that TU 1.1.1 - releasing today - contains a fix for this issue with the Mari Lwyd disguise. Once the patch has been fully deployed, and you have fully-updated your game to the latest version, you should find that you are (finally!) able to remove the disguise when outside of Glowecestrescire, and should no longer see it stuck over your worn armour.

    If exploring Glowecestrescire or completing the arc, please do be aware that as we mentioned before, the disguise will always involve the Mari Lwyd cloak and mask as these are part of the themed costume you wear as part of the Samhain festival in the region. Once you leave Glowecestrescire, toggling your disguise should remove the Mari Lwyd cloak and mask.

    I would like to thank you all again for the information and evidence provided throughout the developers' investigation into this issue; it was integral to getting this issue resolved, and was extremely useful to refer to. I hope that after today's patch, there'll be no further issues, but should any arise, you are of course welcome to get in touch with me here in the thread and I'll reply as soon as I am able.

    Official Response
  • Hypobox
    8 posts

    PC
    Yes completed the Burning Man quest.
    Still playing and pretty far on(80%). Been Vinland, and all other extra locations.
    None of the workarounds have worked for me

  • AJ_Nuvo
    44 posts

    @Ubi-Woofer

    • PS5
    • Completed "The Burning of the Wicker Man". Bloody 80 hours in and not going to restart the entire game for this absolute mess of a bug.
    • Cloak stays on no matter what - in Glowecestrescire, Asgard, Norway and anywhere else in England. If I go to Vinland and return to Norway/England, the stupid cloak comes back. It's on everywhere, after fast-travelling, changing regions by foot or on horseback.
    • If I unequip my cape armour piece, the cloak's ugly-[censored] skull mask gets forced onto Eivor's head without the hood and cape, as seen in some of the pictures provided. The Mari Lwyd cape remains visually equipped as a cape item in loading screens, cutscenes, in the tattoo shop (where Eivor is supposed to be completely topless so you can see the tattoos you have applied), in drinking games, in Orlog - basically everywhere.


    This is so immersion breaking it is absolutely ridiculous. You have a ton of badass looking hoods in the game only for them to be replaced with this disgusting Samhain costume.

    It's worth noting that even after the entire arc in Glowecestrescire, I could still go back and knock on doors in broad daylight in the glitched Mari Lwyd cape and get moldy cheeses for completing rhymes. Not sure if that's intended. Heck, a lot of things seem to be "intended" but I guess the road to glitch-heck is littered with good intentions eh?

  • R3b3L_21
    2 posts

    That is just not acceptable.
    So many bugs, nothing to make up for.

    Last game I buy from Ubisoft, I am tired of these [censored] for each new game.
    Had the same [censored] from Mafia 1 remake and Battlefront from EA.

    They just pushing out AAA titles before their time just to get money.

  • glenesteplaya65
    3 posts
    This post is deleted!
  • ShidaPenns
    5 posts
    This post is deleted!
  • ShidaPenns
    5 posts

    @ubi-woofer

    I'm on PS4. Yes I completed the whole Glowecestrescire arc, and I have this stupid cloak stuck on me no matter what. I've tried everything I've read about how people fixed it but nothing works for me, it's stuck there. I really hate this bug, it's ugly.

  • MonroeTheCat
    5 posts

    Thank you for your attention @ubi-woofer

    • Play on PS4
    • Yes, completed quest "The Burning of the Wicker Man" and reported to Randvi
    • Still seeing the cloak applied (and could not trigger removal) in:
      • Hamtunshire, Oxenfordscire (travel by foot, mount, and/or fast-travel)
      • Cent, Essexe, Suthexe, Grantebridgescire, Lincolnscire, Ledecestrescire, East Anglia, Norway, Jotenheim, Asgard (mount and/or fast travel)
    • Issue has been present consistently in all places outside of Glowecestrescire; with exception of Vinland
  • maxheavelar
    4 posts

    @ubi-woofer

    • Confirmation of the platform (PC)
    • Did you complete the quest "The Burning of the Wicker Man" already? (Yes, done)
    • A list of the places you have travelled to while still seeing the cloak applied, and how you got there (e.g. by foot, on your mount, fast travel) (TRY, All of that)
    • Confirmation of whether the issue has been present consistently, or intermittently; and also whether it is an issue only in some places, or all outside of Glowecestrescire (EVERY REGION)


  • Roughman01
    16 posts

    Just finished this arc tried many of the workarounds and nothing is working, clearly ubisoft could careless they got our money now, between this, multiple other glitches and the cairn stones (I suck at them on console) I think this may be the first AC I give up on

  • frostbyte2300
    1 posts

    @raphaelzoren
    I can vouch for this method, tried it 5 minutes ago and it fixed the issue for me. Luckily I had an auto save from when I had just fast traveled to ravensthorpe and even though I already had the hood up just triggering the animation for it reverted the cloak back to it's proper appearance.

  • TylerEmma2015
    76 posts

    Hi everyone has anyone actually managed to get through the whole clues and riddles quest yet as it’s the only one and that Mari lawd mask and cloak I already got off eivor I kept having a drunk screen continuously too it’s the only quest I need to complete to finish this arc

  • AJ_Nuvo
    44 posts

    I don't understand the devs still do not acknowledge it as a "Known Issue", when the posters in this thread have been providing piece after piece of evidence. Rather it's still stuck under the section where the devs insist it's not a bug. Yes we all know it's "intended" for the cloak to come on when in the Glowecestrescire region (I don't understand though - why not just remove it altogether after the arc is completed wouldn't that solve the damn problem for everyone) - but honestly we just want the devs to acknowledge that it IS a bug whenever Eivor steps out of the damn region.

  • speedynl21
    79 posts

    @aj_nuvo
    they don't care they have there money, and trying to push there crappy cashshop items on you, thats wat count for them

  • SilverToxxin
    3 posts

    I've got the platinum trophy now. This was never fixed and was a total immersion killer the whole time, but at least now they acknowledge it is a bug. So I'm done with this game for now. I'm just annoyed they want to add new outfits to buy and all of us here were not even able to even appreciate what we earned in game. Let alone the people who buy that stuff. End rant.... good luck to the rest of y'all.

  • shadowofajoke1
    6 posts

    @key2blade I had this issue and evertime a teleport back there same thing.


    Firstly once you have completed that towns story, go back home and put the costume on the shelf at the foot of your bed. Then put hood on during gameplay and that should right it. It's clunky, but it works most of the time.

  • guest-HqYVIpSP
    4 posts

    My cloak hood does not appear to have hood up when doing mission like seen on YouTube I've tried to restart latest load before mission tried everything I can think of it wont let me knock on doors he just says locked no one home

  • guest-HqYVIpSP
    4 posts

    @guest-hqyvipsp tbh this game is a let down not happy atall was looking g forward to this game for so long sh########t

  • Astro66
    3 posts

    @ubi-woofer
    Since completing the arc on Xbox 1, I cannot remove the cloak no matter where I am. It constantly replaces what I have equipped in every location no matter how you get there.

  • Rawfract
    1 posts

    Same problem, cloak will not go in any area (bar vinland). Even if I remove all gear and its still present in the tattoo change screen.

Suggested Topics

Community Details

28
Online
131.0k
Users
22.7k
Topics
117.9k
Posts