Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Roughman01
    16 posts

    Just finished this arc tried many of the workarounds and nothing is working, clearly ubisoft could careless they got our money now, between this, multiple other glitches and the cairn stones (I suck at them on console) I think this may be the first AC I give up on

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts
    Best Answer

    Hello everyone! 🙂

    I'm very happy to return to the thread to confirm that TU 1.1.1 - releasing today - contains a fix for this issue with the Mari Lwyd disguise. Once the patch has been fully deployed, and you have fully-updated your game to the latest version, you should find that you are (finally!) able to remove the disguise when outside of Glowecestrescire, and should no longer see it stuck over your worn armour.

    If exploring Glowecestrescire or completing the arc, please do be aware that as we mentioned before, the disguise will always involve the Mari Lwyd cloak and mask as these are part of the themed costume you wear as part of the Samhain festival in the region. Once you leave Glowecestrescire, toggling your disguise should remove the Mari Lwyd cloak and mask.

    I would like to thank you all again for the information and evidence provided throughout the developers' investigation into this issue; it was integral to getting this issue resolved, and was extremely useful to refer to. I hope that after today's patch, there'll be no further issues, but should any arise, you are of course welcome to get in touch with me here in the thread and I'll reply as soon as I am able.

    Official Response
  • frostbyte2300
    1 posts

    @raphaelzoren
    I can vouch for this method, tried it 5 minutes ago and it fixed the issue for me. Luckily I had an auto save from when I had just fast traveled to ravensthorpe and even though I already had the hood up just triggering the animation for it reverted the cloak back to it's proper appearance.

  • TylerEmma2015
    76 posts

    Hi everyone has anyone actually managed to get through the whole clues and riddles quest yet as it’s the only one and that Mari lawd mask and cloak I already got off eivor I kept having a drunk screen continuously too it’s the only quest I need to complete to finish this arc

  • AJ_Nuvo
    44 posts

    I don't understand the devs still do not acknowledge it as a "Known Issue", when the posters in this thread have been providing piece after piece of evidence. Rather it's still stuck under the section where the devs insist it's not a bug. Yes we all know it's "intended" for the cloak to come on when in the Glowecestrescire region (I don't understand though - why not just remove it altogether after the arc is completed wouldn't that solve the damn problem for everyone) - but honestly we just want the devs to acknowledge that it IS a bug whenever Eivor steps out of the damn region.

  • speedynl21
    79 posts

    @aj_nuvo
    they don't care they have there money, and trying to push there crappy cashshop items on you, thats wat count for them

  • SilverToxxin
    3 posts

    I've got the platinum trophy now. This was never fixed and was a total immersion killer the whole time, but at least now they acknowledge it is a bug. So I'm done with this game for now. I'm just annoyed they want to add new outfits to buy and all of us here were not even able to even appreciate what we earned in game. Let alone the people who buy that stuff. End rant.... good luck to the rest of y'all.

  • shadowofajoke1
    6 posts

    @key2blade I had this issue and evertime a teleport back there same thing.


    Firstly once you have completed that towns story, go back home and put the costume on the shelf at the foot of your bed. Then put hood on during gameplay and that should right it. It's clunky, but it works most of the time.

  • guest-HqYVIpSP
    4 posts

    My cloak hood does not appear to have hood up when doing mission like seen on YouTube I've tried to restart latest load before mission tried everything I can think of it wont let me knock on doors he just says locked no one home

  • guest-HqYVIpSP
    4 posts

    @guest-hqyvipsp tbh this game is a let down not happy atall was looking g forward to this game for so long sh########t

  • Astro66
    3 posts

    @ubi-woofer
    Since completing the arc on Xbox 1, I cannot remove the cloak no matter where I am. It constantly replaces what I have equipped in every location no matter how you get there.

  • Rawfract
    1 posts

    Same problem, cloak will not go in any area (bar vinland). Even if I remove all gear and its still present in the tattoo change screen.

  • Elyos86
    2 posts

    @ubi-woofer why is this additional information required? This was flagged as a bug more than a month ago and it still has not been fixed. I have put up with countless bugs (2 x mounts summoned, Tarben romance glitch, quest bugs in Lunden, In Dreams still broken to name a few) in my 100 + hours of gameplay and this is the final bug I’m willing to put up with. Why is this still not fixed?!

  • Jackyboyy23
    1 posts

    @smash1295 this is the only one that has worked! Thank you

  • MrFhob
    1 posts

    @ubi-woofer
    Also having this issue. 
    On Xbox One
    I have completed the glowecestrescire arc entirely. 
    Cloak and skull persist outside of glowecestrescire in every area and cutscene except for Vinland. 
    Persists while exiting glowecestrescire by fast travel and by foot/horse.
    None of the posted workarounds have had any effect.

    Really takes you out of the game to go through Asgard with this cloak stuck on you.
    Would have made more sense to have this cloak as a unique item.

  • OxIdOAC
    22 posts

    @ubi-woofer

    1. PC
    2. Yes
    3. Everywhere! By foot, horse, fast travel, fling, boat, you name it i use it....
    4. Confirmation? I completed the game with this bug, which is around 20~30 hours after i completed The Burning...... quest. Is it enough?
  • AJ_Nuvo
    44 posts

    So Ubi could push out a hotfix for the Fast Travel bug but not this. Also, not even an acknowledgement by the devs of this bug.

    What is taking so long? This has to be some kind of a joke. Is this that difficult to fix/verify? Good gracious and you prioritise pushing out microtransactions without bothering to see how much of a mess your base game is.

  • UrbanEngineer
    1 posts

    When this critical bug fixed?
    I couldn't find any solution even though I tried everything.(ex: restart PC, On/Off hide option equipment, take off all Items etc)

    I'm very upset that I spent almost $ 100 on this game.






  • Roughman01
    16 posts

    I was genuinely considering buying some of the armors in the shop but if this is how they're treating us then I think I'll stay clear of them as there's no point if I cant even see it, this game needed more time before being released as the buggy mess it is.

  • scottyusceaser1
    34 posts

    @vanarlen I spared them both still have the problem

  • scottyusceaser1
    34 posts

    playing on PC

    Same as this comment.....

    • underwater
    • every area (Asgard, Jotunheim, etc.)
    • every single time (Cutscenes, Tattoo Shop, even when all other armour piece is turned off)
    • when i am not wearing a cloak piece (Armor), the deer skull is on the face of the character without the hood
    • nothing really helps - even uninstalling the whole game/deleting the save etc. it ALWAYS comes back
    • can't see tattoos in the shop
    • can't properly shoot with predator bow, because the fur blocks half of the screen


    but im 189 hours in... this bug is game breaking.

Suggested Topics

Community Details

14
Online
129.0k
Users
22.2k
Topics
115.0k
Posts