ubisoft discussions

quick-suggestions

  • locked topic_solved [RESOLVED] Unable to remove the Mari Lwyd cloak from Eivor | POST HERE

    29 likes/747 replies/80595 views
    R3b3L_21
    ubisoft:x-posts, 2

    That is just not acceptable.
    So many bugs, nothing to make up for.

    Last game I buy from Ubisoft, I am tired of these [censored] for each new game.
    Had the same [censored] from Mafia 1 remake and Battlefront from EA.

    They just pushing out AAA titles before their time just to get money.

  • glenesteplaya65
    ubisoft:x-posts, 3
    post_is_deleted
  • ShidaPenns
    ubisoft:x-posts, 5
    post_is_deleted
  • ShidaPenns
    ubisoft:x-posts, 5

    @ubi-woofer

    I'm on PS4. Yes I completed the whole Glowecestrescire arc, and I have this stupid cloak stuck on me no matter what. I've tried everything I've read about how people fixed it but nothing works for me, it's stuck there. I really hate this bug, it's ugly.

  • MonroeTheCat
    ubisoft:x-posts, 5

    Thank you for your attention @ubi-woofer

    • Play on PS4
    • Yes, completed quest "The Burning of the Wicker Man" and reported to Randvi
    • Still seeing the cloak applied (and could not trigger removal) in:
      • Hamtunshire, Oxenfordscire (travel by foot, mount, and/or fast-travel)
      • Cent, Essexe, Suthexe, Grantebridgescire, Lincolnscire, Ledecestrescire, East Anglia, Norway, Jotenheim, Asgard (mount and/or fast travel)
    • Issue has been present consistently in all places outside of Glowecestrescire; with exception of Vinland
  • maxheavelar
    ubisoft:x-posts, 4

    @ubi-woofer

    • Confirmation of the platform (PC)
    • Did you complete the quest "The Burning of the Wicker Man" already? (Yes, done)
    • A list of the places you have travelled to while still seeing the cloak applied, and how you got there (e.g. by foot, on your mount, fast travel) (TRY, All of that)
    • Confirmation of whether the issue has been present consistently, or intermittently; and also whether it is an issue only in some places, or all outside of Glowecestrescire (EVERY REGION)


  • Roughman01
    ubisoft:x-posts, 16

    Just finished this arc tried many of the workarounds and nothing is working, clearly ubisoft could careless they got our money now, between this, multiple other glitches and the cairn stones (I suck at them on console) I think this may be the first AC I give up on

  • frostbyte2300
    ubisoft:x-posts, 1

    @raphaelzoren
    I can vouch for this method, tried it 5 minutes ago and it fixed the issue for me. Luckily I had an auto save from when I had just fast traveled to ravensthorpe and even though I already had the hood up just triggering the animation for it reverted the cloak back to it's proper appearance.

  • TylerEmma2015
    ubisoft:x-posts, 76

    Hi everyone has anyone actually managed to get through the whole clues and riddles quest yet as it’s the only one and that Mari lawd mask and cloak I already got off eivor I kept having a drunk screen continuously too it’s the only quest I need to complete to finish this arc

  • AJ_Nuvo
    ubisoft:x-posts, 44

    I don't understand the devs still do not acknowledge it as a "Known Issue", when the posters in this thread have been providing piece after piece of evidence. Rather it's still stuck under the section where the devs insist it's not a bug. Yes we all know it's "intended" for the cloak to come on when in the Glowecestrescire region (I don't understand though - why not just remove it altogether after the arc is completed wouldn't that solve the damn problem for everyone) - but honestly we just want the devs to acknowledge that it IS a bug whenever Eivor steps out of the damn region.

  • speedynl21
    ubisoft:x-posts, 79

    @aj_nuvo
    they don't care they have there money, and trying to push there crappy cashshop items on you, thats wat count for them

  • SilverToxxin
    ubisoft:x-posts, 3

    I've got the platinum trophy now. This was never fixed and was a total immersion killer the whole time, but at least now they acknowledge it is a bug. So I'm done with this game for now. I'm just annoyed they want to add new outfits to buy and all of us here were not even able to even appreciate what we earned in game. Let alone the people who buy that stuff. End rant.... good luck to the rest of y'all.

  • shadowofajoke1
    ubisoft:x-posts, 6

    @key2blade I had this issue and evertime a teleport back there same thing.


    Firstly once you have completed that towns story, go back home and put the costume on the shelf at the foot of your bed. Then put hood on during gameplay and that should right it. It's clunky, but it works most of the time.

  • guest-HqYVIpSP
    ubisoft:x-posts, 4

    My cloak hood does not appear to have hood up when doing mission like seen on YouTube I've tried to restart latest load before mission tried everything I can think of it wont let me knock on doors he just says locked no one home

  • guest-HqYVIpSP
    ubisoft:x-posts, 4

    @guest-hqyvipsp tbh this game is a let down not happy atall was looking g forward to this game for so long sh########t

  • Astro66
    ubisoft:x-posts, 3

    @ubi-woofer
    Since completing the arc on Xbox 1, I cannot remove the cloak no matter where I am. It constantly replaces what I have equipped in every location no matter how you get there.

  • Rawfract
    ubisoft:x-posts, 1

    Same problem, cloak will not go in any area (bar vinland). Even if I remove all gear and its still present in the tattoo change screen.

  • Elyos86
    ubisoft:x-posts, 2

    @ubi-woofer why is this additional information required? This was flagged as a bug more than a month ago and it still has not been fixed. I have put up with countless bugs (2 x mounts summoned, Tarben romance glitch, quest bugs in Lunden, In Dreams still broken to name a few) in my 100 + hours of gameplay and this is the final bug I’m willing to put up with. Why is this still not fixed?!

  • Jackyboyy23
    ubisoft:x-posts, 1

    @smash1295 this is the only one that has worked! Thank you

  • MrFhob
    ubisoft:x-posts, 1

    @ubi-woofer
    Also having this issue. 
    On Xbox One
    I have completed the glowecestrescire arc entirely. 
    Cloak and skull persist outside of glowecestrescire in every area and cutscene except for Vinland. 
    Persists while exiting glowecestrescire by fast travel and by foot/horse.
    None of the posted workarounds have had any effect.

    Really takes you out of the game to go through Asgard with this cloak stuck on you.
    Would have made more sense to have this cloak as a unique item.

Suggested Topics