Welcome to discussions

Quick Suggestions

  • MrMontr
    4 posts


    I've never been one too really complain about game bugs as they're bound too happen, I've overlooked so many in this game thus far and this one may not be game breaking but damn does it ruin the immersion.

    This message like many others will most likely fall on deaf ears but this bug is real, yes it may be "intended" too have it on when in the Glowecestrescire area but when you travel too every other region on the map and you still have the cloak and horse mask on I'm sure isn't "working as inteneded" especially when you've stripped off all your armour and the cloak still remains on with the horse mask clipping through your face...

    I've put about 150 hours into the game so far and purchased many items with helix credits just too now not be able too even see half of what I've purchased.

    Please push a fix for this in the upcoming patch, I want too continue playing this awesome game and future titles too come.

  • Ubi-Woofer
    Ubisoft Support Staff 1036 posts
    Best Answer

    Hello everyone! 🙂

    I'm very happy to return to the thread to confirm that TU 1.1.1 - releasing today - contains a fix for this issue with the Mari Lwyd disguise. Once the patch has been fully deployed, and you have fully-updated your game to the latest version, you should find that you are (finally!) able to remove the disguise when outside of Glowecestrescire, and should no longer see it stuck over your worn armour.

    If exploring Glowecestrescire or completing the arc, please do be aware that as we mentioned before, the disguise will always involve the Mari Lwyd cloak and mask as these are part of the themed costume you wear as part of the Samhain festival in the region. Once you leave Glowecestrescire, toggling your disguise should remove the Mari Lwyd cloak and mask.

    I would like to thank you all again for the information and evidence provided throughout the developers' investigation into this issue; it was integral to getting this issue resolved, and was extremely useful to refer to. I hope that after today's patch, there'll be no further issues, but should any arise, you are of course welcome to get in touch with me here in the thread and I'll reply as soon as I am able.

    Official Response
  • Roughman01
    16 posts

    Just checked latest patch notes, think we've essentially been told to go [censored] ourselves, can't see a fix

  • speedynl21
    79 posts

    quess this was more importend ( Addressed instances where players were able to open barred doors with the Dive of the Valkyries ability )
    no more opening barred doors

    but a real bug like this dum cloak will not be fixed
    good thing i already did the hole main line and uninstalled the game some time ago
    maybe in a year or so, IF all is fixed then i take a look again

  • Roughman01
    16 posts

    @speedynl21 sadly I didn't finish the main quest and no matter what I do I can't remove it, think till be my first AC I don't finish though it'll be last one I buy

  • AJ_Nuvo
    44 posts

    @Ubi-Woofer @UbiQuB3

    So as others above have stated - new patch notes but this bug isn't even within. There are two possibilities

    1. You guys didn't even bother to put it to the devs/didn't even bother testing it
    2. The devs got your message, but couldn't be arsed to deal with it

    If this is the level of pride you put into the game and the dedication you give to serving the gamerbase which paid for the game (as well as your other Helix store items), then you are lacking. Sorely lacking.

    I've been playing AC since AC1, have gone through ups and downs, but this is the first time I see the dev team so unwilling to investigate player reports and indisputable evidence. Why, for the love of all that's good, do you simply not bother?

    Do you need us to reiterate? The Mari Lwyd cloak appears and is stuck on Eivor even after the Glowecestrescire arc, outside of Glowecestrescire (definitely not intended). It is on in Asgard, Jotunheim, Norway and the rest of God's good land of England. It appears in the tattoo shop screens and in cutscenes and when the cloak (whichever - Brigandine, Galloglach, Thegn etc) is unequipped as an armour item, the ugly as heck horseskull gets forced onto Eivor's face. You tell me if that's intended.

    Can you goddamn fix this already?

  • DayusMakhina
    1 posts

    @aj_nuvo Too right. It's messed up for me too.

  • D-Kruger
    18 posts

    Found not a fix, but a workaround. If you equip Bayek's outfit, the cloak disappears. It's not good enough for me, since I want Eivor to look like a viking, but maybe someone will benefit from it.

  • Hypobox
    8 posts

    Well at least we get xmas stuff that we cant see...AS WE ARE STUCK IN HALOWEEEN!!!

  • AJ_Nuvo
    44 posts

    I am not sure why this can't be hotfixed. Immersion is as good a reason as progression to hotfix anything. It's just a matter of removing the goddamn cloak once the Glowecestrescire arc completes, as well as any glitched cloaks Eivor may have gotten. If you tell me that's rocket science in the field of game design, then I concede. But you can push out hotfixes for quest bugs so this doesn't seem too far off. Good gracious.

  • nimz2011
    3 posts




    Ive been to the witch locations by fast travel. Travelled to Lincolnshire but the cloak still wont go away. Im trying to get the Thor pieces

  • AJ_Nuvo
    44 posts

    So. Patch is downloaded, cloak of shame is still there.

    [censored] taking the [censored] out of us.

  • D-Kruger
    18 posts
    This post is deleted!
  • D-Kruger
    18 posts

    @aj_nuvo They are so useless.

  • MrsFrostbitn
    1 posts

    I was so hoping the update would fix this but nope. I'm up to Holy Day quest and the stupid cloak is still there!!

  • Roughman01
    16 posts

    And that's me still not playing or contributing to the helix store as I've still got the cloak, ubisoft are major [censored] ups, think I'll just leave this game till the future as they clearly are just leaving fixing this issue, this has really soured me on ubisoft games for the future think I'll be blacklisting these

  • Hypobox
    8 posts

    Updated, still cloak stuck.

  • LSDSkycoke
    8 posts

    Same here, i definitly think UBi doesnt even care the clients...

  • D-Kruger
    18 posts

    @roughman01 They already have your money, why would they care?

  • k0k066
    11 posts

    Have the same problem tried many things with no luck of course , I have abandonded the game for a week now , heard about 1.1 , downloaded it hoping it was going to fix it aaaaaaand nothing

  • AJ_Nuvo
    44 posts

    @Ubi-Woofer can you at least provide an update and not just leave us to wait in the dark?

    It's rather hopeless as it is as you guys at Ubi support are the only ones who can fight our case before the devs. If even you guys are remaining silent, this bug looks like it will never be investigated by the devs.

Suggested Topics

Community Details