Welcome to discussions

Quick Suggestions

  • LSDSkycoke
    8 posts

    Same here, i definitly think UBi doesnt even care the clients...

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts
    Best Answer

    Hello everyone! 🙂

    I'm very happy to return to the thread to confirm that TU 1.1.1 - releasing today - contains a fix for this issue with the Mari Lwyd disguise. Once the patch has been fully deployed, and you have fully-updated your game to the latest version, you should find that you are (finally!) able to remove the disguise when outside of Glowecestrescire, and should no longer see it stuck over your worn armour.

    If exploring Glowecestrescire or completing the arc, please do be aware that as we mentioned before, the disguise will always involve the Mari Lwyd cloak and mask as these are part of the themed costume you wear as part of the Samhain festival in the region. Once you leave Glowecestrescire, toggling your disguise should remove the Mari Lwyd cloak and mask.

    I would like to thank you all again for the information and evidence provided throughout the developers' investigation into this issue; it was integral to getting this issue resolved, and was extremely useful to refer to. I hope that after today's patch, there'll be no further issues, but should any arise, you are of course welcome to get in touch with me here in the thread and I'll reply as soon as I am able.

    Official Response
  • D-Kruger
    18 posts

    @roughman01 They already have your money, why would they care?

  • k0k066
    11 posts

    Have the same problem tried many things with no luck of course , I have abandonded the game for a week now , heard about 1.1 , downloaded it hoping it was going to fix it aaaaaaand nothing

  • AJ_Nuvo
    44 posts

    @Ubi-Woofer can you at least provide an update and not just leave us to wait in the dark?

    It's rather hopeless as it is as you guys at Ubi support are the only ones who can fight our case before the devs. If even you guys are remaining silent, this bug looks like it will never be investigated by the devs.

  • shyam3010
    84 posts

    @aj_nuvo looks like we’ll have to keep our fingers crossed for another month, hoping that they’ll get the next patch right.

  • speedynl21
    79 posts

    dev's say this
    Mari Lwyd costume applied after completing the Glowecestrescire arc
    Note: This is intended behaviour. The Mari Lwyd costume will be applied over the disguise when roaming the Glowecestrescire territory

    yea for that arc, not for the rest of the world
    give it a year and maybe its fixed then

    in the mean time they keep pumping worthless [censored] into there cashshop(come buy it now, buy helix, come on, do it now)
    we don't care for the bugs, we want your money

  • D-Kruger
    18 posts

    This [censored] makes me SO angry.

  • BlueOnAir
    3 posts

    I'm getting [censored] tired of Bugisoft. You guys are completely incapabable of listening to your PAYING customers when they reports YOUR mess, and you don't even care enough to try to do something about it. Like temporarily deleting the cape from the game, the time for the code monkeys working at your studios to figure out how a PC works.

    You're a [censored] disgrace as a company, maybe even worse than EA.

  • D-Kruger
    18 posts

    Is there a way to somehow edit the savegame maybe? I tried with inventory editor, but it didn't help.

  • Roughman01
    16 posts

    @d-kruger that's it I just presume they don't anymore, but was kinda hoping to get some of the helix store items but there's not much point if I cant see them

  • scottyusceaser1
    34 posts

    [censored].... isn't it fixed???!?!?! ..

  • scottyusceaser1
    34 posts

    Mari Lwyd cloak is STILL bugged.... even with the enormous amount of reports from players, this is still not fixed. I suppose putting out a event is much more important than fixing a bug that breaks the games enjoyment.

  • scottyusceaser1
    34 posts

    @aj_nuvo Well said, literally everything that needs to be said you've stated! Now we need a response.

  • AJ_Nuvo
    44 posts

    Maybe if some users can provide their save files (for PC and PS4), that might speed things along.

    I honestly don't get why we need save files. The evidence is overwhelming enough for the devs to just look at the code and see what went wrong. I believe @Damo_77 already provided an example save file.

  • MrMontr
    4 posts

    @aj_nuvo how do you provide a save file ??

  • AJ_Nuvo
    44 posts

    @mrmontr I believe for PS4, you extract it onto a USB and upload it here somehow. Don't think it differs much for a PC.

    I've a mind to upload my PS5 save file to just show them how scuppered the immersion is, since they somehow need all this data to prove the existence of bugs that are clearly depicted through pictures.

  • MrMontr
    4 posts

    @aj_nuvo if only I had a pc too do it I would, I don't even have the energy too play the game anymore knowing just how ignorant the devs are being too an obvious bug, I put over 150 hours and spent so much with helix also and for what... they don't care.

  • cclarke98
    3 posts

    Cloak from mission stayed equipped after end of glowecestrescire arc end. Won’t allow me to change cloaks and stays equipped in tattoo and hair menu, when it unequips everything from Eivor. Makes me wish I never bought the game. What’s the point if I can’t look badass. Please fix in next patch. Thank you

  • AJ_Nuvo
    44 posts

    This is the reply I got from Ubi Support:

    Hi there, AJ_Nuvo.

    Thank you for contacting Ubisoft Customer Support, and thank you for all of the information you have provided.

    I am going to send you some troubleshooting steps I would like you to try.

    Your best option is to start by resetting the console display and audio settings. If that does not work, try lowering your display output resolution.

    If you become unable to use add-on content or start content downloaded from the PlayStation Store, restoring your licenses might fix the problem.

    From the PlayStation Dashboard:
    1. Select Settings
    2. Select Users and Accounts
    3. Scroll down to Other, then the option to Restore Licenses
    4. Select Restore

    This should check to be sure that any content on your console matches your account's privileges.

    If you continue to experience trouble then, based on what you’ve described of the issue, it sounds like some of the game files may have been damaged or corrupted, and aren’t working correctly.

    For this issue, I recommend that you try clearing your PS5 Game Data Utility files. Doing so will clear any install / update data and DLC content.

    Note: All DLC items can be re-downloaded. Exclusive Content is tied to the account and does not need to be re-downloaded.

    1. Navigate to your Settings.
    2. Select Storage, then choose the the desired storage device.
    3. Select the content that you want to delete under Games and Apps
    4. Select Delete.

    Once that's done, you can proceed to reinstall the game. If you own a physical copy of the game, disconnect your console from the internet while the disc content is installing. Once it's finished, you can reconnect to the internet, and allow the remaining DLC and updates to download.

    Please avoid launching the game until after all content and updates have finished installing to your PlayStation 5.

    After doing this, try launching the game again.

    If the issue persists, test your game disc on a second console. If you have a digital copy of the game, download that copy to your account on the second console instead.
    In some cases, you could have a bad game disc. Please try testing your game on a second console to determine if you have the same results.

    If you have the same issue on a second console, please try exchanging your game disc at the retailer for a new copy.

    Additionally, try testing your save on a second console as well to make sure that your save files are all working correctly.

    Please let me know if you continue to experience issues after this.

    If this does not work please upload your save files for investigation! https://support.ubisoft.com/en-US/Article/000080981 This link will help you with completing this.

    Kindly,
    Ubi-SushiVampire
    Ubisoft Customer Support

    Ugh. You could've just said "go [censored] yourself" and it would have been clear. What's the point of having a support channel when all you're going to do is give stock responses?

  • zolkiss89
    6 posts

    I have the same problem on the PS5. The whole arc is done, but that stupid mask is there. I tried several thing, like unequipping the gears, saving, loading. The only time, when it was not available when I travelled to Jotunheim and Asgard, didn't tried Vinland yet. After coming back to Midgard, I got that cloak and skull back.
    I finished the arc with the latest patch, but this is ridiculous, that this is the third breaking bug, which cannot be resolved. The first, I couldn't speak with Ubba, and I had to restart the whole campaing because of it. Now I will not restart, since I have 80 hours in it, and I'm sure that I'll wait next one year before buying any damn Ubisoft game, since they are released in an Earyl Access state.
    Especially when a bug occur, the first answer is try to restart the campaing...

Suggested Topics

Community Details

56
Online
130.6k
Users
22.6k
Topics
117.5k
Posts