Welcome to discussions

Quick Suggestions

  • MonroeTheCat
    5 posts

    @Ubi-Woofer
    Could we please get an update on where the devs are at with this issue? Trying to be patient but it is wearing very thin (unlike the cloak, which is a huge eyesore). Save files have been provided and as it is clear this is not an isolated issue it would be good to know if this will be resolved. Or if the dev team simply feels players should move on from the game if they don’t like it...


  • Ubi-Woofer
    Ubisoft Support Staff 713 posts
    Best Answer

    Hello everyone! 🙂

    I'm very happy to return to the thread to confirm that TU 1.1.1 - releasing today - contains a fix for this issue with the Mari Lwyd disguise. Once the patch has been fully deployed, and you have fully-updated your game to the latest version, you should find that you are (finally!) able to remove the disguise when outside of Glowecestrescire, and should no longer see it stuck over your worn armour.

    If exploring Glowecestrescire or completing the arc, please do be aware that as we mentioned before, the disguise will always involve the Mari Lwyd cloak and mask as these are part of the themed costume you wear as part of the Samhain festival in the region. Once you leave Glowecestrescire, toggling your disguise should remove the Mari Lwyd cloak and mask.

    I would like to thank you all again for the information and evidence provided throughout the developers' investigation into this issue; it was integral to getting this issue resolved, and was extremely useful to refer to. I hope that after today's patch, there'll be no further issues, but should any arise, you are of course welcome to get in touch with me here in the thread and I'll reply as soon as I am able.

    Official Response
  • shyam3010
    84 posts

    @monroethecat Good luck getting any sort of meaningful reply. I've made two threads about the game constantly crashing on my PS4, and I've discovered that it's largely affecting PS5 and PC users too. Guess what? This issue isn't even on the known issues thread or on the reported issues megathread.

    They've taken our money and buried their heads in the sand.

  • AJ_Nuvo
    44 posts

    If it's any comfort at all, here's what I got from my latest exchange with Support:

    Hi there, AJ_Nuvo.

    Thank you for contacting Ubisoft Customer Support, I am sorry that you feel as though we send a stock response.

    I sent our PlayStation 5 troubleshooting.

    Our game developers are investigating this issue. As soon as there is a fix for this it will be posted on the forums.

    Again, I am sorry you felt as though a stock response was sent. This is being investigated, I hope you have a good night.

    Kindly,
    Ubi-SushiVampire
    Ubisoft Customer Support

  • speedynl21
    79 posts

    @aj_nuvo

    the first post about this bug was made ( Nov 16, 2020 )
    and they are still investigating it ?, yea sure

  • AJ_Nuvo
    44 posts

    @speedynl21 better than nothing I guess. Forcing our way now doesn't seem to be yielding results.

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    Hello everyone,

    I've checked in on this issue and am pleased to say that a fix is now scheduled for a future update. I've not received further details of when the patch will drop just yet however as soon as I know, you will all be informed!

    Thank you again to everyone who took the time to answer my questions, provide images and videos, and contribute to the overall investigation. Your help has been invaluable in allowing the developers to isolate the issue and resolve it.

    Please let me know if you have any questions, concerns or feedback, and have a great rest of your week! 🙂

    Official Response
  • superhunter481
    1 posts

    Yeah I've tried all the different ways to work around the bug that I've found on here and on reddit. I went back to glowechester and knocked on every door I could then went back to Ravensthorpe and unequipped all my gear and tried my cloak and suddenly all the Raven Clan gear was re equipped but the Samhain cloak remained

  • Aday12285
    1 posts

    Same issue, this has ruined the game for me. Will not be playing until this is fixed.

  • D-Kruger
    18 posts

    @ubi-woofer Thank you, let's hope it's this year.

  • Roughman01
    16 posts

    @ubi-woofer bout time we got a response, hopefully it's fixed sooner rather than later as you got people missing out on the Christmas stuff because of a stupid bug

  • Kormac67
    582 posts

    @d-kruger You don't honestly believe that.

  • D-Kruger
    18 posts

    @kormac67 I said let's hope 🙂

  • speedynl21
    79 posts

    its still sit under gameplay bugs
    not under resolved

  • Th3PR1NC333
    1 posts

    After completing “Glowecestrescire” I can’t remove/take off the cloak or the mask that was given to me. I tried everything by switching cloaks, removing all my gear, restarting the game. Nothing works..please fix. I don’t want to continue playing the game like this.

  • Matt_Thor_
    1 posts

    @Ubi-Woofer
    And now I have this bug aswell, great.
    On PS5
    Tried every tip posted on here
    Fast travelled too 5 different areas and hasn't gone. Unequipped/equipped it, hidden it, changed cloaks, helmets, unequipped everything and still this cloak stays on
    Very annoying and is ruining the game for me, as I have just finally upgraded all my gear too mythical but can't see it.
    Won't be playing this until this is fixed. I was shocked when first read how long ago this was first posted and still no fix. Unacceptable!

  • MonroeTheCat
    5 posts

    @ubi-woofer
    Thanks for the update! Definitely hoping it’s part of a patch very soon so I can get back to playing - and dreaming of getting to light the Mari Lwyd cloak and mask on fire, never to be seen again 🔥

  • frostyginger52
    1 posts

    Glowecestrescire cloak is stuck on me. Can't remove it at all. Makes me look stupid in the cutscenes. Please help

  • AWALL1700
    1 posts

    This really sucks. No fixes work. Fix it fast or give me my money back. I paid for a WORKING game damnit! No more putting out unfinished games! Fucks sake!

  • Chabz_Ast
    4 posts

    After completing the Glowecestrescire Arc The silly Mari lwyd mask is stuck on Eivor, even in other regions of the map, i cannot remove this stupid mask, if i unequip my cloak the mask remains on Eivors face

  • rodjedi
    2 posts

    @ubi-woofer Hi! The game will be long forgotten till it will be fixed. Not a good business policy. Is it so hard to make it a changeable gear?

Suggested Topics

Community Details

34
Online
130.9k
Users
22.7k
Topics
117.9k
Posts