ubisoft discussions

Quick Suggestions

  • Ubi-Woofer
    Ubisoft Support Staff 1268 posts

    Hello everyone,

    I've checked in on this issue and am pleased to say that a fix is now scheduled for a future update. I've not received further details of when the patch will drop just yet however as soon as I know, you will all be informed!

    Thank you again to everyone who took the time to answer my questions, provide images and videos, and contribute to the overall investigation. Your help has been invaluable in allowing the developers to isolate the issue and resolve it.

    Please let me know if you have any questions, concerns or feedback, and have a great rest of your week! 🙂

    Official Response
  • superhunter481
    1 posts

    Yeah I've tried all the different ways to work around the bug that I've found on here and on reddit. I went back to glowechester and knocked on every door I could then went back to Ravensthorpe and unequipped all my gear and tried my cloak and suddenly all the Raven Clan gear was re equipped but the Samhain cloak remained

  • Aday12285
    1 posts

    Same issue, this has ruined the game for me. Will not be playing until this is fixed.

  • D-Kruger
    18 posts

    @ubi-woofer Thank you, let's hope it's this year.

  • Roughman01
    16 posts

    @ubi-woofer bout time we got a response, hopefully it's fixed sooner rather than later as you got people missing out on the Christmas stuff because of a stupid bug

  • Kormac67
    1024 posts

    @d-kruger You don't honestly believe that.

  • D-Kruger
    18 posts

    @kormac67 I said let's hope 🙂

  • speedynl21
    79 posts

    its still sit under gameplay bugs
    not under resolved

  • Th3PR1NC333
    1 posts

    After completing “Glowecestrescire” I can’t remove/take off the cloak or the mask that was given to me. I tried everything by switching cloaks, removing all my gear, restarting the game. Nothing works..please fix. I don’t want to continue playing the game like this.

  • Matt_Thor_
    1 posts

    And now I have this bug aswell, great.
    On PS5
    Tried every tip posted on here
    Fast travelled too 5 different areas and hasn't gone. Unequipped/equipped it, hidden it, changed cloaks, helmets, unequipped everything and still this cloak stays on
    Very annoying and is ruining the game for me, as I have just finally upgraded all my gear too mythical but can't see it.
    Won't be playing this until this is fixed. I was shocked when first read how long ago this was first posted and still no fix. Unacceptable!

  • MonroeTheCat
    5 posts

    Thanks for the update! Definitely hoping it’s part of a patch very soon so I can get back to playing - and dreaming of getting to light the Mari Lwyd cloak and mask on fire, never to be seen again 🔥

  • frostyginger52
    1 posts

    Glowecestrescire cloak is stuck on me. Can't remove it at all. Makes me look stupid in the cutscenes. Please help

  • AWALL1700
    1 posts

    This really sucks. No fixes work. Fix it fast or give me my money back. I paid for a WORKING game damnit! No more putting out unfinished games! Fucks sake!

  • Chabz_Ast
    4 posts

    After completing the Glowecestrescire Arc The silly Mari lwyd mask is stuck on Eivor, even in other regions of the map, i cannot remove this stupid mask, if i unequip my cloak the mask remains on Eivors face

  • rodjedi
    2 posts

    @ubi-woofer Hi! The game will be long forgotten till it will be fixed. Not a good business policy. Is it so hard to make it a changeable gear?

  • rixcoast
    3 posts

    I was unable to take off the cloak/mask after completing the main quest line. Tried most of the suggestions but nothing worked.

    I eventually managed to fix it by reloading a manual save I made immediately when I returned to Raventhorpe after finishing the main quest line. After loading the save, the new Yuletide Festival message immediately displayed and the Yuletide intro cut scene played. During the cut scene I had on the cloak, but when I got control of Eivor I was immediately able to take it off and it hasn't appeared since.

    Might not work for everyone but thought I would share just in case it helped someone out.

  • zolkiss89
    6 posts

    So I just tried the following steps:
    1, Removed the game from the PS5
    2, Turned-Off the PS Plus save game sync for the game
    3, Removed the local save game
    4, Reinstalled the game
    5, Copied the save games from the Plus storage
    6, Turned-On the PS Plus Save game sync for the game

    After the login, the cloak and the mask were gone, and still not came back since them. So this helped me.
    If you don't have a PS Plus subscription, please don't remove your save game, since on PS5 you cannot backup them on external drive (what a shame)

  • AtomikNinja98
    2 posts

    I’m sure there have been others reporting this issue but I mean it’s game breaking! When you do the glowecestrescire arc Gunnar gives you a costume to go knock on people’s doors. After this part of the arc the costume is now stuck on my character. Finished the arc went talked to randvi and it’s still there. Cloak and skull mask will not go away. I mean people were complaining about this a month ago so I don’t know why it’s not fixed. Seems like you guys half a**ed it. Also multiple bugs with Yuletide festival. I mean it’s a timed event and you release it with bugs that make it to where you cant even do the missions? Come on Ubisoft.

  • AtomikNinja98
    2 posts

    Gunnar gives you a costume for Mari lywd or something and it will not go away after completing the arc. I mean this issue was reported a month ago. Woulda thought you would have it patched by now. It’s game breaking. Even when I remove all gear it’s still there. When I go to the tattoo shop I can’t even see the tattoos because it’s one my character 24/7.

  • AJ_Nuvo
    44 posts

    @zolkiss89 can anyone else vouch for this method? I can't play this weekend due to work.

    @Ubi-Woofer thanks for the response. Something's looking up, at least.

Suggested Topics