Welcome to discussions

Quick Suggestions

  • hoodlumgoose
    1 posts

    @lowerdanny omg it worked! The cloak immediately flickered and went back to my original. Thanks for reposting this! ☺

  • Ubi-Woofer
    Ubisoft Support Staff 782 posts
    Best Answer

    Hello everyone! 🙂

    I'm very happy to return to the thread to confirm that TU 1.1.1 - releasing today - contains a fix for this issue with the Mari Lwyd disguise. Once the patch has been fully deployed, and you have fully-updated your game to the latest version, you should find that you are (finally!) able to remove the disguise when outside of Glowecestrescire, and should no longer see it stuck over your worn armour.

    If exploring Glowecestrescire or completing the arc, please do be aware that as we mentioned before, the disguise will always involve the Mari Lwyd cloak and mask as these are part of the themed costume you wear as part of the Samhain festival in the region. Once you leave Glowecestrescire, toggling your disguise should remove the Mari Lwyd cloak and mask.

    I would like to thank you all again for the information and evidence provided throughout the developers' investigation into this issue; it was integral to getting this issue resolved, and was extremely useful to refer to. I hope that after today's patch, there'll be no further issues, but should any arise, you are of course welcome to get in touch with me here in the thread and I'll reply as soon as I am able.

    Official Response
  • chl0enic0le
    1 posts

    This is utterly ridiculous, I've spent hours trying every fix by everyone here and on reddit and nothing works. I cannot play continuing like this, please release a patch soon I'm losing my mind. I'm worried for the state of this considering it was reported over a month ago.

  • BygoneEgg368964
    4 posts

    I've paid a lot to get new skin in the store, but I can't use them because of this [censored] skull cloak. It makes me very upset.
    If ubisoft can't fix this [censored] ASAP, I won't play it anymore!

  • rixcoast
    3 posts

    @aj_nuvo The Yule Festival is currently available when visiting Raventhrope. I think it triggers automatically. It is only available for a limited period of time. I don't think you need to have completed the main storyline to access it. https://www.ubisoft.com/en-gb/game/assassins-creed/valhalla/news-updates/5u0bZyad2ng1ZTGuWug3dh/assassins-creed-valhalla-yule-season-preview

  • Chillhart
    5 posts

    None of the Fixes works for me on PC 😕 How can some simple bug like this not be fixed in over a month!

  • Kormac67
    613 posts

    @sutekhone You are drunk because of the Yule feast, it's not related to the cloak.

  • BygoneEgg368964
    4 posts

    Mari Lwyd mask won’t go away! 

    I've finished the Glowecestrescire arc, but I can't remove the skull cloak, even I turn every piece of equipment off, the skull cloak is always on my face.

    The second problem is every time when I replay the game after I get killed, my character will be drunk, it happens every time!

    It seems like I am still in the Halloween hell of Glowecestrescire's even after I've made alliances with all England except Hampshire.

    I hope Ubisoft can fix this ASAP, otherwise I can't keep playing!

  • cnnryng
    16 posts

    @kormac67 No it’s related to the cloak bug, some of us having been “drunk” every time we load the game since well before the Yule update

  • KnightofTara
    13 posts

    I am playing on the XBox One version. Ultimate Edition.

    I now also have the Mari Lwyd cloak stuck on me no matter where I go or what I do. I cannot wear the cool Native American outfit outside of Vinland. And I am also spawning drunk (since Yule Festival start).

    This is really making me angry. These problems seem pretty universal. Did no one play test any of this before release?

    No point in buying any of the cool armor sets if I cannot see it through the damn skull cloak.

    Is a Hotfix inbound? It is badly needed. Updates would be appreciated.

  • ABigAssMexican
    2 posts

    @w0ffeh go in photo mode it tends to dissapear dont know for how long tho but it did work

  • cnnryng
    16 posts

    @abigassmexican This works for me but only to remove the skull mask, doesn’t seem to affect the cloak

  • binskies
    29 posts

    I'm playing on Xbox Series X, and I don't have the issue that alot of others are having, I don't see the deer skull when the hood is down (thank goodness), but no matter what I do, I cannot get rid of it when I pull the hood up. It doesn't matter which cloak I'm wearing. I've completed the Glowecestrescire Arc and reported back to Randvi. It doesn't matter where I am in the Valhalla world, when I put on the hood that stupid deer skull is there. I've gone to Asgard and back, exited and re-entered the animus, quit the game and rebooted the console. I've researched all over the internet, and I've tried everything that I found to be suggested that has worked for other people and nothing is getting rid of it. Honestly, if there isn't a fix for this soon, I will probably quit playing altogether, it is THAT annoying. Please fix this!!!!!!!!!!!!!!!

  • ZackSpahr
    2 posts

    @th3pr1nc333 happened to me, I took it off upgraded it then put another one on then switched again, not sure what part fixed it but it worked

  • guest-vE0qB42G
    4 posts

    Ubisoft! please fix this big. I cannot get rid of the hideous cloak from the Samhain/glowchestershire mission. its really unsettling! Please make the patch so we can use our other outfits, and not the samhain cloak and mask. thank you.

  • scarlett-joker
    1 posts

    @abigassmexican What's photo mode? Do you mean selecting share?

  • lalusitana
    19 posts

    Mine disapeared when took a photo

  • Mr.Foxconn
    17 posts

    @Ubi-Woofer
    Hello,
    I just encountered this,, Cloak Bug,,. The Marry.... Blablabla Cloak appearence is stuck on my Eivor. I tried very strange solutions which i found on internet, but nothing helps. Hide, take on, fast travel, went to Asgard and came back, changed gender, nothing...
    Is there a solution or this is system bug?
    @Ubi-Woofer @Ubi-Woofer @Ubi-Woofer


    This problem is ruining the game experience...

  • BygoneEgg368964
    4 posts

    @ubi-woofer
    I play this game on Xbox one X, my main story is almost completed but I can't still get rid of the skull cloak.

    Such a great company. Ubi would rather give us lots of Merry Christmas missions that are full of bugs than fix numerous bugs that we have been suffering from.
    This fraudulent organization tricks us to waste our hard-earned money on Helix store and we can't wear awesome skin on because of this stupid skull cloak. 

    We can't even know when will it be fixed. I'm so disappointed!
    Sorry for showing my anger to the staff, your CEO and the whole management team have a big problem!

  • Merlinthewise24
    2 posts
    This post is deleted!
  • Merlinthewise24
    2 posts

    Been trying for ages, photo mode, reloading etc, hated the thing. This 100% just worked thank god!

    Fast travel to settlement.

    Unequip everything, so you're naked + Skull cloak obvs. then in inventory equip JUST your regular cloak.

    Toggle hood up, and hopefully it should glitch back like mine just did. Also re-equipped all my gear too randomly.

    Then manual save like your life depends on it 😜

    Hope this helps someone.

Suggested Topics

Community Details

145
Online
139.3k
Users
24.5k
Topics
126.6k
Posts