Welcome to discussions

Quick Suggestions

  • JasonJuneau
    2 posts

    Hey! Ubisoft! Big bug issue here. Get off your [censored] and [censored] fix it.

  • Mr.Foxconn
    17 posts

    even i cant open a ticket at support.ubisoft.com/en-GB/Cases/New

    what i wanted write there:
    AC Valhalla Cloak Bug,
    im waiting more than one month to repair this bug.
    i want refund, is it an option?
    Im really tired of this glitch and dont want play anymore with tis game.
    This is ruining the game experience.
    I didnt play out the story, i wanted under Xmas holiday, but... nothing happened , so im ready for refund , take back this game and give my money back.

  • guest-vE0qB42G
    4 posts

    its been 10 days, and. is till have this hideous cloak!! i cannot get rid of the cloak even after putting 5hours of gameplay AFTER the glowchestershire mission...please fix this bug...

    @ghey_fish seconded

    @UbiChem please please fix this samhain cloak bug..i cant get rid of this cloak no matter what im doing. Ive put in 5 extra hours of gameplay after the glowchestershire mission, and its still there. As you can see, there so many many others stuck with the same problem...this is nt the first bug we as gamers have dealt with playing this game...

  • guest-vE0qB42G
    4 posts
    This post is deleted!
  • guest-vE0qB42G
    4 posts
    This post is deleted!
  • Skullsplitterr
    2 posts

    After completing Glowecestrescire arc, I can't remove Mari Lwyd's mask and cloak, even outside of Glowecestrescire, no matter where I am or what I do. I have tried every online hint to no avail. Even when I unequip everything from my character, it still has the damn mask and it is ruining my gameplay.

    @ubi-woofer I'm playing on PC and I have the Mari Lwyd's cloak and mask everywhere except in Vinland, in the following situations:

    • the cloak is on permanently and the mask shows up when I put on the hood,
    • when I unequip the cloak in the Inventory, Mari Lwyd's mask appears over the character's bare face, together with the cloak on the character's back,
    • during all loading screens I have Mari Lwyd's cloak but not the mask, even if the character is fully naked,
    • when applying new tattoos, I can't see the back of the character, because he has Mari Lwyd's cloak on him all the time.


    I am sorry to say, but this bug is unacceptable and has been reported so many times and for so long that there's no excuse for it to still be there. It's completely ruining my gameplay.

    Please just get this corrected.

  • Skullsplitterr
    2 posts
    This post is deleted!
  • guest-aQ7oyO2I
    1 posts

    I am in Jotunheim and it’s STILL ON!!!!!! I hate this so much I may quit playing completely. The best part of the game is GEAR and it’s ruined with this *bug. PLEASE FIX IT UBISOFT @ubi-litten

  • SOE_BuddaB8n
    1 posts

    Keeps saying “locked no one home” when I try and knock. I’ve restarted multiple times.

  • betwixt714
    1 posts

    I, too, am experiencing this bug.

  • Obesius2020
    1 posts

    I had this horrible samhain cloak for a couple of days, but was able to get it to come off. Hopefully it works for u guys. I went into my inventory and unequipped everything including weapons. At this point my eivor was running around in boxers and that ugly cloak. I then went back into my inventory and equipped only a cloak. Then exited the inventory menu and activated the cloak disguise frim the option wheel. At that point the cloak i had chosen became visible along with all the other outfit items i had at the time of the glitch. Please try it in this order it was the only way it worked for me, all though i had tried removing all my items before but it didnt work. Maybe its just the exact series of steps, maybe luck Good luck!!! The sight of that thing was ruining the game for me.

  • ChuckKatse
    283 posts

    Welcome to AC Bug Halla. From what I read in Game Play but, can't confirm, the next update/patch is not scheduled until February.

  • Daros111cz
    1 posts

    Is it getting fixed at all? This topic is more then a month old and I just got this issue and nothing I'm doing to get rid of the cloak works.

  • EggyWhisper54
    1 posts

    I have the same experience. Really ruining the game for me. I was going to buy one of the armor packs in the store, but now that i cant change my hood I wont anymore. I think you are losing big on this Ubisoft!

  • Syke80
    9 posts

    Same problem here. Nothing seems to fix it, not game restart, not changing the cloaks

  • grimshwiz
    2 posts

    @chillhart I haven't played other than to check if it was fixed and logged out since a week after release. Such a disappointment.

  • grimshwiz
    2 posts
    • Un-equipping/re-equipping my cloaks
    • Un-equipping all armor and weapons (as well as traveling between areas while everything is unequipped)
    • Hiding my cloak when traveling between Glowecesterscire and another area (on foot/horse/fast travel)
    • playing the Vinland arc as normal
    • traveling back to Vinland with everything un-equipped. Still shows back up when I return.
    • Un-equipping saving and re-loading. (The game just re-equips the cloak that I took off)
    • traveled between Norway and England
    • continued to progress the story
    • completed all activities/wealth/mysteries etc. in Glowecesterscire
    • Spamming the quick access cloak button after leaving Glowecesterscire and alternating between cloaks
    • Hiding and un-equipping my cloak and killing myself.
    • Restarting the game


    This is on PC, and I haven't played since the week of release due to this bug. I check after every update and log in and still no fix. I guess time is near for a chargeback on my credit card for my Ultimate Edition.

  • Dens1tyBlade
    1 posts

    Ubisoft please fix the damn cloak bug, like i see 10000 of people complaining about it. I can't imagine it be hard to fix

  • UnitLegend
    5 posts

    Over 1 month and still people are having this glitch, time is ticking and people are moving on to other games



  • MonroeTheCat
    5 posts

    @chuckkatse
    Wouldnt surprise me at this stage that we won’t get it until then. I’ll consider coming back to play if/when they do decide to release the fix, particularly now that they say they have it solved!
    Until that day comes, if ever, I’ll move on to other games and spend my add-on money elsewhere instead of on this game.

Suggested Topics