Welcome to discussions

Quick Suggestions

  • NeedleNerd
    11 posts

    I play on PC and what worked for me just now was to wear the cloak (Mari Lwyd will show with the skull mask on) and jump into water. When I climbed back out of the water I was wearing my regular cloak. HTH!
    PS: Still drunk every time I load a game 🙄

  • Ubi-Woofer
    Ubisoft Support Staff 799 posts
    Best Answer

    Hello everyone! 🙂

    I'm very happy to return to the thread to confirm that TU 1.1.1 - releasing today - contains a fix for this issue with the Mari Lwyd disguise. Once the patch has been fully deployed, and you have fully-updated your game to the latest version, you should find that you are (finally!) able to remove the disguise when outside of Glowecestrescire, and should no longer see it stuck over your worn armour.

    If exploring Glowecestrescire or completing the arc, please do be aware that as we mentioned before, the disguise will always involve the Mari Lwyd cloak and mask as these are part of the themed costume you wear as part of the Samhain festival in the region. Once you leave Glowecestrescire, toggling your disguise should remove the Mari Lwyd cloak and mask.

    I would like to thank you all again for the information and evidence provided throughout the developers' investigation into this issue; it was integral to getting this issue resolved, and was extremely useful to refer to. I hope that after today's patch, there'll be no further issues, but should any arise, you are of course welcome to get in touch with me here in the thread and I'll reply as soon as I am able.

    Official Response
  • NeedleNerd
    11 posts

    @needlenerd If it reverts (as it apparently did for some people) I'll update.

  • Danziii
    6 posts

    You know what? Screw this game and screw Ubisoft. Never have I played a game so blatantly [censored] broken. I've had so many gamebreaking bugs throughout my time in this game and I've got through them because I was actually enjoying the game, but after 20 or so hours with this horrible cloak, I cannot stand to stare at this abomination any longer. As well as world events not loading properly, meaning I can't even fully complete the game. Ubisoft are an absolute disgrace. You cannot contact any of their customer support, they give you no indication of when these issues might be fixed. They've known about Mari Lwyd bug now for over a month and they'v done [censored] all about it. It's clear that they just wanted to push this [censored] out and take our money from launch and that's it. I could've waited many more months before buying this garbage fire when it's actually playable and I would've paid half the price. Give me a refund for this [censored].

  • B00MSIE
    329 posts

    @needlenerd

    For me (XSX), this solution (just like all others mentioned above) does not work.

  • iJames91
    4 posts

    Try restart the game or use the BAYEK SUIT and remove

  • Lucerne-UK
    2 posts

    @cclarke98 I am having the same issue. Tried all the fixes suggested but unfortunately I am still laden with the cloak... and drunk every time I enter the game. So annoying!!!

  • Lucerne-UK
    2 posts

    @lupuswolf65 Same for me. Getting me really annoyed now!

  • ErinBoru
    4 posts

    Here's an excerpt from NME.com-gaming news, posted on December 29th, by Simjar Singh:

    Assassin's Creed Valhalla producer Julien Laferriere has shared Ubisoft's top priorities for the game post launch.

    Laferriere said apart from already assured post launch content, his team is mainly focused on pushing out updates based on player feedback. In an interview with Game Informer, he said " It's about hearing what the player base is saying, and reacting to that, on top of extra content."

    Wow.

    Want some salt on those wounds?

  • iwul_BRAND
    1 posts


    dammit guys, it's nearly 2021 and the bug still persists.
    Playing on fat XONE, tried nearly all of the workarounds posted.

    whatever I do, the cloak remains there after wrapping up the arc, seemingly not as a part of EQ but rather stuck to my character model. Even in the tattoo parlor, Eivor undresses to underwear... and Mari Lwyd cloak. Tried it all: leaving Glowcestrescire, returning there and leaving again (fast travel and horseback both), taking clothes off, swapping, toggling cloak visibility off, spamming hood command on the wheel, you name it.

  • B00MSIE
    329 posts

    @ijames91

    Thanks, but also not working. While using the Bayek suit the cloak is gone, but as soon as I put on anything else it is back. Made invisible visible, cap on/off, jump in water, ride horse, tried all solutions, but in the end, the cloak is still there.

    At first it wasn’t irritating me, but now I begin to really dislike it. I use the Bayek suit now, but it also begins to irritate me, because I am sort of forced to use it.

  • Mr.Foxconn
    17 posts

    i know its not your fault Ubi-woofer, but please send my message to your boss, this game is a pathetic bug pile .
    im playing Cyberpunk 2077 at holiday, because of this Cloak Bug, and know what? Better game 😄 Still full of technical bugs, BUT I CAN WEAR WHAT I WANT.
    So if i could timetravel i decide again which product should i buy , Valhalla or Cyberpunk, that decision would be Cyberpunk, sorry i will never buy again AC game

  • Mr.Foxconn
    17 posts

    anyone here know how can i get the refund, i would appriciate the help, because chat support is death, cant opent even a bug ticket and i really want refund this. Didnt finished the game, but not this wanted when i bought this

  • B00MSIE
    329 posts

    @mr-foxconn

    For me it is the same about the comparison Valhalla and Cyberpunk. I really don’t get it why review sites complain that much about Cyberpunk and they praise Valhalla into heaven. I really like the idea Valhalla has to be, but the amount of bugs is a bit to much to ignore. I get it, they can’t fix this amount of bugs immediately, but this game really should have been delayed.

    I really like Ubisoft games like Far Cry and AC. Have them all and spend the most of my gaming time on them. Normally I would have also bought Fenyx Rising, but decided to skip it because of Valhalla. Instead I bought Cyberpunk, also because I knew if I disliked it, I could get a refund.

  • M3W3SY
    9 posts

    Starting to get the [censored] now. Over six weeks! This is [censored]! The glitch is one thing but the general lack of a timeframe or hot fix is just spit in the face.

    I'm on series x. This didn't work for me but a friend has had success.



    It is atrocious that the community is having to find ways to glitch a [censored] problem that ubisoft ignores. Christmas is not an excuse to ignore an issue raised over six weeks ago.

  • Shady_Em
    2 posts

    @rankinsect this didn't work for me either. This is really a giant drag on the game. I've tried all the "fixes" I could find

  • shyam3010
    84 posts

    @ubi-woofer not good enough.

  • rankinsect
    52 posts

    For me, this fix worked (doesn't for everyone):

    1. Go to anywhere that's not Glowecestreshire.
    2. Make sure your hood is not up.
    3. Summon your horse and mount it
    4. While mounted, use the cloak action to put up the hood of your cloak.


    It is intentional that you get the costume anytime you're in Glowecestreshire - even if you get unbugged, it will reappear in that region, but it shouldn't stick when you leave.

  • AJ_Nuvo
    44 posts

    @m3w3sy it took so long because at first, the devs were convinced we were taking the [censored] out of them. "It's intended" they say, only to realise much later that they done [censored] up.

  • Karloz1995
    268 posts

    @cclarke98 funny how in the game the developers makes hints about them wanting to get less time working and also raise their salary to "improve" their working time hahahahah after this lazy developed game, they dont deserve any of that....

  • guest-Ki2C1XGN
    2 posts

    See it’s this simple. Y’all at ubisoft did a great job creating this game and the other older games. You need appreciation. But with bugs like these, you gotta fix them asap man! This ruins so many people’s(including my own) gameplay. Such an abrupt interruption. We don’t wanna continue playing with these glitches. So don’t you think if you all can create such a big game so beautifully, then you should most definitely be able to fix this bug in atleast a week????!! But it’s been a month and a half and nothing!! This is sad and it’s just ruining the image of ubisoft. Please fix it asap....atleast the mari lwyd cloak glitch. It’s just horrible. Just fix it to make the cloak into a hood which is available to wear in the inventory. That’s all.

Suggested Topics

Community Details

142
Online
142.0k
Users
25.1k
Topics
130.0k
Posts