Welcome to discussions

Quick Suggestions

  • Cheva1ier.
    3 posts

    @Ubi-Woofer

    PC

    I am also an unlucky player who cannot remove the cloak.
    After 150 hours in the game I must say that this bug was a major factor that I couldn't enjoy the game. I have already ended the main story and left the game until the problem was fixed.

    I must say that I came back only to take the Yule fest Armor.
    Otherwise there was no reason to continue the exploration.
    I preordered the Ultimate Edition since 3rd May and waited with anticipation for a game equal to my favorite Odyssey, but all these glitches and bugs transform my anticipation to frustration.

    Finally I am hoping for an update release before the drop of the DLC ,because for me and many other players there will be no reason to continue the game with the current status.

    Best Regards

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts
    Best Answer

    Hello everyone! 🙂

    I'm very happy to return to the thread to confirm that TU 1.1.1 - releasing today - contains a fix for this issue with the Mari Lwyd disguise. Once the patch has been fully deployed, and you have fully-updated your game to the latest version, you should find that you are (finally!) able to remove the disguise when outside of Glowecestrescire, and should no longer see it stuck over your worn armour.

    If exploring Glowecestrescire or completing the arc, please do be aware that as we mentioned before, the disguise will always involve the Mari Lwyd cloak and mask as these are part of the themed costume you wear as part of the Samhain festival in the region. Once you leave Glowecestrescire, toggling your disguise should remove the Mari Lwyd cloak and mask.

    I would like to thank you all again for the information and evidence provided throughout the developers' investigation into this issue; it was integral to getting this issue resolved, and was extremely useful to refer to. I hope that after today's patch, there'll be no further issues, but should any arise, you are of course welcome to get in touch with me here in the thread and I'll reply as soon as I am able.

    Official Response
  • guest-Ki2C1XGN
    2 posts

    Ok, you've taken this too far ubisoft. It is understandable that any new game may have glitches and bugs and that it will be fixed. But a lotta of us have been seeing this [censored] horse mask and that trashy mari lwyd cloak for 2 months!!! It has disrupted so many people's games. Many like myself have stopped playing and have been waiting for a fix for quite some time. You guys can atleast give us an explanation saying it's a big fix(I don't think it i) and we will release a fix or update at so and so time. But no, keep focusing on minting more money off us by releasing new packs and other bs. Do y'all have any idea how you're ruining the image of the game and ubisoft? I feel so frustrated and I have tried literally everything possible. I feel like i will never ever buy [censored] game of ubisoft ever again. And I'm sure a lot of people feel the same [censored] way! Especially the people who spent 100+dollars to buy gold edition and other add ons. This is really really sad. You're losing many players. Now I am not some noob who has no job and is just sitting around playing all day. I have a job and a lot of other stuff going on. But I am passionate about gaming so I do spend a whatever free time I have playing. But with bs like this, I feel like I should stop wasting my time on [censored] like y'all who take our money and just leave us hanging. please [censored] fix it asap! You have already ruined the game for us. Pls fix it so that we can just finish the [censored] story instead of having to go to wikipedia or youtube to know the rest. Atleast give us a proper explanation and a date for the update.

  • M3W3SY
    9 posts

    I think the complete silence regarding the matter is [censored] me off more than the issue itself. Give me a date it will be fixed and make is soon!

  • Shady_Em
    2 posts

    I'm just gonna toss my 2 cents in for this post. I have the same issue and have had it for over 3 weeks now. I've tried every "fix" out there on the internet. Nothing works. This is really really dragging down the playing experience. It ruins the cinematic scenes. At least respond and say you're working on it, acknowledge it's an issue, something.

  • CA1981StarWar
    5 posts

    @shady_em exactly! At least give us hope and I form us that it will be fixed soon, being ignored is infuriating. They just take our money and don’t give a f...”hey! Check out these new armors we have on the helix store, but them! But just a heads up you won’t get to see the cloak or helmet!” It’s really a big FU to the consumer.

  • karmell33
    2 posts

    Hi Unisoft, the mari lwyd bug is still an issue and is really making it hard to enjoy the game now. Can you fix this asap?

  • karmell33
    2 posts

    Still a problem. Really taking away my enjoyment of the game. Please fix asap.

  • CA1981StarWar
    5 posts

    my only manual save is from the 40 hour mark, I’m well over 100 hours in at the point, so if I go back I lose a ton of progress, but at this point if I want to look the way I want that’s what I’ll have to do, and then not play the Mary lwyd arc until it’s fixed. But the way it’s going who knows if that will ever happen. Complete and utter BS

  • jameskdixon
    1 posts

    Having the same problem has many others. Can not remove clock . Extremely annoying for someone who enjoys cosmetics in a game . How has this not been fixed yet?

  • Roughman01
    16 posts

    Shame this glitch doesn't affect the helix store too as I bet they'd hotfix that in the time it takes me to write this. They're more interested in pushing there next new shiny armor. I was looking to get into this game and participate in events and get helix store armors, but with missing the whole yule event whilst waiting for a fix I'm at a loss. At this point I'm genuinely becoming bitter to ubisoft if this is how bugs are treated whats the point in paying for the game only for it to be pot luck if it'll work then its another [censored] shot if they'll even fix it. I'f I hadn't already committed over 150+ hours I'd of given up. What's also daunting is I've bought the ultimate edition so I've got dlc to play too (which is probably another priority over the bugs). I'm also kinda convinced they don't know how to fix it, that's why we keep getting the generic copy and paste answers every so often saying "were aware of it and will sort it in a patch in the future" I'm sorry but we want a more genuine answer, at the moment it's either in the next patch or in patch 457889975432225789. Rant over for now.

  • Mylilroshi
    2 posts

    After the merry lewd mask mission, I haven't been able to remove/change the cloak I was last wearing and the mask is permanently stuck on my head.... I've tried all the possible fixes with no luck. I've been an AC fan from the beginning but the amount of bugs in this game is really disheartening. I don't think I'll be buying Far Cry 6 new. Just not worth the money...
    undefinedundefined

    
            
  • ziggurcat
    167 posts

    @mylilroshi I kind of had that same thing happen - I just brought up the wheel by holding down on the d-pad, then selected the cloak.

  • Fenargol
    1 posts
    This post is deleted!
  • fmlirl
    1 posts

    Same problem as everyone else... I am not continuing this game until it's fixed

  • CA1981StarWar
    5 posts

    Ubisoft is the Dag of the gaming world

  • BEZIRED
    1 posts

    Any solution yet ?

  • VitakkCZ
    1 posts

    I also have this bug. Finished Glowecestrescire arc. It's strange it wasn't fixed yet, it's after winter event and can't rid of this terrible skull mask

  • tokajero32
    21 posts

    they need to patch it , why u ask no solution yet i dont get it. its simple . they wont patch it, it wont be fixed . when u see next patch notes and u dont see this problem in the list getting fixed then u can complain more.

  • jandraelune
    117 posts

    The Mari Lwyd cloak is awarded to you as an item that does not show up in your inventory, after this whenever cloaking up the Mari Lwyd cloak is the only cloak you have.

  • Damo_77
    15 posts

    Over 8,000 people suffering from this bug have searched out the video I uploaded to Youtube for you. When are you going to give us the fix, [censored].

Suggested Topics

Community Details

23
Online
131.0k
Users
22.7k
Topics
117.9k
Posts