Welcome to discussions

Quick Suggestions

  • cnnryng
    16 posts

    @ubikoreanbbq W H E N

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts
    Best Answer

    Hello everyone! 🙂

    I'm very happy to return to the thread to confirm that TU 1.1.1 - releasing today - contains a fix for this issue with the Mari Lwyd disguise. Once the patch has been fully deployed, and you have fully-updated your game to the latest version, you should find that you are (finally!) able to remove the disguise when outside of Glowecestrescire, and should no longer see it stuck over your worn armour.

    If exploring Glowecestrescire or completing the arc, please do be aware that as we mentioned before, the disguise will always involve the Mari Lwyd cloak and mask as these are part of the themed costume you wear as part of the Samhain festival in the region. Once you leave Glowecestrescire, toggling your disguise should remove the Mari Lwyd cloak and mask.

    I would like to thank you all again for the information and evidence provided throughout the developers' investigation into this issue; it was integral to getting this issue resolved, and was extremely useful to refer to. I hope that after today's patch, there'll be no further issues, but should any arise, you are of course welcome to get in touch with me here in the thread and I'll reply as soon as I am able.

    Official Response
  • Damo_77
    15 posts

    @ubikoreanbbq Here's the thing. You don't have our patience. Our patience ran out last year. And by last year I mean November of last year. As in the month that this game ruining bug was reported to you to do something about.
    The game has been out roughly 2 months, and 1&1/2 months has been spent not playing it waiting for you to fix it.
    $120.00 not well spent.
    What in the H E Double Hockey Sticks is wrong with you people?
    Is there a reason you can't put out a new patch every week until all the bugs are fixed, like a responsive developer would?
    Is there a reason you can't put out a hotfix for a game ruining bug experienced by thousands of players, with that number rapidly expanding now that casual players are catching up to the bingers? And by rapidly expanding I mean 300 more players have searched out my video I posted for you on Youtube since yesterday. The growth of players with this bug is increasing exponentially.
    Holiday vacations can't explain the amount of foot dragging you've been doing, so what are you doing?

  • Chillhart
    5 posts

    @ubikoreanbbq WHAT PATIENCE?!

    ahh...i forgot, that you have the community on "ignore".

  • Roughman01
    16 posts

    @ubikoreanbbq oh look anther generic, cookie cutter response, you've lost our patience, we want to know whether it's worth hoping for a fix sometime this millennium or should we do what I think most people are doing and give up, because unless it's the helix store and lining your pockets with new armors (which ironically we can't use because we're stuck with this [censored] cloak), you don't care and will probably just keep dripp feed these generic "we're working on it and you'll get a patch in the non specific future" answers. This has genuinely soured me on ubisoft, I nearly picked up the new Fenyx rising game but upon seeing its developed by ubinot bothered, I decided my money would be better giving to a reliable developer. If I ever get another Assains creed game I'm waiting a year after release as by then itl probably only just be closed to fixed.

  • Mylilroshi
    2 posts

    @ziggurcat yeah, that does take it off my head. It's just such a lame bug because it really detracts from the quality of experience. I just purchased a new set of armor from the Ubisoft store and can't enjoy the cloak that comes with it. I practically see this damn horse skull in my dreams now! 😂

  • ziggurcat
    167 posts

    @mylilroshi It completely removed it for me, and reverted back to the cloak associated with the armour set I was wearing.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hi folks. I recently merged a few other threads about this issue here in order to consolidate the information regarding this bug. I'd also like to address some of the frustrations that have been expressed recently regarding the lack of a fix date. At the moment, we do not have this information and are waiting for an update from the development team. I understand how disheartening it is to not have a resolution date, and completely understand the sentiment you all have shared. Please rest assured that we will provide updates as soon as we receive them.

    Official Response
  • speedynl21
    79 posts

    yea yea the same broken record again, we sorry but don't know anything, maybe somewhere this year

  • jandraelune
    117 posts

    With the post merge, the name of the source quest got removed. ' The Stolen King ' is the one that rewards a Mari Lwyd cloak item that does not show up in inventory. For those that do not want plagued with this bug, do not complete that quest.

  • Roughman01
    16 posts

    @ubiexcellent so do you not have any communication with your different teams,email, phone, messenger, WhatsApp, carrier pigeon, morse code, shouting, telegram or fax. There's a bit of help but once again I'm guessing with these sparce generic responses they're not even close to fixing it if they've even started.

  • AJ_Nuvo
    44 posts

    @UbiExcellent communication from the developers has been sorely lacking. For a company this big and this long in the business, this is frankly quite unacceptable and shocking. You guys were on-the-ball for Odyssey, while for this, you seem to have dropped the ball completely. No updates on what you guys are working on, no tweets on the main account acknowledging the bugs people are facing, no information on timelines for patches or fixes.

    Look, we understand times are tough. We are fine with waiting. But surely someone in your team is responsible for clear, frequent communication? What's with the secrecy? Why only communicate when rumours and reddit users bring things to light? If anything, there's even less excuse for the lack of communication in times like these, seeing as everything is going increasingly digital and off-site due to the pandemic. It's not as if you can only communicate via pigeons where the coops are at your office. It definitely seems this way now.

    It's ridiculous that right now, the only reliable and frequent source of information on the game is gotten not from the company itself, but smatterings of whispers on the Internet and a single YouTube channel. You guys tell us to refrain from speculation, but right now, speculation seems to be the only reliable source of information, and it's making you guys look like a [censored]-poor company ripping off its consumers with item pack after item pack but saying (perhaps even doing) absolutely nothing on the sorry, sad state of the base game.

    Is everyone at Ubi right now living under a rock? You guys are a publicly traded multinational corporation with the resources to invest in communication with your main customer base which you depend on to survive. Yet we are hearing precious little from your end.

    TL;DR - What's your [censored] problem?

  • cortlandia
    6 posts

    So honest question: I’ve been grappling with the idea of just completely restarting a new game and hoping I don’t get the bug again. Does anyone know how to avoid getting it all together? I’ve heard doing the arc from start to finish, not leaving the area in the middle to go back to the settlement or anywhere else, allows you to possibly avoid the bug. Can anyone confirm that? Second, if I restart a new game will my items from the Yule Festival or those items I bought from the opal trader rollover to a new game or is that stuff lost forever? If my items don’t rollover then screw it I’ll let the story sit in limbo for 100 years before I pick this game up again without a fix. I’m considering this course of action because as much as I’d hate to lose 145 hours of play time I’m betting I can get back to where I am now before a fix is even considered by Ubisoft. I’d appreciate any feedback.

  • AJ_Nuvo
    44 posts

    @cortlandia it's theoretically possible but the question is more of whether you "should" rather than "can". All those hours going to waste, all those resource and silver grinds starting over - all to circumvent a bug that Ubi is putting its head into the sand about.

  • B00MSIE
    296 posts


    I did the quest from front to back in 1 run and after that I did not have the cloak.
    But after completing the next arc, It suddenly was there and now I can’t remove it. I think because I went back to that region a couple if times. There are a lot of high value transports there to rob, that spawn frequently.

  • AJ_Nuvo
    44 posts

    @b00msie so it seems the bug is more insidious than it first appeared. Just by simply travelling to Glowecesterscire the cloak has a chance of being forced onto Eivor? [censored]?

    Ubisoft, tell me now why you thought this was a good idea for this to be "intended"?

  • M3W3SY
    9 posts

    My wife Mrs M3W3SY just did the quest run today. We finished it multiple times each resulting with the cloak. One run. Tried to walk, sail, ride, and fast travel from the area with the same result. She has reloaded and avoided the area pledging to other regions. On xsx

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    Hey everyone,

    I appreciate your continued discussion on this topic, and would like to reassure you all again that this is an issue with a planned fix scheduled for release in an upcoming update.

    I really wish that we could tell you more about the patch and when it will release, however these details are still being finalised and we do not have access to them yet. Once we know exactly when the patch will drop, and what it will contain in full, we'll let you all know here. We are communicating as much information as we have, and will continue to do so, and appreciate your patience and understanding in the meantime.

    I realise our updates recently have not provided any new information however we are looking to provide more concrete details as soon as we have them available to us. Until then, we'll keep you updated with the status of the issue and continue to answer any direct questions you may have.

    As a quick request, please remember that you are bound by the Ubisoft Code of Conduct as well as the Forum Rules when posting here on Discussions, and ensure to follow all of those guidelines when posting. We welcome your feedback with regard to Assassin's Creed Valhalla, whether positive or negative, but will not tolerate abuse, discrimination, excessive offensive language or other content that is in breach of our rules. Thank you. 🙂

    Official Response
  • KrovOwl
    1 posts

    After completing the Arc mission in Glowecestrescire, the Mari Lwyd cloak stays stuck on your Eivor. Trying to change the cloak to another cloak does not work. Even when you try to remove your cloak completely, it appears on your Eivor. The only gear I use at the moment is the Bayek Outfit I have since it does not have the cloak glitch. This is extremely unfortunate because I have purchased two gear packs and I am unable to enjoy them since the Mari Lwyd cloak is glitched on and unable to be removed. Please fix this.

  • ToddLouis
    3 posts

    I have finnish the game a long time ago. I happened to go back into Glowecestrescire and it popped back on. That was two weeks ago. I can NOT remove this.
    When are they going to fix this?
    This is ruining the game for me.

  • BannedBeast
    1 posts

    It’s been almost 2 months and still no word off a fix. Just the same message of not knowing when. I payed good money for this broken mess. It like unity all over again.

Suggested Topics

Community Details