Welcome to discussions

Quick Suggestions

  • Theminirckstr
    1 posts

    Having the same issue. I've tried everything....

  • loki1130
    13 posts

    Cloak is there all the time after you complete Glowecestrescire. Does not matter where you are on the map.

  • lupuswolf65
    15 posts

    @loki1130 Was talking to ubisoft chat support yesterday about this issue and at the end of it they said that they are aware of the issue and are investigating it, so here's to hopping that they solve it and fix when the next patch releases.

  • loki1130
    13 posts

    @lupuswolf65

    Looks like the cloak is not removable once you start The Gutted Lamb quest. Before that if you have traveled to any other area then Glowecestrescire you can replace that cloak with your own cape by pulling up the hood.

  • DakotMastaFlex
    1 posts

    I was able to fix mine by unequipping all of my items and then closing my inventory. Good luck fellas!

  • LSayer92
    12 posts

    @vanarlen i spared the king but killed the witch. Still got the problem

  • CcRuSsElL99
    1 posts

    Have the same issue. tried all the supposed fixes (fast travelling to ravensthorpe and putting on cloak, removing all gear and then selecting the cloak etc) i even tried switching eivors gender, going to asgard, having a feast, anything to reload the character model but nothing worked. i could remove the cloak previously but when i finished the arc and progressed past The Gutted Lamb quest it was permanently stuck to my character. Really annoying as i dont like the look of the cloak nor the mask that comes with it, puts me off playing the game while i have this stupid thing stuck to me. hope ubi fixes it soon 😞

  • MeinChurro
    39 posts

    Yeah, just got this. So, the cloak is unremovable forever without a broken workaround? As in, every time you happen to hit the border of gloucester it goes back on? If so I guess I am deleting 2 hours worth of save, and redoing the

    spoiler
    I did just before. As that is my earliest save. This is probably one of the most insane bugs I have ever seen. Everything else okay, okay, but this one just takes the cake Ubisoft. Almost every single time I do a lighthearted or goofy quest your game breaks. Horribly. I literally cannot believe this.




  • raphaelzoren
    24 posts

    What I did to remove it was the following:

    Re-load a previous save and finish the Glowecestre questline.

    Right after, fast travel to your settlement.

    You will arrive with the ugly Halloween cloak. Proceed to press down on the D-Pad and put the hood on. Do NOT unequip or hide the cloak first, just press down on the D-Pad to try to put on the skull mask at your settlement.

    This will revert you back to your normal cloak thus fixing the issue.

    If you report to Randvi you will be stuck with the ugly halloween cloak so don't do that first.

  • MeinChurro
    39 posts

    @raphaelzoren So, if I completed the story arc, fast traveled back to my settlement, cloaked, THEN turned it in. This nightmare would be gone for good? I like the sound of that, if that is true. I might be able to do this story arc after all.

  • SHARKBAIT_85
    1 posts

    Idk if I’m getting ahead of myself but I completed this arc and I still have the robe given from this arc after completion. My issue is I cannot access my other robes and I remain with the one from this arc. Am I missing something or is this a glitch where I have to continue with this robe? I just want to use my other robes.

  • guest-uqLP2XaH
    3 posts

    @sharkbait_85 I had the same issue. I went back to ravensthorpe and simply cloaked and de-cloaked and my intended cloak was back on. Silly bug but smth that should help

  • LSayer92
    12 posts

    @ccrussell99 couldnt of put this any better myself mate. Ivr resorted to going back to playing other games now. Will keep checking on here for updates but in all honesty ive been waiting that long my excitement to play the game just isnt there anymore

  • iGunhild
    1 posts

    I found a workaround in case anyone would be wanting to try this while having a recent save during the Quest.
    First I was in the midway of knocking doors (1/3) then I engaged the guards on the bridge which instantly removed the face mask of Mari Lwyd.
    Then I wasn't able to knock doors anymore I did the following as follows:
    -meditate (To daytime).
    -rode the horse to Hamtunscire.
    -fast traveled to the dock in Glowecestre (the mask came back on during loading screen).
    -I then completed the quests (remaining 2 doors).
    -Attacked the guards again.
    -Rode to Hamtunscire.
    -And finally was able to remove the cloack via the quick menu to cloak/uncloak.

    It's a bit hectic but it worked for me that way after many trials of mixing things up.
    In the end I went to find Gunnar and get into the fist fight without Mary lwyd cloak/mask.

  • ExpressedZero68
    18 posts

    I'm a few hours away from the quest in Glowecestrescire for Gunnar, whenever I put the hood up it changes to that hood with the skull and I'm unable to change it back or remove it.

  • raphaelzoren
    24 posts

    @meinchurro yup, that's what I did. I completed the entire arc w/o leaving Glowecesteire to prevent potential bugs, went to my settlement, tried to put the halloween skull on and it vanished.

  • Abeonis
    55 posts

    @expressedzero68 If you've completed that quest line, you need to change your hood to a different one and then back again (simply hiding the hood won't work). The Mari Lwyd hood will return each time you visit Glowecestre(scire), so you'll need to do this each time you leave the region.

  • ExpressedZero68
    18 posts

    @abeonis thanks for the heads up!

  • PryzN97
    1 posts

    I have the same bug, nothing helps. Hope they'll fix it soon

  • Superfly_Boss
    83 posts

    New patch announced. Hopefully this will fix this issue.

Suggested Topics

Community Details

137
Online
217.9k
Users
36.7k
Topics
182.4k
Posts