Welcome to discussions

Quick Suggestions

  • yondernick
    5 posts

    I have now finished the Gloucestershire arc of the campaign and Eivor has been stuck wearing the Mari Lwyd cloak ever since. I have tried everything from moving the hood on and off, removing all gear and adding it all, fast travelling all over the place, going back to Gloucestershire and then leaving (fast travelling and manually on foot) and nothing works!

    It's enfuriating! Has anyone got any ideas other than the obvious. I might even uninstall the whole game and reinstall it.

  • Abeonis
    55 posts

    @yondernick Assuming you ahve spoken to Randvi to completely wrap up the arc, you need to change your hood to another one, and then change it back to the desired hood whilst outside of Glowcesterscire entirely in order to fix it. Simply hiding the gear, or removing the hood and then putting the same one back on won't do it.

  • yondernick
    5 posts

    @abeonis yep. Tried that and still there.

  • guest-gVpsPIF
    2 posts

    Hi. When I played a Glowcestrescire’s Story Mission, they gave me a black cape with a mask to dress like a divinity during a Halloween-Like Fest. Now I can’t remove that cloak...what I have to do?

  • Abeonis
    55 posts

    @yondernick All I can say is that it has worked for me, multiple times now. What Quests do you have in your log?

  • yondernick
    5 posts

    @abeonis

    - old friends
    - a new home
    - breaking the order
    - viking for hire
    - a rivalry for the ages
    - in dreams...
    - a brief history of the hidden ones
    - a felines footfall
    - taking rot
    - lost glory

  • Arathorn_ToXiK
    12 posts

    @yondernick hey I had this annoying bug too but it disappeared when I went in water!

    You know when Eivor is in water he removes his hood. So when I did it it removed completely Mari Lwyd hood and my original hood came back.

  • lonewolph1
    3 posts

    After doing the Glowecetreshire mission arc, my character can't take the dear skull costume off, and no matter what I do, the cloak will not go away.

  • Arathorn_ToXiK
    12 posts

    Update to my previous comment: Several days later while I was playing and doing precisely the Rollendritch Standing Stones, the Mary Lwyd cape suddenly reappeared out of nowhere and there is no way to remove it.

    Since I started playing AC Valhalla I noticed many bugs but damn that one is so ridiculous and annoying af...

  • ignoreality
    2 posts

    Same issue. None of the solutions posted in various places helps. I tried:

    • uncloaking and decloaking
    • removing my cloak entirely
    • equipping another cloak
    • setting the cloak to invisible
    • logging out and back in with no cloak equipped
    • logging out and back in with a cloak equipped
    • fast traveling around the world with and without a cloak on


    Absolutely nothing can remove the Mari Lwyd cloak from my character.

  • Superfly_Boss
    83 posts

    @dduttonnc except this is not working in our case. The cloak and the stupid horse mask stays on no matter what.

  • Superfly_Boss
    83 posts

    @loki1130 No. it didn't. The mask stays on no matter what.

  • AQVILIVS
    2 posts

    Same problem. Can confirm this is still an issue for a lot of people. Is this being fixed?

  • Paatjo
    1 posts

    What worked for me was that I unequipped every piece of my armor, re-equipped everything, then used the cloak(from the quick access wheel) to put on the hood and then the Mari lwyd cloak/mask disappeared.

    Playing on xbox one.

  • Fractal009
    64 posts

    @kwizatchz

    Well I got this issue as well, but lucky me, only in Glowcestershire area...

  • ULCER_9MM
    3 posts

    Having the same issue here, the cloak and the skull mask just permantly equipped. It disappears if I travel to Vinland, but as soon as I go back to England or Norway it defaults back. Doesn't matter what I have equipped. Tried hiding all the clothing items saving/reloading etc

    Also, skull mask disappears if I go underwater, but reappears as soon as the hood goes up

  • Ubi-Swaggins
    Community Manager 429 posts

    Hey folks,

    Sorry to hear that you are having issues with the Samhain Cloak.

    This issue has been reported to the team and they are investigating it further.

    Official Response
  • Superfly_Boss
    83 posts

    @ubi-swaggins Thank you.

  • Superfly_Boss
    83 posts

    @paatjo I have tried this step multiple times before and after patch 1.04. it stays on either way. It overrides everything else you are wearing.

  • TylerEmma2015
    76 posts

    So I’m literally stuck with a drunk screen and can’t find the druids guy a little after this has anyone found a fix or know if Ubisoft know

Suggested Topics