Welcome to discussions

Quick Suggestions

  • AJ_Nuvo
    44 posts

    So many workarounds yet none work. I think it's really about how lucky you are. Mine's butchered beyond all hope. Guess I'll have to wait for Ubi to make good on their word.

  • jappojakks
    3 posts

    So I hid all of my gear then fast traveled to ravensthorpe then unhid all of my gear including helmet and then put my hood up and BOME! My old cape was back on. Got this from someone else hope it works for you guys.

  • Jaleb8991
    4 posts

    is there still no fix for this? It’s annoying to be stuck with this dumb mask the entire game 😕 please fix soon

  • ghey_fish
    1 posts

    @fylkirpanzer there is still no fix for this for many many players. This bug completely ruined the end of the game for me. I spent $100 on this game and have no interest in it anymore after this stupid stupid bug. Why is this not fixed?

    I don’t envision myself ever buying another Ubisoft Game at launch ever again. Every time something like this comes up

  • AJ_Nuvo
    44 posts

    So Ubi seems more preoccupied with pushing out Helix Store packs than fixing the base game.

    Look, these armours look great. But I am not going to spend a single cent on them until I can SEE them when cloaked, instead of a horse skull. Capische?

  • ViRaLuNdEaD
    27 posts

    Add me to this list. I have tried all of the suggestions in this thread and cannot get rid of the cloak. It even shows up in the tattoo shop view making it impossible to see tattoo previews. In all areas of the game the cloak cannot be removed.

  • ViRaLuNdEaD
    27 posts

    @jappojakks I've tried so many variations of this and nothing. Glad it worked for you.

  • Vhaelon
    1 posts

    Having the same issue here, i tried ALL the things you guys say and nothing works...
    I already finish the main story and i'm still stuck with that cloak...
    We need a fix for this bug now!

  • FylkirPanzer
    180 posts

    @ghey_fish Yeah. I understand. I've enjoyed all the AC games up to this point, but for me the primary reasons why I don't like Valhalla is that there is absolutely no replayability, and the lack of Viking Age themed armor sets, and various other mechanics that I greatly enjoyed in Odyssey, not being in game. This was the only bug I ever ran into thankfully, and somehow managed to fix it by swapping and unhiding armor, etc. but it seems that method only works when you're not in Glowecesterscire, otherwise you're stuck with the dumb mask and cloak.

    Ironic how Ubisoft is fixing various bugs and things, but ends up ignoring other bugs or further breaking the game each update. I bought the Ultimate Edition and this will probably be the last Ubisoft title I buy. A shame too because I absolutely love the Viking Age, and they butchered it with broken things and missing gameplay mechanics from the previous titles.

  • guest-ZwAuF96F
    1 posts

    I'm having this problem with my PS4. After doing the Glowecetreshire mission arc, my character can't take the dear skull costume off, and no matter what I do, the cloak will not go away.

  • fabiosumi
    1 posts

    that minute of regret, I bought the season pass few minutes ago, and I just saw mari lywd's bug now , so sad

  • calebnlouie
    1 posts

    @smash1295 this worked for me as well thank you so much for figuring this out

  • UnitLegend
    5 posts

    i still have this glitch, ill quit this game until it's fixed.



    Ubisoft support isnt working.

  • UnitLegend
    5 posts

    I have this issue too, I don't want to have to wait until February for the next update I'm enjoying this game but this glitch is ruining my experience

  • UnitLegend
    5 posts

    @ashrosie94 i have it too [censored] my life

  • R3b3L_21
    2 posts

    Enough already. By reading the mega-threads, you only have to wonder "why is this game even released".
    We are not talking about graphic glitches and minor bugs, we are talking about game-breakings bugs that do not let you continue main quests even. This is unacceptable in all levels.

    I have spend 55 hours playing the game and 1/3 of them I am encountering problems, bugs and various [censored].
    Mari Lwyd cloak is just a minor but super-irritating bug but STILL is letting you continue the game, even in that feather-[censored] cloak. Quest destinations aren't even showing sometimes, quests that do not let you interact with the target. This is totally unacceptable for a game release over a month ago. Even after loading a game to continue, you discover that out of the blue that even if you wear your armor, cloak, braces, pants and have your weapons, they aren't even on your inventory - which means that if you change a weapon, you've lost it.

    We aren't supposed to buy a game that needs so much polishing. After Origins and Odyssey, someone would've expected that things will be smooth and graphics engine tried already twice but no... Ubisoft Montreal have a different opinion.

    FIX.THE.[censored].GAME.ALREADY.


  • waymatt09
    1 posts

    same kills the game stop playing, (fix it devs if was a money glitch you fix it) worst assassin game for glitch yet

  • D-Kruger
    18 posts

    So, it's Christmas now, so we won't see a fix for this crap for a while. Shame on you, Ubisoft. You've failed spectacularly. Hope your holidays are as fun as our game.

  • Th3_L3mur
    1 posts

    @lowerdanny This works! Such a maddening bug. I stuck with it for a while, but just about pulled me out of the game because I enjoy configuring my gear. Thank you so much for posting a simple solution to this bug.

  • ubi-Cole7
    2 posts

    Dear Ubisoft,

    All I want for christmas is this damn cloak to be removed off my character. I have a couple immersive ideas for ways for you to do this.

    • Talk to Gunnar in Ravensthorpe. He'll say "You're still wearing that stupid cloak"? and then takes it off you and we never see this cursed Mari Lwyd skull again.
    • Visit Gunnar's house in Ravensthorpe. Here you'll have an option to burn this cloak in his fireplace and we see the skull melt into ashes.
    • Make it an item to unequip in inventory?

    Final option

    • Eivor performs a new stun attack on an enemy where he chokes the enemy out with the cape and bashes his face in with the Mari Lwyd Deer Skull, repeatedly.


    Please fix this issue. Thank you.

Suggested Topics