Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • droc1984
    5 posts

    I've had a similar issue for the past few days. When I try to load the game from the save menu, it initially shows a loading screen but then goes blank.

    Has your issue been resolved?

  • maze08861
    4 posts

    @ofekih Has there been any kind of update on that?
    I just started to have the same issue on Stadia and can't load any of my save games any more.

    Since today I can't load all my saved files (also not as "Continue") on Google Stadia for Assassin's Creed Valhalla.
    I tried several devices, but whatever I do, after the loading process, I end up on a Stadia screen with an error message:
    "Your game had a glitch.Reopen the game to play."

    Sometimes it actually does load, but after moving around for a couple of seconds (I tried also fast travel), I end up with the same error message.

    This started to appear after more than 20 hours of play time and I just started the quest "Firing the Arrow" in Lunden.

    As of now I can't play the game any more.

    Could you please assist with this?
    If this persists I will have to ask for a refund.

    Thanks

    I created a video and uploaded it to youtube:

  • maze08861
    4 posts
    This post is deleted!
  • maze08861
    4 posts
    This post is deleted!
  • LordHelmchen87
    3 posts

    I got the same issue. Can't load any savegame. From the loading screen the screen is turning black but I can hear the ingame sound.

  • alexrioh
    8 posts

    @lordhelmchen87 I got the same issue. Black screen after the loading screen since yesterday...

  • RetroCobi
    1 posts

    @maze08861 Same here, I canโ€™t even play the game anymore.

  • alexrioh
    8 posts

    It is a glitch that is related for months on this thread just found it : https://discussions.ubisoft.com/topic/83549/unable-to-progress-makes-me-go-back-to-eurvicscire/118?lang=en-US

  • maze08861
    4 posts

    @RetroCobi the new patch version 1.1.1 just got released yesterday.
    I only had time to check it quickly, but the problem seems to be resolved for me
    https://stadiasource.com/article/1379/Title-Update-111-Arrives-For-Assassins-Creed-Valhalla

  • Ubi-Woofer
    Ubisoft Support Staff 576 posts

    Hello all,

    Thank you for your reports of this error message while playing Assassin's Creed Valhalla on Google Stadia. I am very sorry to hear that you are unable to properly load your save games due to this, and thus cannot play the game.

    Having checked for an existing report of this issue, I can see that we have already forwarded information to the developers with regard to the "your game had a glitch" error, and they are looking into it. Due to the nature of the Stadia platform, we're unable to offer direct troubleshooting, however please rest assured that this is an issue we are aware of and we'll update those affected as soon as we can. I'll look to make a new megathread for this issue with this thread as the primary, so that any players on Stadia can share their experiences here for us to track.

    It would be helpful if you could all let me know which quest / world event you were completing at the time of your last save, as well as the region you were in, for me to investigate if there is a common sticking point for those affected. Please make sure to have tested the game on the latest version (TU 1.1.1) to make sure that the issue persists currently. Thank you very much for your help in advance! ๐Ÿ™‚

    Official Response
  • LordHelmchen87
    3 posts

    @ubi-woofer

    Hello ubi-woofer,

    Thanks for the official reply. I tried loading my save game with patch 1.1.1 now and still got the same issue - i hear the ingame sound but the screen is black.
    The issue accured when playing the quests in Eurvicscire: After storming Magnis fortress I killed Ricsige and saved the game afterwards. From then on I wasn't able to load the savegame (and older savegames) any longer.

  • LordHelmchen87
    3 posts

    @ubi-woofer

    I was hoping for the new patch to improve the situation. Unfortunately I still can't load my savegames. ๐Ÿ˜ž

Community details

19
Online
113.1k
Users
19.1k
Topics
96.1k
Posts