Welcome to discussions

Quick Suggestions

  • 9 Likes/506 Replies/6487 Views
    nanatake
    3 posts

    @jadennn89 but I'll have to travel 4000 km to Petra O_O

  • Jadennn89
    4 posts

    @nanatake worthwhile if it does. I travelled back after heavy in the head quest. 3k distance too haha.

    All the best!

  • master_ring
    41 posts

    Hundreds of post and ni single response.

    Since 1.04 manual saving and autosaving doesnt work and we cant progress. fast travel included.

    If it helps you I've managed to play and save in Asgaard, but once you are back to England nothing works.
    Verified game - OK
    Contacted ubisoft - No response
    Tried progressing story - Nope it doesnt autosave

    You can only do one action when you load game and once your game do autosave or you go fast travel for the first time its goodbye... Not allowed to save or fast travel.

    Is there an option to revert to 1.02 so we might actually play game???

  • master_ring
    41 posts

    Asgaard worked but only asgaard and only 20 mins... After same old story no FT or save... Moved to England got autosave and thats it.

    Cant manual save game doesnt autosave and not able to FT.
    Spoeaking to anyone in village, sleeping, doing quest, meditation - nothing helps

    Anyone found solution or we spend our weekend on forums?

  • master_ring
    41 posts
    This post is deleted!
  • LuisSarta
    28 posts

    After patch 1.04 the game delete all my manual saves, ok, I've a save in the cloud, but the manual saves...
    Another thing, I think the combat became more clumsy.
    The Synchronization Viewpoint does not show more details with th eprevious patch.

  • ranga_pr1nc3
    10 posts

    Talking to Petra in camp fixed it for me holy [censored] finally !!

  • Euphomia
    2 posts

    This is Gamebreaking stuff right before weekend, don't expect anything from them any time soon.
    Time to play something else until the 10th.

  • Leginat
    7 posts

    Talking to Petra doesnt work for me... 😞

  • gavinda84
    3 posts

    @ranga_pr1nc3 Yes, same for me. I had to do all of the ‘talk to Petra’ mini quests until she confessed she liked me. After that cutscene, it righted itself. PHEW.

  • funkiermunky
    2 posts

    @master_ring what a joke! How can this not be a priority to fix?!?!

    I'll be after a refund too if that's the case... I didn't get any free loot and stuff mate no.. madness. For a flagship game it's a pretty poor show imho

  • gavinda84
    3 posts

    @leginat I spoke to her a few times - did a weird mushroom quest, then spoke to her again and ‘spent some time together’ doing an archery challenge, then spoke to her again and said ‘yes’ to liking her - after that last one (after a cutscene) it righted itself. Said challenge completed and quick save and fast travel are back for me.

  • listenersfury
    1 posts

    @rimmerrr petra didn't work for me but I did the assinate the dummies and talked to the tattooist and after that it was fixed

  • weiping512
    3 posts

    is this a BUG?
    need solution urgently

  • gavinda84
    3 posts

    @rimmerrr You’re a genius!!!!!

  • fullmetal_boy
    3 posts

    @weiping512 return to your settlement and start s feast - that`ll solve the issue

  • nick588588
    1 posts

    Good day,

    The Maj 1.04 introduced a major bug affecting at least Ps5, xbox series x and Pc. For a lot of players including me, it is now impossible to fast travel. Also, other players reported that it is now also impossible to save or load a previous save. Even if some player like me can save, or use a previous save that was done before the maj, the fast travel bug persist.

    Theses bugs were reported on many forums and social medias. Some videogame news website started to report these issues yesterday too.

    It is a major issue, making players unable to progress in the game... This issue needs to be address ASAP Ubisoft... Please...

  • Gokislav
    21 posts

    Nothing from all the tings you suggested working. I tried everything, but without success.

  • Gokislav
    21 posts
    This post is deleted!
  • Gokislav
    21 posts

    @gokislav Even worst, when i try some mission in Ravensthorpe the game autosave me with 0H in cloud. Bugisoft!

Suggested Topics

Community Details

124
Online
196.6k
Users
33.4k
Topics
166.6k
Posts