Welcome to discussions

Quick Suggestions

  • MrChristopherH
    11 posts

    I got the same problem. Im in the middle of sons of ragnar mission and i can not fast travel or manual save. Pretty upsetting tbh. Ive been gaming this story alllll night and did not have this problem until sons of ragnar mission.

    I thought it was just part of the mission. Until i progressed past the castle storming part.. now i have to meet back up with sigmund. But i cant fast travel. I cant manually save and also im getting the animus walls saying i cant proceed into the area where sigmund is which is an area ive already opened and synced. So im really confused and irritated. Please fix ubisoft .

  • Ubi-Borealis
    Ubisoft Support Staff 2894 posts
    Best Answer

    Hello all!

    I apologise for the delayed update. This issue has been marked as resolved following TU 1.1.1.

    If you're still encountering this issue in-game following this update, please don't hesitate to update this thread so we can take a closer look. If you are still encountering the issue, please can you include a video in your post that shows you're unable to fast travel/save, as this can be passed on for further investigation.

    Thanks all! 😊

    Official Response
  • Leginat
    7 posts

    I slept with Petra and then went to Eivar's bed and it worked for me

  • MonsieurTobi
    1 posts

    guys i may have a solution for pc

    go to the epic game store and click library
    then click the options button for ac valhalla and click verify
    then just let it dowload for a while

    this fixed it for me
    I hope it fixes it for you guys

  • CrankAnimal
    3 posts

    It worked! Thanks mates, Off to new adventures 😎
    Just killed a few straw puppets, and solved a quest (whatever Quest It was). Right after that everything worked normally again.

  • Th3QuadLaser88
    12 posts

    @harmynl I am having the same issue after the new patch update and I’m also on an Xbox series X. Everything was totally fine until they released this patch.

    I also seem to be missing manual saves.

  • Th3QuadLaser88
    12 posts

    Ever since the new Patch I’m Having issues where Autosave and Manual Save won’t work, also some of my manual saves seem to be missing. I also can’t fast travel within the game anymore. I can’t even play to progress my game because saving no longer works.... this needs to be fixed or I want my money back!

  • atoboleski
    12 posts

    I had the problem after the last update where I was unable to save a game or fast travel. I tried everything from reinstalling the game to reinstalling ps5 system hardware.

    What eventually worked, and feel free to try combinations, 1. Reinstall ps5 software since I could never get a clean install of valhalla (without corruption and restarting).

    2. Then reinstalled valhalla via wifi vs my cat8 ethernet. Got my first clean install. Note, it took 3 fresh installs of the ps5 software and 3 installs of valhalla to do this.

    3. After this, I still couldn't save but I was able to get in the game.

    4.I started a new game, got through the painfully slow intro, then was able to save.

    5. Bad news, This however saved over my cloud save with all my progress. I did have another cloud save I did manually but 10 hours prior. I loaded that save and everything is working fine minus 10 hours lost and all opals are showing on the map but are not there.

    I know this works as I tried loading into this save previously and could not save.

    If I had to try this again I would save my most current game to a usb (if it lets you). Do the entire process and then try to load the usb save after successfully getting a fresh game to save.

    You might be able to skip parts relating to corrupt data and just start a new game.

    Poopy enough but I'm playing again.

  • Prototype7680
    1 posts

    Since the update i can´t save the game i can´t use the fast travel.
    before the update was all ok.
    Oh and now i can´t talk to the Örlög NPC in Norwic...

  • Viking152
    2 posts
    This post is deleted!
  • LLightbringer
    5 posts

    Great job introducing game breaking bug like this before long weekend... /flips table

  • arymanik
    32 posts

    Ubisoft i understand what You want make something better, but how i can play in games with bugs when I can't save a game ?

    Before patch everything working for me so good on PS5, now i can load game, but i Was play 2 hours, and want to make manually save...
    I cannot, i can't use fast travel, also my autosave make last time when I open the game ...
    It's not normal...
    Can anyone explain me this ?
    And please stop telling me what I'm after battle because how i can be after battle in mine city with 2 hours of playing ???
    I trying start new quest of main history auto save not working....
    It's big bulshit which starting make me angry... Why ? Because I will give back this product to seller, reason ? I cannot play, cannot mean how i can finish game which taking min 50hours without save ? And also autosave....
    Thank You for take my few hours of mine life...
    I understand deleted save... (I always have to many copies) I understand bugs... But You took possibility for just save a game *.*
    For all devs start working with braib and test all function which You change in game code before release new patch....

  • Naltus99
    8 posts

    having issue loading save files on ps5 after 1.04. still waiting on ubisoft for reply

  • Synapses14
    5 posts

    Having this issue as well, can't manually save.

  • Ubiron78
    4 posts

    PS5 here, updated patch and can't save now. I completely deleted the game, then didn't install the update. However, all my data was labeled corrupt. Installed update and then I could load, but still unable to save or fast travel after a few minutes. About 25 hours into the game...

  • arymanik
    32 posts

    @synapses14 it's making game unplayable ;///.... Seriously they don't know how to make auto save and auto clod upload without broke anything ??? It's beginning of programming and function....
    People learn this on 1 year of studies...

    Company which earn billion of dollars have problem which resolve anyone good programmer which know code...

  • Ratiness19
    2 posts


    Same issue here. Play Station 5.
    More than 20 hours into the game...

  • Synapses14
    5 posts
    This post is deleted!
  • JNHall91
    1 posts

    The game will not manually save, quick save or fast travel I spent several hours doing things just for it to completely restart me. Everything was fine until the stupid update that happened on the 26th. I spent over $100 on this game and I'm not happy that I can't play it. SOMEONE NEEDS TO FIX THIS ASAP!!

  • SliverSpleen
    2 posts

    @jnhall91
    same problem after I've updated to 1.0.4 on PC

  • An0844JarHead
    1 posts

    @blindspider33 In typical Ubisoft fashion, they have broken a fundamental part of the game with an improvement patch. Your game is now worthless until they fix the error. The only way to save (on PC) is to go to Asgard. You will auto save loading in and out. You can also manually/quick save in Asgard. If you haven't gotten that far yet, well what did you expect from Ubisoft? Competence? LOL.

Suggested Topics

Community Details

123
Online
142.4k
Users
25.2k
Topics
130.4k
Posts