ubisoft discussions

Quick Suggestions

  • 9 Likes/507 Replies/7811 Views
    2 posts

    Had to return to Ravensthorpe to talk to Petra. Now I can save and fast travel again.

  • penguinsaresmug
    1 posts

    Same problem here on PS4 after the last patch. Going back to the settlement and having a feast does seem to work as then I can save manually, trouble is the second you start a quest the save system breaks again and you have to go back and do it again. Since I'm not willing to spend 50 coins a go to simply save my game this is a deal-breaker for me, can't play the game when it's in this state so the disc is a coaster at this point.

    Patching the game and managing to break it completely? Congratulations Ubisoft, you've hit a new low.

  • jfraga37
    1 posts

    @kennethlam169 same issue it’s very very annoying. Game is unplayable.

  • Catdaddy33
    1 posts

    Talking to Petra then exiting the convo worked for me - I can now save in England.. I could also save in Asgard after completing the opening quest,..but not after I returned... now it seems I can...

  • q.tom1971
    2 posts

    Still unable to save. Autosave not working. Anyone know when this will be solved.

  • arymanik
    32 posts

    Dear Ubisoft
    I understand what to many people wrote about it before, and i don't must write again which bug we need immediately to repair but....
    Patch 1.04.00 was realise date 7 days ago. Yes, with last 7 days we can't play in Your game.
    You make product which cost around 200$ for Collectibles Version, and You don't care about People ?
    I was saw Authentical Card of Collectible Version with number 75 000 (the highest)
    It's around 15 000 000 $$ from just the biggest available game pack to buy.
    And You want just tell 75 000 people bad words, about You don't care game it's working or not ?
    I understand what license told Us what we can't refund program's which have bad codes in game...
    We can refund only broken package of game...
    But why You do this to Us ?
    You not taking any responsibility of Your movements ??
    Its was be 7 day's ago when games was start crashed, and now what ? We can't use autosave, or manual save, You telling Us back to main Village, and speak or do something and will be repair... Seriously ? This is a joke ?

    I understand error with quest, glitch with graphics, bugs in fight scene, but unavailable to save progress ?? This is one big [censored] (sorry for this word), but I can't name this with another's words....

    When You will realise patch 1.05.00 or 1.04.10 for repair this one, for You it's small problem, but for Us it's like we can sell this game to another people.
    Seriously, everyone magazine of games, everyone website which writing about electronics enteraimen should give Valhalla 3/10 not 8/9/10 because they don't play at last version....

    Do something with this, or i will collect all signature of people who have same opinions like me, and i will make group lawnsuit about big refund for the Customers. Because it's not normal selling program which not working for normal price. And believe me, Your layer's will not win this war....

    Everybody who accept with me just write this in comment...
    They must see how much are Us together!!!

  • OzoneHeals
    22 posts

    @q-tom1971 whenever I load a save my game crashes. Ubisoft told me days ago to just wait and watch the forums. They told me nothing for certain and still haven't showed their face in any forums about saves since the 26th when 1.04 came out and broke the game even more. I have 90 hours played and I'm scared it's all lost because of something they did. It'll probably be another week until they come out with another update to change or revert anything in 1.04 and who knows if that will help or make it worse.

  • q.tom1971
    2 posts

    Still unable to save. Auto saving is not working. When can we expect this to be resolved.

  • guest-0V6V9a6F
    1 posts

    Is anybody else having trouble saving/loading mine won't autosave, manual save or allow me to fast travel I literally can not play this game without having to start all over again every time or leave my xbox on 24/7

  • arymanik
    32 posts

    UP Topic.
    Reason collect people which feel cheated

  • Wy4ches
    1 posts

    Same saving games issues. I travel Ashgard, complete every quest. When i go back my settlement cannot save this time. Cannot fast travel. After 1.04 patch. Please help. I lose 25 h gameplay agaln 😞 xbox one

  • guest-7eBKaQ6T
    1 posts

    The same problem, no autosave, no saving during the game, no traveling

  • Tolkyyn
    129 posts

    For some reason Eivor cannot fast travel in the world, but can in Asgard. So the game is broken. The main story and Asgard story are compelted, I'm just out to kill the last OotA Leader, and it takes forever to go by longboat.

  • ConceptVorkuta
    6 posts

    I was able to fix the bug by sitting on the throne in the Longhouse at Ravensthorpe. I got a “Quest Completed” banner pop up (no name associated with it). Now I can Fast Travel & save. Hope this helps y’all

  • B4K3RS
    2 posts

    Hello, cannot progress the game. After patch game is not saving automaticly and manual save is not avaible. Also fast travell is not avaible.

  • Madmartigan744
    1 posts

    Used put on disguise now i can fast travel and save again. Hope it helps

  • BingTing166
    1 posts

    I also am unable to save my game or fast travel. Saving was fine in Asgard, but since returning to England I can't quick save or full-save. As I progress in the game, the autosave symbol shows where it should, but when I go under the "load" tab, it doesn't show any record of the autosaves.

    Please fix ASAP, because I'm scared if I die I will lose over 10 hours of progress and I almost don't want to keep playing until it is fixed!

  • Mk4chris
    3 posts

    @mrchristopherh Ian having the exact same issue can’t go anywhere.

  • Daegan87
    16 posts

    On top of the issues I've had with kingmaker and not being able to save and the game not auto saving, I can't fast travel. Apparently the lack of saves and the lack of fast travel go hand in hand. There was an article about this online 5 days ago. Why is ubisoft not acknowledging and fixing our issues. Right now it's a $120 cd

  • neil_reyes
    5 posts

    @arymanik Same here, unplayable game

Suggested Topics