Welcome to discussions

Quick Suggestions

  • 9 Likes/506 Replies/6532 Views
    guest-WTRS6QGF
    1 posts

    I can't fast travel:( It worked yesterday. I am playing the game on XBox One.

  • Aguzzin0
    1 posts

    @vipbt87 the game has only 20 save game slots.... if u want to save remove or delete older save game files from game menu

  • Husky_878
    6 posts

    I hoped that I would be able to save my game again after update 1.1 on the Xbox One. The issue would have been adressed. Still, I am not able to manually save my game, fast travelling does work however.
    I still get the message that 'Online functions are not available right now' in the world map, but I am connected to Ubisoft Connect.
    every time the game autosaves or cloud-saves, I lose my ability to manually save, making the game unplayable over 20 hours in.

    Valhalla is trash, you sold many people an utterly broken game.

  • Husky_878
    6 posts

    I have the same problem, even after Update 1.1. Trash game.

  • Maugetarelfin
    2 posts

    The 1.1.0 didnt fix this either... I have no words.

  • Thorliaug
    3 posts

    @ubi-borealis hi there ,

    i updated , i already did the quest a few weeks agoo , but still no save or fast travel ... what now ?

  • Thorliaug
    3 posts

    @ozoneheals hi there ,

    i updated ubisoft and the game to the new patch and still no saving or fast travel .

  • Husky_878
    6 posts

    @maugetarelfin Yup. It didn't fix anything. [censored] this game.

  • VipBT87
    2 posts

    @aguzzin0 I knew that. That only is not helping very much... It is simply not possible to save the game: "Cannot save game right now"

  • RoundishCone90
    1 posts

    Suffering from fast travel bugged can't continue playing the game

  • ktd
    7 posts

    1.1.0/2.0 broke the game for me. Can’t fast travel (says it’s unavailable) and can’t meditate at the top of the mountain in “Of Bloods and Gods” (meditation is grayed out). There’s nothing in the game I can do to progress so my 70h is nothing but a waste of time right now. 😞

  • igguk178
    2 posts

    @ubi-borealis
    Hi,
    I tried this morning and it seems to be working now, thanks.

    When i booted the game i didn't go to continue button but opened the Load menu, there was a New save there with the date of today that sent me to Raventhorpe, in front of the message box of the long house. From there everything seemed normal.

  • PresidentPrez1
    15 posts

    I am currently on the of bloods and gods mission and i can not meditate on the top of the ledge i have tried reloading previous saves all the way back 6 days ago. I have also ploughed 80+ hours into Valhalla and for this to stop me in my tracks is so annoying also the war weary mission is not continuing after i have killed the attacking hoard so my 80+ hours is also wasted my platform is xbox one x please find attached a picture of the bug/glitchundefined

  • kimtarian
    3 posts

    I can't travel or save after 1.1 update. once I start any quest, fast travel isn't available and neither is saving. I've tried every type of quest close to me. all saves....playing on stadia. game is essentially broken since I cannot save my progress.

  • DragonScale94
    1 posts

    Whenever I try to fast travel it doesn't work, and my character is stuck, only able move on the spot. Sorry, I hope that makes sense.

  • guest-GmxQATeF
    1 posts

    my game is taking too long to load after the recent patch, then when the game starts i can't fast travel anywhere. I'm stuck at my camp with no people around, graphics are incomplete, and I'm stuck in one spot. this has been going on for 2 days now. I feel like I'm gonna miss out on the yule festival. hope this gets fixed very soon

  • Aiii0000
    4 posts

    After downloading the 1.1.0 patch auto save isn't working and manual save is unavailable. The function was still working perfectly the day of the patch release, I played it that day before updating the game.

  • adrian_hrg
    1 posts

    December 17, has someone been able to solve the problem of saves and be able to travel fast?

  • Fitty275
    3 posts

    I'm stuck on the loading page anyone else having that problem? Its stuck on a black screen and the loading symbol in bottom right corner

  • morro64
    3 posts

    As noted by others since the Yule Festival update game loads up very slowly and I cannot fast travel, just reappear in the same spot with only half the details around me appearing, and unable to move. When I did manage to get to the Yule quests, full of bugs, waypoints missing or in ridiculous places far away

Suggested Topics