Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • ZeroInfinity94
    1 posts

    Fast travel gives me a bug, textures do not load properly and cannot move about have tried
    talking to Petra
    assassinating dummies
    sleeping in Eivors bed then meditating
    Validating game files
    loading a save before the problem began

    Nothing has worked, bug came up after starting Randvi romance quest.
    Running the latest version of the game as of 12/01/21
    Playing on PC

  • DommyTram0
    1 posts

    My fast travel does not work. I try to fast travel but it just keeps me in my same location after the loading screen, except my surroundings aren’t rendered fully and I’m stuck in place. I try restarting my PS4 but I get the same results. Then if I fast travel back to my starting point, it goes back to normal but slowly degrades to an unrendered state. This isn’t all the time but I basically gamble every time I load up the game. Is anyone else getting this or knows of a patch coming up?

  • IsatisAngel
    5 posts

    I have exactly the same bug, since the end of the Yule Festival, on PS4. When I want to do fast travel to or from the colony, the game loads, but I re-appear in the same area I want exit, stuck in place, with very low poly textures around me. It's impossible to fast travel or move. I must close and restart the game to try again, and the bug occurs really often ! This Yule Festival was a real mess, and it goes on poisoning the main game. The only solution I have is to enter or to quit the colony on foot.... It's very annoying ! It seems to happen less often with anchor fast travel point of the colony.... But not sure.

    Moriatii is right, this game could be great, but it has a HUGE amount of bugs ! Same as Unity, or even worse. Origins and Odyssey were more stables...

  • dwalls17
    1 posts

    This is happening to me now. I hard reset my ps5 and I spawn at RavenThorpe, whenever I leave I can’t save. When I die I reload at my fast travel point, but when I hard reset the console again, I end up back in raventhorpe

  • TonRoozendaal61
    1 posts

    Hi everyone,

    For a few months I have been looking for this problem to solve it. Many people say they have the same problem. Now my question is: where is UBI-SOFT to explain, or are they all deaf and mute there. Moreover, it is very difficult to ask UBI-SOFT a question about this problem. Would it help if EVERYONE complains and wants their money back? The communication with this Company is really, really bad. Are definitely counting the money they've collected from this game!


  • Asgardian02
    1932 posts


    i just hope you didnt purchase the season pass...

  • Ubi-Borealis
    Ubisoft Support Staff 1883 posts

    Hello all!

    I apologise for the delayed update. This issue has been marked as resolved following TU 1.1.1.

    If you're still encountering this issue in-game following this update, please don't hesitate to update this thread so we can take a closer look. If you are still encountering the issue, please can you include a video in your post that shows you're unable to fast travel/save, as this can be passed on for further investigation.

    Thanks all! 😊

    Official Response
  • BJWall
    3 posts

    Running 1.1.1 on Xbox Series x and I cannot save my game. I go into the save menu, pick Create a new Save Game and it simply won't save. I believe when it get in this state even the auto and quick saves aren't working. I'm about to lose all the progress I've made playing a few hours this evening.

    Very frustrating

  • BJWall
    3 posts

    V 1.1.1 Xbox Series X

    Issue happened again, I can no longer save games. I think I know when it happens. It seems to be after a quick resume. I immediately go into save game select 'Create a new Save Game' and it simply won't do it. No new same appears.

    I back out of the game and quit it in xbox. Go back in and I'm able to save a game.

    At least this time I caught the problem before I actually started playing.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @bjwall Apologies for the late response! How many save slots have you used so far?

    Official Response
  • BJWall
    3 posts

    @ubiexcellent Any chance Update 1.2 addresses the save problems?

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @bjwall Hello! This issue should now be resolved, but please let me know if that is not the case for you and I'll be happy to take a closer look at this with you.

    Official Response
  • bergeo2005
    1 posts

    @ubiexcellent unable to do manuel save since 10 december 2021 so if i play for 1 hours and close game when i go back it starte at dec 10 the last save game in the cloud i have a ps5

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @bergeo2005 Hey there! I went ahead and removed the email address you provided in your previous message, as it is considered sensitive information. Regarding this save issue you're facing, are you also unable to fast travel? There is a chance this is actually a completely separate issue, but I'd like to confirm that before continuing this conversation on a different thread with you.

    Official Response
  • cyber545
    1 posts

    Hello Dev Team,

    I can now manually save my game, Fast Travel is still greyed out.

    My last update was 2/27/2021 8:56 PM
    Size: 65.02 GB
    Version: 3.01
    Platform: PS4

  • Ubi-Borealis
    Ubisoft Support Staff 1883 posts

    Hello there @cyber545! Welcome to the forums 🙂

    I'm sorry to hear that you're unable to fast travel. I would recommend ensuring that you have the most up-to-date version of the game installed, as TU 1.2.1 was released last week (27 April 2021), which is a newer version than the version you have installed.

    If the issue persists after updating your game, can you send us a video that shows how you're unable to fast travel in-game? We can then pass this on for further investigation.

    Thanks! 😊

    Official Response

Suggested Topics

Community Details