Welcome to discussions

Quick Suggestions

  • gt2point0
    9 posts
    This post is deleted!
  • UbiExcellent
    Ubisoft Support Staff 756 posts
    Best Answer

    @b4st0un3 Thank you so much for sharing these video clips here! I'm happy to say that this issue with not being able to progress in "War Weary" due to Ceolbert being dead will be fixed in a future patch! The teams will share more detailed information about when this patch will go live on the game's official website, so please check here for specifics.

    Official Response
  • hernandezaali
    4 posts

    @gt2point0

    at what point did you drop the body? I sent pass the church to the barrier and threw him over. Saved game tried again and his corpse still lying on the other side. Bishop still does not have any interactions.


  • GicaDeLaBar
    3 posts

    @hernandezaali same here.....the body is on the other side of the mission area after I load the autosave and still I'm not able to talk with the priest.

  • bigdix1984
    1 posts

    Hello I was just wondering like everyone one else on here what’s going to happen with the 10 hours or so I have doing different stuff to try and work around this problem. My last save I can do is a week ago.

    please help.. lol

  • fatblokekev
    54 posts

    @bigdix1984 Hi mate - I would assume that you will lose everything else you have done in the meantime, however, don't take my word for that. I am only guessing. I am seriously considering starting again as nobody is seemingly prepared to give us an estimate of the fix time/ I looked back on the forums and this bug reared its ugly head on the 20th November, some 13 days ago!!!

  • fatblokekev
    54 posts

    I have come up with a solution to my time problem. I have started playing Assassins Creed Odyssey again. I have changed all the PC controls to the same as Valhalla so I don't get confused and, funnily enough, I think Odyssey is a better game!

  • bubs1985
    3 posts

    @fatblokekev not a bad shout £80 for a game i cant play never encountered a single bug In odyssey all 3 of my playthroughs

  • fatblokekev
    54 posts

    @bubs1985 Very true mate - I am really enjoying playing Odyssey again. Been on for 7 hours so far - NO CRASHES, NO HANGING. Sweet!

  • JimmyJoe70
    1 posts

    I submitted a ticket...this is a really bad problem, how do they not have a fix, yet? I expect more from a company of this caliber,

  • gingeryarou20
    2 posts

    Have reloaded previous file to restart mission, but once I’ve cleared them from the river the mission updates the name but doesn’t proceed to give me next step in quest line. Saw somewhere that if you had a hard save file to reload that it could possibly fix it( which I don’t so I’d lose 49 hours of gameplay to even) is this a patch that’s going to fix the issue or did the game just become worthless?

  • Ashlea.
    3 posts

    There is a known bug in the War Weary quest which stops me from proceeding at all. When will this be addressed / when will there be an update?

  • Betorak94
    23 posts

    Can Ubisoft or someone from support do something about it??! Can't progress and it's just annoying being there, quest is done but I can't just finish it!! Can't do anything else in the game apart from waiting. Is it possible to retrieve my money and just get on playing anything else than Valhalla??! Unacceptable.

    And no, I don't have previous saves. Fix these forums aswell. They're trash at this moment.

    Thank you!

  • Gooby1452
    10 posts

    I have a similar issues however Ceolbert died after I defeated leofrith and I can't even enter the church at the start of the arc!!

  • baughmr
    3 posts


    My case number is 13508164. Xbox One X user.

  • PhilFamous
    1 posts


    Same here.. During the battle in front of the church and at the river ceolbert dies and after all enemies are killed the mission does not continue because the new task is not shown. I only have auto saves and I can't go back to restart the mission, because I deleted all the saves and wanted to create a new one after that mission, which I now know was very stupid...
    I've already played 40 hours and can't continue playing the main story without having to start all over again. I’ve seen many bugs but that a story related npc can die is just ridiculous.

  • gian883
    2 posts

    Cannot proceed "war weary"

  • SithLordCarls
    1 posts

    I am still unable to complete war weary. Ceolbert is dead and now there are no ai’s anywhere to be found. I lost my save because I thought I could restart the mission by completing a harder mission. My game is pretty much broken. If anyone has any ideas other than restarting the whole game I’m all ears.

  • Loganxus
    2 posts

    Yep. reading all the ways that are suppose to work by heading with the horse to the barrier and jumping off at the right time so the body of Ceolbert be out of the quest zone... then returning back, killing the commander in the river first... All the plots and scenarios... still no result. does not work for me. it been 7 days for me to been unable to proceed and i would say 4 hours of trying different way to "work around the bug". Hoping eny day there will be update that will fix it. Very frustrating. Undone... Is there an official reply from Ubi on it. seems we can make our own raid party here.

  • fatblokekev
    54 posts

    @loganxus If you read back mate. the last acknowledgement from Ubisoft was on 1st December !!!!!!!

  • Loganxus
    2 posts

    @fatblokekev Damn...
    Then we need to "speak" with Ubi himself 🙂 [censored]... Durring those years i have been a fan of him, giving $ for many of the products, Ubi got me addicted and now my pal is failing us giving me the "doze"...
    Ubiiiiiiiiii, Where are you ?!?! Come on man...Just today man... give us answer... Say "it will be alright"...
    I do not want to be "clean" 🙂

Suggested Topics

Community Details

86
Online
140.6k
Users
24.8k
Topics
128.4k
Posts