ubisoft discussions

Quick Suggestions

  • thothomasd
    5 posts

    @ubiexcellent

    this is what my bug look like . I have exactely the same bug exept ceolbert not speaking and it is not written "follow ceolbert"

  • SEV--1207
    22 posts

    @fatblokekev it annoys me how this game is still being sold and hit best selling game like how tf is this the currently the best game to buy

  • fatblokekev
    54 posts

    @sev-1207 That "Top Spot" will soon diminish once everybody gets as far as the War Weary Quest and cannot continue. It is an absolute disgrace. Ubisoft should be ashamed of their nefarious customer practices.

  • ThusFarJay
    1 posts

    Ceolbert is dead and I’m unable to move through the story because his death won’t let me progress in the quest. I’ve tried taking him out of the area and he’s dead no matter what. I’ve been sitting on this for weeks. We’re had patches and updates. You’d think this would be on the list before seasonal events. I’ve gone unto other games. Fix this sh**!! Minor bugs are common, game breaking bugs are not. Unacceptable to go this long.

  • Itzdadon
    12 posts

    You guys can't be serious sending me an email stating that I'm not done yet, and showing my game stats. No [censored] I am not done yet. I can't progress. The fact that ya would even send that kind of email knowing the issues that the game is having is appalling. Another week of not hearing from anyone is getting kinda old already.

  • executorul007
    2 posts

    @billyrockfish same issueis on ps5.after145 play hours i can not continue quest "war weary" because Ceolbert is died in long house


  • UbiExcellent
    756 posts

    Hello everyone. I wish to apologize to all of you that are still unable to progress due to Ceolbert being dead. At the moment, our teams are still investigating this issue, but I'm happy to say that they hope to implement a fix in a future patch. While this might not be a specific date, I do hope this information provides some relief.

    @alshortstop0101 Our teams are looking into similar reports from players saying that they're not able to fast travel after the latest update and have made a Megathread about this here.

    @thothomasd Thank you for explaining the issue so thoroughly and for sharing this video clip with me! As I mentioned above, a fix should be added to the game in a future patch, but specific details will be shared at a later date. Please stay tuned!

    @bayshark1977 I appreciate you sharing your case number with me here regarding the issue you're facing in 'Blood from a Stone'. I've added your save file to our on-going report about this issue.

  • fatblokekev
    54 posts

    @ubiexcellent

    hope to implement a fix in a future patch "

    That fills me with massive confidence! (Not)

    " I do hope this information provides some relief "

    Who are you kidding? It is now 40 days since this bug was reported. As I have said in one of my previous quotes on this matter, Ubisoft are displaying totally nefarious customer service standards. A full refund is the only way out of this hole that Ubisoft have dug themselves, plus a FULL apology across the broad spectrum of the Trade Press.

  • SammieRae2911
    3 posts

    While I appreciate the update from Ubisoft, this bug was reported by me thanksgiving week. A complete MONTH has passed by with no fix. Whatever happened during the last update completely broke the game for me. I am now unable to call my ship or fast travel. I was previously unable to meditate with the War Weary bug which prevented me from completing the Snotingshire story arc, as you need to meditate to complete one of the quest. This game is literally UNPLAYABLE at this point and such an incredible disappointment. I am not starting over and losing all that game play to probably just run into another game breaking bug. This has been the worst gaming experience ever. Just look at the megathreads with all the reported problems, I have never seen anything like it, it's absolutely ridiculous. Was the game truly finished before you sold it to your customers? I feel Ubisoft owes their customers some sort of compensation. A refund, credits, SOMEthing. We did not get what we paid for, and I don't know any product in which I pay full price that doesn't perform, or is broken, that I can't return or compensated in some way. Ubisoft is going to lose a lot of customers, including myself, with how disappointing this experience has been.

  • SEV--1207
    22 posts

    @fatblokekev loool that's funny XD who comes up with these messages

  • fatblokekev
    54 posts

    @sev-1207 Supposed to be a Representative of Ubisoft, lol

  • muners86
    4 posts

    Just got a message from Ubisoft saying your journey is not over yet. Well don’t you think I know that Ubisoft if you sorted this bug I’d be well on my way progressing through the game.

  • fatblokekev
    54 posts

    OK - So I sent an email to the CEO of Ubisoft in France...

    "Dear Mr Guillemot

    First of all let me say that Assassins Creed Odyssey, with its DLCs, is by far the best game I have ever played, and being 66 years old and having played hundreds of different games, that is truly an accolade. 

    It is a shame that I cannot say the same for Assassins Creed Valhalla...  On 27th November 2020 I hit a glitch in the “War Weary” quest, meaning I was stuck in that quest with no way of progressing with the game. This bug was first reported to your staff via the Ubisoft Forums on 20th November 2020. Over 40 days later neither I, and I assume many thousands of customers are still stuck. This is a very serious situation in that people who have paid quite a large amount of money are not getting the benefit of either a playable game or good Customer Service. All we get are vague comments from Forum Modulators that it MAY be fixed in a future update whenever that may be. The full forum thread can be found here: https://discussions.ubisoft.com/topic/86520/unable-to-progress-with-war-weary-because-ceolbert-is-dead-post-here/307?lang=en-US

    The reason I mentioned Odyssey is that, the day after I couldn’t continue with Valhalla. I started Odyssey again from the beginning, and have since completed it, including the add-ons. This shows the length of time I have waited for a fix to Valhalla. 

    I am writing to you as a last resort to see if you can achieve what your Moderators cannot. There are a lot of very angry customers out there who feel they have wasted their money and have lost faith in the Ubisoft Brand.

    Kindest regards"

    One day later I got this reply from Ubisoft Customer Support....

    "Hey fatblokekev,

    I'm contacting you from Ubisoft Support. We're contacting you in response to a letter you've sent to our CEO.

    I can appreciate that it's been quite a while since you initially contacted us regarding your issue in completing the quest War Weary in Assassin's Creed Valhalla.

    The information you provided to us was actually instrumental in the developers identifying the cause of the issue and how to resolve it; there is a fix planned for an upcoming update to the game which should resolve the issue and allow you to continue. I'm afraid however I'm unable to provide a specific date for the update.

    Due to certain factors, such as the certification process, there is no way for the development team to push an update out any quicker than the date it's currently planned.

    Should you require any further assistance with the above or have any other queries, please feel free to get back in touch.

    Kind Regards,
    Ubi-76
    Ubisoft Support"

    So obviously, the CEO just passed it to Customer Support who came back with the same lame answers, (and STILL no apology).

    Where to go from here?

  • SEV--1207
    22 posts

    @fatblokekev it's just the same bs response from these guys.... we hope to fix it soon is such a rubbish response for something that needs urgent attention and professional customer support I'm tired with these guys getting away with this [censored]

  • luffy.11
    2 posts

    Same heren xbox one

  • NATHRAAKH
    1 posts

    I litteraly can’t progress in the game because the second I speak to Ceolbert and Ivarr in sciropscire and the cinematic scene ends CEOLBERT IS DEAD ON THE FLOOR


    ps4

  • mohdmohd2468m
    1 posts

    After kill enemies.. I can't finished quest and still Subject without any request...
    This after update 1.1.0

  • Stu2985
    4 posts

    I have tried this on my daughters PC which is brand new high end gaming pc loaded up my saves and the quesst is still bugged on a totally diff spec machine threfore the issue must lie with the quest mechanics.

    The fact its across platform as well must mean there is a combination of things that those if us who cant proceed have either done or not done.

    Submitting my tech specs isnt really going to solve this one UBIsoft.

    After 100 hours in I am loath to restart the whole game again as it appears there is a very high chance it could bug again in exactly the same way.

    Month waiting for a patch is a bit of a joke really whem a lot of games can bring servers down and patch instantly.

    Very frustraing and i wont be buying an add ons or AC games again which is a shame as this was my first one and its put me right off.
    ~

  • Reju405
    1 posts

    Third January, still no fix nor any info about fix and ppl complaining about Cyberpunk2077 unplayability...

  • Lun4de4thstryke
    2 posts

    Same for me and on pc. You can't progress further into the game without completing this. I've tried going back to Ravensthorpe to see if I can switch to a new town and you can't. I have no prior saves so unless I start over, which I'm not.. I've got over 100 hours vested into the game.. I can't continue. Please fix this!

    It's pointless to play half of a game and the money you spend to not progress.

Suggested Topics