Welcome to discussions

Quick Suggestions

  • diiorio
    40 posts

    @xzxdarkhuntzxzx may be something with the controller chip not set for window 10 or not detected right by windows. Check for driver updates from MS. the chip set may not yet be in current drivers that work with default xbox one controllers. COuld be a settign for bluetooth or device id not recognized.

    hopefully it will be fixed soon.

  • Ubi-Spud
    Ubisoft Support Staff 675 posts

    @dontonn Hey there! Not a fix I know, but does this happen at all when you are connected via cable?

    Please try verifying your game files and testing the game again.

    Official Response
  • Shelty321
    3 posts

    how am i able to connect my controller to my pc in valhalla? i connected it to my computer and its flashing on but the game wont register it and wont let me change modes

  • Shelty321
    3 posts

    @dontonn how are you able to play? i plugged my controller in and it wont pop up or let me change from my keyboard

  • KKonieczko
    3 posts

    Seconded - the controller works (well enough) with the Uplay Connect overlay, but the game itself is not recognizing my controller.

  • okiemarine
    2 posts

    The game menu recognizes all inputs from my XBOX controller, but in-game it doesn't recognize the RB. You know, the one needed for light attacks... On PC.

  • Shelty321
    3 posts

    @okiemarine so you just plugged yours in and it was able to recognize it no update or programming needed? mine wont even register when i plug it in

  • okiemarine
    2 posts

    @shelty321 Yeah. My controller is always plugged in. It recognized it right away, even when I unplugged and plugged back in, trying to troubleshoot the button issue.

  • KKonieczko
    3 posts

    @shelty321 @okiemarine
    That sounds familiar - the controller works, but the shoulder buttons don't register for me either. I also don't have the option to change the control from 'Mouse+Keyboard' to 'Controller'

    Weird.

  • KKonieczko
    3 posts

    @Shelty321 @okiemarine
    Ok, I found a workaround. Got to the first elite fight and WASD + Q + Shift + Alt for all the commands was not working for me.

    I loaded Valhalla into Steam and launched from there - no issue with the controller at all from that point. I use 'SteamGridDB Manager' for this. Not sure if it will help with your particular issues, but it cleared up mine!

  • JC_Denton89
    4 posts

    Xbox Series X controller not working for me when plugged in either. A Uplay popup shows that a controller is detected and it detects controller inputs when I activate the uplay overlay, but in game it is not detected.

  • JudgeKenobi
    5 posts

    What's super fun is this doesn't seem limited to PC only. While I do not yet have the new series x console in-hand, I did pick up one of the new controllers. They work with xbox one so no problem. It is great on the console. As soon as I start trying to play Valhalla, it is doing this really weird thing where it alternates between connected and disconnected every couple of seconds and appear to try to be swapping between keyboard and mouse and controller at those times. Either way, it effectively leaves the game unplayable with the new controller. I did not have this issue last night with a standard xbox one controller, but the issue appears to be limited strictly to Valhalla. Not sure how this went unnoticed.

  • JudgeKenobi
    5 posts

    Fun fact, this is true on both console and PC. The new xbox controller constantly disconnects and reconnects when in gameplay for Valhalla. For some reason, when you get in to submenus, it works fine. Issue seems limited to ACV and doesn't occur on other titles. I submitted a support ticket. If it matters, I am using an xbox one with the new carbon black series x controller.

  • JC_Denton89
    4 posts

    Okay for me it seems like a windows update issue. Series X controller now works in-game after installing windows updates as well as updating all the xbox related apps in the Windows store.

  • JC_Denton89
    4 posts

    So after those updates it works when connected via USB C but bluetooth still isn't working despite showing up in windows and being detected by the ubisoft connect overlay.

  • blumpz
    8 posts

    @judgekenobi yes thats the issue im having as well. although it did die down when i hooked up the wire instead. when its bluetooth only it somehow messes with the connectivity and renders the game choppy as hell because of it coming on and off. I think it must be eating up all the CPU at those times or something. But it just happens so frequently that it just seems consistent when it really shouldnt be

  • fyredog911
    1 posts

    The Xbox series x controller connects perfectly with my PC and functions in the Ubisoft overlay, but does not allow use within the game itself.

  • y00pdl
    2 posts

    I have the same issue;

    The game freezes for a little bit, and normally comes back fairly quickly. This isn't a 'once in 15 minutes' thing, rather a 'every other minute or so' thing. Later I noticed that when this happens, the Ubisoft notification in the top right corner tells me my Xbox Elite S2 controller was disconnected, and it will reconnect fairly quickly as the game continues. A few times it didn't reconnect at all and wouldn't reconnect manually either, while the game was running. When the game is closed the controller can be manually reconnected again.

    The prologue was as good as unplayable with this issue, and I haven't progressed any further.

    The controller is new (purchased new about three weeks ago) and has shown zero issues in any other title, at all.

  • menocrazyfool
    1 posts

    @y00pdl I have the same issue. Playing on PC with Xbox Elite Wireless 2 controller via bluetooth. Only occurs in Valhalla. Frustrating. I am having to use a cable which is ruining my immersion in the game

  • dcGColts
    12 posts

    @acedarkholme-t2 I have same issue with Xbox Series X controller Shock blue my cyberpunk special edition xbox one controller does it also but not as frequent both via bluetooth z490 unify. It seems to happen only when ubisoft connect is running. I am not sure if it's all ubisoft games but I know valhalla its really bad.

    BTW @y00pdl to fix the lag from this switch, go to control tab in valhalla settings and set control method to xbox controller instead of hybrid.

    Before with uplay this never happened. I have not tried xbox wireless adapter to see if that still does it but with wireless adapter input delay is higher so I prefer bluetooth.


Suggested Topics

Community Details

35
Online
130.9k
Users
22.7k
Topics
117.8k
Posts