Welcome to discussions

Quick Suggestions

  • Song.of.Victory
    1 posts

    I'm having the same issues with the same controller: pc with both of my xbox elite 2 controllers. Keeping the controller plugged in does work, but it basically breaks my controller if I try to do wireless. After a while the controller will permanently unpair, and I have to restart my pc and set up the controller as a new bluetooth device. This doesn't happen for any other game. Both controllers are updated to current firmware.

  • Parayia
    1 posts

    Having the same issue as reported before, same controller. After a few disconnects I have to restart the pc to get the game pad working again. Sure cable works, but that's not the way a wireless controller is meant to be used. Hoping for a fix.. Can't enjoy it at all with a dc every 5 minutes.

  • TheZonk88
    57 posts
    Hi,

    I play on the PC and have the problem that my Xbox Elite 2 controller is repeatedly disconnected and reconnected according to the overlay. So far, the problem only occurs with Assassin's Creed Valhalla. The period between disconnect and reconnect is not noticeable, but there is a massive lag in the game per connect message from the overlay.

    Does anyone have any tips?


    @dontonn Hey there! Not a fix I know, but does this happen at all when you are connected via cable?

    Please try verifying your game files and testing the game again.



    Your Problem is related to my Bug report. Everytime your Gamepad is disconnecting the Inputmode is switching to K&M which causes the "lag"

    https://discussions.ubisoft.com/topic/79462/bug-input-mode-hybrid-causes-freezes-and-stutter

  • AiQLee
    2 posts

    Same issue here with Elite 2 controller. Haven't found a fix

  • Naithachal_
    1 posts

    Same here don't they test such things bevore release?
    X-Box Controller isn't some no name....

  • AiQLee
    2 posts

    I think I found a way.
    Add your controller to Steam.
    Add the game to Steam as well (Steam has an option to add non-steam game to its library).
    Then use Steam to start the game.

    My Elite 2 didn't get disconnection anymore.

  • BubbaFett7242
    1 posts

    Over the past few days I have used an Xbox one controller to play Valhalla on my computer and it has been working fine, but yesterday it completely stopped working. It works completely fine with other games and in Ubisoft Connect, and I can use it at the start screen where it says "press any button", however in both the menu and the game itself it does not work. I have already tried the following: uninstalling and reinstalling, disconnecting the controller, restarting both the computer and the game, as well as attempting to add it the my steam library as a non-steam game, however I got a 'catastrophic failure' notification upon trying to do that. I can't stand playing on keyboard and mouse and is extremely frustrating.

  • guest-n3dibAOI
    1 posts

    I have a rather infuriating bug when the game thinks the controller has disconnected intermittently during gameplay. I have been unable to play the game because of this. Any fixes available?

  • Ubi-Baron
    Ubisoft Support Staff 730 posts

    @guest-n3dibAOI Thank you for reporting this to us.

    Just to confirm, this is happening on the Xbox console or on PC with the controller?

    Are you playing with it wirelessly or plugged in? Does it make a difference if you change from one to the other?

    Official Response
  • synwinger
    1 posts

    @guest-n3dibaoi
    I have the same problem too. Mine is wireless.

  • OptimistNZ
    1 posts

    @aiqlee This worked for me, thanks!

  • Ubi-Spud
    Ubisoft Support Staff 700 posts

    Hey there, I'm sorry that the controller isn't working! Are you connecting via Bluetooth or wired connection?

    Official Response
  • Scheckleberg
    3 posts

    See below for tweet @ ubisoft support.
    Bluetooth for Xbox elite series 2 controller not working in valhalla
    undefinedundefined

  • FIobert
    1 posts

    Same problem, Xbox Controller Elite 2 gets disconnected every 15 minutes in-game (Valhalla) after short freeze. Will try the Steam workaround.

  • Scheckleberg
    3 posts
    This post is deleted!
  • TBlair64
    2 posts

    @ubi-baron this happens to mine as well. xbox series x blue controller on xb1.

  • dcGColts
    12 posts

    Steam fix works good I did notice minor issue at times where response would be liked delayed on movement or character would stop running as if controller was disconnecting but it wasn't very rare occurrence though. If these company's are going to go epic exclusive they should really understand what makes steam so popular in the first place and adapter the same/similar features.

  • mastafreak87
    2 posts

    Just got my carbon black controller today and it's doing the same. The issue is also happening with a PS4 controller so the issue must be related to Ubisoft connect latest update. 😠

  • DrowBacks
    1 posts

    This is happening with my white Xbox Series X controller on PC, but my PS4 controller works fine. Disconnects every 15-30 seconds or so, but it isn't occuring with any other software.... Just want to invade Britain with my fancy new controller.....

  • Scheckleberg
    3 posts
    This post is deleted!

Suggested Topics

Community Details

120
Online
141.2k
Users
24.9k
Topics
129.3k
Posts