Welcome to discussions

Quick Suggestions

  • KhanGungus
    2 posts


    I'm unable to start the fight at @ Walsham Crag - there is nothing to interact with to start the fight. This occurred after 5 or so boss attempts - I've moved on hoping the quest would reset but it looks like it's still broken.

  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts
    Best Answer

    Hey all!

    We're glad to hear that you've been able to successfully fight Regan now! As we've had no new reports of this issue following TU 1.1.1., we will now be setting this case as resolved. If you are still unable to start the fight with Regan, please don't hesitate to update this thread so we can take a closer look.

    Good luck with the rest of your viking adventures! 😄

    Official Response
  • Lampert95
    3 posts

    @j2ezg I feel like this is one of those small issues that may never get fixed :{

  • EvilWaylander
    7 posts

    The witch sister at Walsham Crag has glitches out. I killed her as she killed me I got de synchronised.
    I didn’t get the dagger and the icon is still there on the map but I can’t trigger the body to get her to appear.
    I have tried numerous times to by fast travelling, doing something else first.
    but no luck any ideas

  • Bluefire016
    1 posts

    I am having the same issue. Reloading the game, fast travelling away, and playing through the story further hasn't yielded results. I also tried placing the dagger of one of the other sisters into the statue and no luck.

  • takaranta
    1 posts

    I have a problem where I left the mission since I died too much leveled up came back and now when I try to interact with the corpse it’s not triggering please fix this as this is the last daughter I need to defeat

  • Gerend
    1 posts

    Same just now, killed 2 of them but can't interact with the one in Walsham Crag

  • Zlgrate
    1 posts

    I cant play the second daughter of Ragnar at Walsham Crag. I tried and failed earlier but now cant interact with the corpse to spawn her.
    I defeated the 1st and 3rd daughters already, maybe doing the 3rd before glitched it?

    Tried meditating, reloading save files, fast traveling and progressing in story quests...

  • Galacticrazor11
    3 posts

    When doing the Daughters side quest when I died at Walsham Crag so I changed my gear to try a different way yet when I went to do the mission it wouldn't even let me do it crashing once and then not even letting me do the fight at all and nothing I've done has worked no matter how early I go into my saves it wouldn't work

  • XxIpManxX95
    1 posts

    I am also having the same issue for this boss on PC. I fought them three times and lost. All the sudden I cannot interact anymore to start the fight again. really want this gear cause I am a bear tree main.

  • KhanGungus
    2 posts

    Still unable to start fight, other sisters have been defeated, completed other zone arcs.. Seems there will be no way to reset this and will require an update from Ubisoft to resolve unfortunately. Huge bummer wanted to finally get into a new set of bear armor.

  • IbrahemHosni_95
    2 posts

    when I arrive at the location (Walsham crag) nothing respawn. I killed the other 2 bosses of daughters of lerion but this one is not respawn on PC version

  • Mvh44
    1 posts

    I attempted this mission a handful of times at a lower level and failed. The mission has since broken or bugged out for me and I can no longer attempt to fight Regan. I defeated the other two sisters while lower levels and needing to give it a couple tries. Does anyone know of a fix or work around? I am sorry if this has been posted before for this specific character I know there has been issues with Gonriel. Any help is appreciated or information.

  • Ubi-Baron
    Ubisoft Support Staff 730 posts

    Hey guys,

    Thank you for reporting this to us.

    We have passed on issues with the Daughters of Lerion to the AC team to be looked into.

    Just to confirm, did you all die a few times before this occurred, and have you been able to interact/start the fights with the other ones after this point?

    Official Response
  • Ubi-Baron
    Ubisoft Support Staff 730 posts

    Thank you for reporting this to us.

    Did this occur after having died a few times on this boss fight? If so, then this is something that we are aware of and is currently being looked into.

    Did you take a break at any point from fighting them or was it immediate retries before this occurred?

    Official Response
  • monkey36948
    3 posts

    One of my witches (regan) is bugged and I can't summon her now I died to her very early on in my playthrough around 40/50H ago and now I can't 100% or get the thor mythic armor or weapon

    What can I do here cause losing 40/50H of progress is not gonna happen

  • NikolaFilipoff
    1 posts

    It's been a few days now and still am unable to start the fight with Regan. Can't interact with the dead body to start the mission and I already beat the other two sisters. Please fix that asap, you're stopping me from getting Thor's stuff. This is not a minor bug, this is a vital mission because of the rewards.

  • Ubi-Ginge
    Ubisoft Support Staff 135 posts

    @galacticrazor11
    What platform are you playing on when you experience this?
    The devs are currently looking deeper into this issue
    If you're on PC or PS4, can you please share your save with us via Facebook PM or Twitter DM

    Official Response
  • Seraphix2407
    1 posts

    @ubi-ginge This is on ps4 for me. I died 3 times against her and it bugged out.

  • Ubi-Swaggins
    Ubisoft Support Staff 346 posts

    Hello everyone, sorry to hear that you have encountered this issue.

    The team are investigating this issue further, but are requesting save files of affected players.

    Can you provide that via our website?

    Official Response
  • Hodgiebeats
    1 posts

    @henrybowen1 Same here, I died to Regan a few times and now I can't interact with the Corpse. It's made me afraid to fight Cordelia at this point.

Suggested Topics

Community Details

160
Online
141.0k
Users
24.9k
Topics
129.0k
Posts