Welcome to discussions

Quick Suggestions

  • Ricardo198629
    2 posts

    I have already defeated two daughters of lerion, all I need is regan but when I get to her and be in it. Corpse does not appear to me the option to inspect to start pearl, does the same thing happen to someone?

  • Ubi-Borealis
    Ubisoft Support Staff 2929 posts
    Best Answer

    Hey all!

    We're glad to hear that you've been able to successfully fight Regan now! As we've had no new reports of this issue following TU 1.1.1., we will now be setting this case as resolved. If you are still unable to start the fight with Regan, please don't hesitate to update this thread so we can take a closer look.

    Good luck with the rest of your viking adventures! 😄

    Official Response
  • Gr1mz2
    2 posts

    I've been playing Valhalla for well over 50 hours now and I must say the game is absolutely wonderful. I tried Regan boss fight twice and I couldn't seem to defeat it so I went back to main and side missions to grind and increase the power level and now that I'm back to defeat Regan now that my power level is par I can't seem to interact. I play on PC and this bugs been stopping me from enjoying the game as I'm a completionist and I like to go sequentially through the entire game as it's meant to be played. Please fix this as soon as possible!

    Update: the 2.75gb update that came today adding the new hels armour set. But still hasn't patched the bug yet.

  • GloFriend
    6 posts

    @capsomann

    PS4 here and Cordelia is bugged. I can't interact with the hanging body.

  • AL12W
    6 posts

    Im having the same issue, tried the Daughter at a lower level lost alot so went away to level up and came back to not be able to interact. Now im unable to platinum due to being unable to finish East Anglia. Do we have a patch time frame or if its getting down?

  • Bizzareoutsider
    1 posts

    @ubi-baron
    It will not allow me to fight goranil again I tried the fight back to back like 6 times amd now I can do it again please fix this

  • Wolfsdead91
    1 posts

    I have this issue also on ps4 i fought goneril 3 times then after I tried to fight her again there's no icon to interact with on the body anymore and I've tried alot of things rebooting, fast travel ect and nothing worked will this be patched soon ?

  • jeffertson1987
    11 posts

    Still the same problem fore over a month now quite playing because i cant get thors armor complete en thors hammer stil no fix fore it 😠😠😠

  • tokajero32
    21 posts

    Not sure what to say, its been 35 days. This issue was posted since day in the forums from other players. We sended videos/files/saves to the team. yet u gave priority to other things to fix when this is a very important part of the story and claiming the hammer. Really cant say more. I like u guys i like your games but there is something odd here. With these kind of actions u lose clients. Lets wait now next patch god knows when or maybe u will fix it in the next expansion.

    Peace out guys in ubisoft team. Happy new year!

  • MindOfEllis
    7 posts

    New update still not fixed and I'm getting very frustrated cause I'm on xbox and it did the same thing to me

  • AL12W
    6 posts


    So... Did literally almost everything else get patched except for the Witches? So frustrating i wouldve platinumed ages ago, its not minor its major because you cant even finish the trophies. @ubi-swaggins

  • deckdaddy21
    14 posts

    @mindofellis PC Same boat. It's not only glitch they haven't fixed. Can't pick up a key in Lunden either. Figures. They add content but can't fix what's broken. go figure.

  • Nucleaire9740
    2 posts

    Bonjour, j'ai un bug avec un mystère en est-anglie je ne peux pas déclencher le combat avec l'une des filles de lerion. ( Celle au nord de l'est anglie ) impossible d'intéragir avec l'homme mort qui déclenche le combat

  • Nucleaire9740
    2 posts

    Bonjour, il m'est actuellement impossible de démarrer le combat avec l'une des filles de lerion. (Celle au nord de l'est-anglie) je ne peux pas intéragir avec le cadavre pour démarrer le combat

  • Crl1991
    1 posts

    @ubi-swaggins this is a month later nearly how is this not fixed with the most recent hot patch?!? People are [censored], it’s a vital part of the game not some irrelevant side quest. THIS SHOULD BE A PRIORITY BUG FIX

  • IdoIronSide
    1 posts

    I'll provide save file , given the instructions on how to share those


    this is not a minor bug. it prevent players to gain thor's armour and as result mjolner the hammer is out of reach.
    I play with a hammer in the game and i would like to obtain the armour and the thors hammer.
    its not like some treasure map locations that are buggy, its actually critical to the game

  • Little_Ruddegar
    1 posts

    I’m super frustrated that after the huge patch this still hasn’t been fixed. It’s pretty game breaking for me. I’ve never whinged about bugs in the past because these are impressive games and the issues are always cosmetic. But this shuts out a major part of the game.

  • Ubi-Woofer
    Ubisoft Support Staff 818 posts

    Hello everyone,

    I am pleased to confirm that a fix is planned for a future update, and this should fix not only Regan but the other two sisters as well to my understanding. We don't have a confirmed date for the patch yet however as soon as we do, we will be sure to update not only this thread but the others for the other two sisters as well.

    We are incredibly grateful for all the information and resources provided by players in order to identify these issues and investigate them. The images and videos received were invaluable to the developers and the time taken to produce and provide these is not ignored. Thank you all very much.

    I'll return as soon as I have more information; in the meantime, do not hesitate to reply with any questions, concerns or feedback.

    Official Response
  • AL12W
    6 posts

    @ubi-woofer
    Thank you, and also i love the game. 🤙🏻

  • Gr1mz2
    2 posts

    @ubi-woofer Thank you so much!

  • eduardreiner
    1 posts

    Hello everyone, I have a problem with the dead body to start the Fight VS the Witch in Walsham. Trying to reload, but problem is still. No interaction with the dead body. I'm the only one?

Suggested Topics

Community Details

49
Online
144.0k
Users
25.5k
Topics
132.5k
Posts