ubisoft discussions


  • locked topic_solved [RESOLVED] Unable to interact with the corpse to start the fight with Cordelia | POST HERE

    2 likes/277 replies/7134 views
    Original poster ubisoft:x-posts, 7

    Hi Ubi!

    Have you completed any other mysteries in the area?

    • Im only missing Cordelia of the three Daughters of Lerion. I have completed several of the mysteries, both before and after the bug.

    Have you left the zone before returning?

    • The issue first arrived for me after I returned to the game, after saving and going to bed. The day before the bug I was able to try fight Cordelia for probably 30 times. No issues. When I restarted the game and returned I could not interact.
    • I tried to leave the zone, fast travel to other locations and return, reload the save, complete missions (both main and other), travel to Asgard/Jotunheimen and return. Did not work on the old patch, nor on Patch 1.04. Tried all of this on both patches.

    Did you complete any other main quests before returning?

    • I have completed many main quest missions since I discovered the bug, but I had not done any missions (Main or other, including mysteries/wealth/etc.) between the time I was able to summon Cordelia and not. I'm, however, not 100% if I went to bed because I was not able to interact with the corpse or not, but I believe I was able to.

    Have you been able to interact with the other 2 corpses for the Daughters of Lerion mysteries? Which daughters have you been able to successfully interact with?

    • Yes. I have completed both the two other Daughters of Lerion mysteries. Cordelia was the third one I attempted. I did them in a sequential order, so I did not jump between them without completing them.

    I hope this will help you finding a solution to the bug. I really appreciate that you are working hard to solve this, however, I must be honest and say that I am a bit dissapointed that there has been so many bugs - especially the ones like this that is in my - opinion - gamebreaking. All in all, thank you for one of the best games in the series, love it, and hope I can wear Thor's armor soon.

    Edit: In additon, I want to note that It seems like my experience have been somewhat different from many others; I did get to interact with Cordelia many times - not only 3 or 4 times - before the bug appeared.

  • aradead
    ubisoft:x-posts, 1

    I have the same Issue! Unable to interract with Cordelia, I'm on PS4.
    I have kill the two other daughter and complete Other quest in this Zone.
    Need a fix. Please.

  • cmburkit
    ubisoft:x-posts, 4

    @sadarum @valtyrnine this is a huge programming bug with a broken embedment. The only thing left to 100% the game is one sister and finishing the Thor gear.... this needs to be fixed. UBI QUIT ASKING PEOPLE FOR INFO AND SCREENSHOTS. THIS HAPPENS ON EVERY VERSION AND IS WIDESPREAD. IVE SEEN OVER 100 posts here with the same issue and complaints that all you are doing is asking for system info and screenshots

  • Dannspress
    ubisoft:x-posts, 22

    @ubi-ginge PC! And yes, still experiencing
    Already send my files to the support!
    On the comments you will find the ticket

  • Azriell666
    ubisoft:x-posts, 3
  • Ubi-Pingu
    Community Representative ubisoft:x-posts, 132



    Please, provide additional information about your gameplay:

    • Have you completed any other mysteries in the area?
    • Have you left the zone before returning?
    • Did you complete any other main quests before returning?
    • Are you able to interact with the other 2 corpses for the Daughters of Lerion mysteries?
    • What platform you are playing on?

    I would also like to remind you that bumping threads is against forum rules.

  • vipandree
    ubisoft:x-posts, 8

    @ubi-pingu I had this issue too. Can‘t interact and finish this mission.

  • vipandree
    ubisoft:x-posts, 8

    @ubi-pingu the others 2 daughter are finished only the last one.

    • I had died and then returned and the mission can‘t be no more interacted.
    • main quest done.
    • ps4 and ps5
  • zoh-pb
    ubisoft:x-posts, 1

    After dying 2-3 times I can no longer interact with daughter of lerion in east anglia. It’s been 3 days and it’s frustrating

  • Ubi-Baron
    Ubisoft Support Staff ubisoft:x-posts, 798

    @zoh-pb Thank you for reporting this to us, we are aware of issues with these encounters and it's being looked into.

    Would this be Regan or Cordelia?

  • DanRag85
    ubisoft:x-posts, 10

    @Ubi-Ginge would it not be possible to update the game so that each daughters of lerion encounter automatically starts when you enter their area. This would fix the problem for everyone as we all have the glitch on different encounters. Would be great if this was possible thank you.

  • Lucasbe111
    ubisoft:x-posts, 1

    i also have that problem with Goneril.

    i died 2 or 3 times and then i could no more interact with it, i tried to interact with it again after finishing an arc and starting a new arc and i also tried to restart the game, did not help.

  • Cone4152
    ubisoft:x-posts, 1

    I have done everything else in the game i'm at 94% completion on Xbox one, this is the only thing that is stopping me from moving forward.

    No interaction available have saved, closed loaded back in left the area come back meditated and as stated above have finished everything else.

  • Vizjerei77
    ubisoft:x-posts, 3

    Hi, i don't have this save anymore(or i can't find it ).I started the new game after completing the story because patch didn't help me,and this mystery ended well. But i have now problem in Jounheim with mission where we must find this Ymir's caouldron. Problem is in this, that i was there(inside glove) before this mission happened to find Ymir's blood, i leaved this place to find other parts of blood...but now,when i have this mission...i can't enter the cave in glove or when i start the route from that abandoned cart near Snake tree , i can enter this glove but after long corridor i end up in fingers part of this glove and there is no place to go down

  • oedipian
    ubisoft:x-posts, 1

    Same issue with Cordelia. Got beaten many times, so I decided to come back when more powerful. I'm level 250+ now, and I can't interact with the hung corpse.
    Please Ubi, fix this, I want to complete the Thor armour !

  • Arashismap
    ubisoft:x-posts, 1

    Me too Fix it

  • Ubi-Pingu
    Community Representative ubisoft:x-posts, 132


    Thanks a lot for a reply! I will pass this information to the team.

  • kimosabe888
    ubisoft:x-posts, 4

    My bug issue is a little different. I can [E] interact with the dead men to start the fight. Once the open cut-scene finished, and boss runs to me knocks me to ground, and then I can not get up, I can not move, I can't use abilities, none of the keys I press do anything, I can't do anything. I can't fight so I just stay on ground, while boss continues to hit me over and over until I die, I'm just stuck. The H button does work because when I get lower health I can press H to restore health, while boss continues to just hit me over and over while I stay stuck on ground until I have no health rations anymore and die. This has repeated multiple times on both bosses Goneril and Cordelia. I have not tried the Regan boss yet.

    Things I have tried but none worked:
    (1) Rebooted game many times, closed other apps running, rebooted my PC (windows 10 64bit, GeForce rtx 2070 Super gpu). gpu drivers are fully updated.
    (2) reset game settings to default.
    (3) Left zone and returned, went to different zones and returned, I also went to sleep in my bed in Raventhorne and returned.
    (4) Tried starting the game from different software both the UBI launcher, and the Geoforce Experience game starter.
    (5) Went to Inventory and in lower right of screen selected to Exit Animus, then returned to Animus (because this is something fisher people are trying to get fish to appear since fish are also bugged).
    (6) I am at skill level 400, with many master points at this point.
    (7) I have not finished all the mysteries quests in the zones of the daughters. How would I get a list for you of the quests/mysteries completed for the zone? I finished all Vinland quests, I think I finished all main quest but I don't know how to tell. Currently about 99% done Jotunheim quests, but since I went back to Ravensthorpe, it says my current quest is Bound to Fate (return to asgard), I waited a long time to do asgard line of quests.

    ubisoft:x-posts, 1



    I am still experiencing this on Xbox Series X. Like many of the other comments here, I have defeated both of the other sisters and need to beat Cordelia in order to progress in pursuit of Thor’s armour set.

    I tried to beat her approximately 30 times when I was around level 60 and left to power-up. I returned around level 160 and the interaction (y) button prompt was gone. I tried restarting the console, restarting the game, several different fast travel points and interacting with the environment as much as possible. Then I found the other 2 sisters and beat them in order of difficulty (lowest to highest) to see if it would unlock sequentially. Cordelia will be my last opponent in this arch.

    I’ve sent the following video to UbisoftSupport on Twitter. I cannot upload to this thread for some reason.

  • Retr0_517
    ubisoft:x-posts, 1

    I am trying to get the Thor set so I can get the hammer, but the Daughter of Lerion in Berkelow Bog isn't working. I tried fighting her at a lower power level and I failed so I came back at power level 300, and I can't even interact with the body. The piece of her gear and her father's vault is the only two pieces of gear I have left to get. I love this game and put 60 hours in on the first week of release, but until this is fixed, I don't have the same desire to play the game.

Suggested Topics