Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • francezu95
    2 posts

    I have the same problem. Tried Cordelia a few times but was destroyed.
    Now, I cannot interact anymore with the corpse.
    Tried restarting the game but to no avail.

  • Delbertqb1
    1 posts

    @kanjman13 same, I tried to fight the electric daughter after 3 tries of losing at power level 90. I am now power level 250 and still cannot interact with her.

  • bdb384
    1 posts

    Also having an issue getting Cordelia to appear, the prompt isn't showing up on the hanging corpse. I've gotten her to show up before, then after beating the other two daughters it suddenly won't let me.

  • Killjoyno69
    3 posts

    Issue still persist. I've liked the other 2 and I've fought her before but now I can't. Please fix 😞

  • mfam2
    2 posts

    I have tried getting the thor armor set, after I completed the first two Daughters of Lerion the game didn't let me interact with Cordelia to start the boss fight. I have tried restarting, uninstalling, and loading an old save. Nothing is working someone help!

  • francezu95
    2 posts

    This issue is occurring for me as well, but with Cordelia. Same thing, tried a few times, to no success; now I can't interact with the hanging corpse.
    Did all other mysteries and wealth that were possible (only the armor at Lerion's palace remains, because I don't have the third dagger) in East Anglia, and I believe I did some main story missions as well (related to Oswald). Managed to defeat Regan in the meanwhile, although I've started that fight several times as well, but no issue occurred there.

    First, I've discovered Goneril and defeated her. Then I've discovered Cordelia and tried the fight but I was massively underpowered and at some point I saw that I cannot interact with the corpse anymore. Decided to leave it for later (as I was destroyed in the fights, did not bother at that time to re-load or try again to interact with the corpse). Some time later on I've discovered Regan and tried that a few times until I managed to defeat her. Now, when going back to Cordelia, the corpse is still not interactable.

    Restarting the game or re-loading another save does not work.

    @Ubisoft, any deadline or date when this is going to be fixed?

  • Opus728
    1 posts

    Same issue on PC
    I cannot interact with the corpse to spawn Cordelia in Berkelow Bog for Thor's Armor. I have killed the two other sisters but I cannot interact with the corpse to fight the final sister.

  • XdeathcoreX
    2 posts

    I have the same issue in PS5.

    I challenged Cordelia a couple of times and lost. After that I decided to upgrade my armor next to the corpse and saved. After that I wasn't able to interact with the corpse anymore.

  • MoKellex
    1 posts

    Same problem in Grantebridgescir. I tried around power level and got destroyed twice and I can't try again and to this point I have a power level around 370. So I want restart the nearly the whole game

  • SubarcticBobcat
    1 posts

    Xbox one player here

    I am also experiencing this issue, but with Cordelia

  • Beamerx17
    2 posts

    I am also having the same problem with the first daughter. Is there going to be a fix?

  • Beamerx17
    2 posts
    This post is deleted!
  • Keychack
    1 posts

    Same here with Cordelia, new update didnt fix this neither did it fix trophys not showing at the longhouse nor vinland loot being bug

  • Wamjimjam
    3 posts

    I just downloaded the latest patch but the problem was still there (1.0.4) this sucks.
    Anyone else managed to get it working?

  • Adinis1994
    1 posts

    @wamjimjam nope, not working

  • jeffertson1987
    11 posts

    Still the same problem with the patch 🤬

  • sadarum
    6 posts

    @jeffertson1987 ubi really [censored] it up in the update, i`ve been contacting them for a week and a half about this and they assured me that was gonna be we deserve compensation, just like in unity because this is messed up, and the ubi suppoort is down, awesome.

  • Jokypapa
    2 posts

    same bug with new update... 😞 Xbox one

  • RumbloodNox
    2 posts

    After defeating the easier sisters, I foolishly challenged Cordelia (Power 340) and lost. I decided to forgo her until I was stronger and thus continued to beat the story. Now, I have completed all territories except East Anglia. The mystery for Cordelia and the Wealth for Thor's Helmet are still incomplete since I cannot interact with the hanging corpse to summon her. Even with the new update 1.0.4 today, still nothing has changed. I've done as many things to prompt the interaction (fast travelling away, walking up to her, talking to experienced travelers and the cartographer, interacting with the Lerion statue) and still naught.

    Ubisoft, I'm enjoying the game and appreciate all you've done but I was sincerely hoping this would've been fixed. I would rather have a wholly complete game at launch and waiting for it than a buggy one.

  • yu8155
    1 posts

    Mine is bugged on the mystery located in Berkelow Bog with the same symptoms. It appears this bug could apply to any of the Daughters of Lerion. I have the other two defeated but not the one in Berkelow Bog and just as others I died 3 or 4 times before I was unable to interact with the corpse to initiate the fight. My last death was likely in the second stage as someone else stated which may be a factor.

Suggested Topics

Community Details