Welcome to discussions

Quick Suggestions

  • guest-DjhcmB6G
    3 posts

    @raudstrupe on Xbox series too. I’m trying to beet Cordelia and the same thing happened and had the same idea as you so have really advanced in the game but still not working

  • Ubi-Woofer
    Ubisoft Support Staff 1061 posts
    Best Answer

    Hello everyone,

    We announced last night that TU 1.1.1 will launch today on January 14th, and I am pleased to say that in this patch is the fix for the Daughters of Lerion encounter with Cordelia whereby the corpse cannot be interacted with to start the fight.

    Once the update has been applied and you have fully updated your game, you should find that you are able to interact with the corpse upon returning to her lair in Berkelow Bog in East Anglia. Please give this a try once the patch is released, and let me know here in this thread if you encounter any further issues!

    I would like to thank you all for bringing this issue to our attention, and for providing all of the requested information throughout our investigation of the issue. This thread will remain open if you have any further questions or concerns, and either myself or another agent will respond as soon as possible. Thank you! 🙂

    Official Response
  • Ubi-Swaggins
    Ubisoft Support Staff 420 posts

    @glehnxiv I have merged your thread into an active thread about this bug.

    The team are aware of it and are looking into it further.

    Official Response
  • te582
    1 posts

    Im experiencing the same issue i failed it multiple times and now the interact icon is gone and i cant fight her anymore

  • BIG_UNIT2015
    2 posts

    I’m trying to kill the first daughter of Lerion cordelia and it shows I haven’t defeated her yet I cannot interact with the strung up corpse to fight her please help very annoyed with this

  • Ima4nDAl0reI92
    12 posts

    I cannot start the cordelia boss fight. I fought her three times and when I went to try a fourth the game no longer lets me interact with the corpse that starts the fight. I have an ongoing case with Ubisoft already. PLEASE get this FIXED ASAP!!

  • xGodfatha88x
    5 posts

    @ima4ndal0rei92 yeah I have similar problem different witch though and no one seems to have a solution at least you got to fight her mine was broken from beginning

  • Bir1in
    8 posts

    Having the same issue on Xbox One. After fighting the second daughter, the interact icon (Y) was not there. I fast traveled and returned later and it fixed it. I then went to fight the third daughter but it happened again. This time, fast traveling is not working and loading previous saves is also not working. It seems to be a problem whenever you take multiple attempts at the fight. The autosave must be bugged.

  • Troy99926
    1 posts

    @bir1in was really hoping someone would no how to fix this

  • BottaDekulo
    1 posts

    @big_unit2015 I can't to

  • crazyguitarguys
    8 posts

    @glehnxiv i have the same thing dude, pisses me off badly

  • crazyguitarguys
    8 posts

    @ubi-swaggins do you reckon it'll be patched? and when will a patch come? or is it stuck in our safe games? if so, will we get the items from ubisoft because we'd lose 50 hours of progress if we had to start over?

  • Ima4nDAl0reI92
    12 posts

    I managed to beat the other two but as I said I can’t even get cordelia to spawn. It’s really frustrating. I want that thor helmet lol

  • ben100322
    1 posts

    @big_unit2015 did you find a fix?

  • sadarum
    6 posts

    hi there yall, i was trying to defeat cordelia a few times but i was underlevel, after some time i couldnt interact with the body thing and summon her, the prompt doesnt appear anymore. Anyone got this problem?

  • xGodfatha88x
    5 posts

    @ima4ndal0rei92 mine are all broken so I can't get any of them to spawn so at least you got two of three.

  • tinypicker
    23 posts

    I also have this issue, and I know seven others as well. Please at least tack this to the list Ubisoft.

  • Velier
    1 posts

    I have same problem, failed it about 3-4 times and now i cant activate it 😕

  • KNeblett2020
    1 posts

    Prompt no longer available to trigger boss fight with cordelia.

  • Connor1504
    1 posts

    @ima4ndal0rei92 I've also got this bug on the PS4, beat the other two witches but can't start the Cordelia Fight

  • DavidFCorreia
    3 posts

    Yeah, me too... Can't interact with Cordelia anymore... And this is an issue that is happening to a lot of people. I hope they will fix this, doesn't make much sense to bug like this just because we lost 3/4 times.

Suggested Topics

Community Details

156
Online
193.6k
Users
32.7k
Topics
163.5k
Posts