Welcome to discussions

Quick Suggestions

  • KNeblett2020
    1 posts

    Prompt no longer available to trigger boss fight with cordelia.

  • Ubi-Woofer
    Ubisoft Support Staff 1009 posts
    Best Answer

    Hello everyone,

    We announced last night that TU 1.1.1 will launch today on January 14th, and I am pleased to say that in this patch is the fix for the Daughters of Lerion encounter with Cordelia whereby the corpse cannot be interacted with to start the fight.

    Once the update has been applied and you have fully updated your game, you should find that you are able to interact with the corpse upon returning to her lair in Berkelow Bog in East Anglia. Please give this a try once the patch is released, and let me know here in this thread if you encounter any further issues!

    I would like to thank you all for bringing this issue to our attention, and for providing all of the requested information throughout our investigation of the issue. This thread will remain open if you have any further questions or concerns, and either myself or another agent will respond as soon as possible. Thank you! 🙂

    Official Response
  • Connor1504
    1 posts

    @ima4ndal0rei92 I've also got this bug on the PS4, beat the other two witches but can't start the Cordelia Fight

  • DavidFCorreia
    3 posts

    Yeah, me too... Can't interact with Cordelia anymore... And this is an issue that is happening to a lot of people. I hope they will fix this, doesn't make much sense to bug like this just because we lost 3/4 times.

  • o23SlimShady23o
    2 posts

    Same here can’t act with cordelia killed all the other ones

  • andres0013
    3 posts

    Anybody know any solution for this??

  • Xeraloth
    1 posts

    I also have the same issue. It occurred when I kept throwing my body at her, reloading and going at her again. Then she killed me one last time and I can't attempt a rematch anymore.

  • jeffertson1987
    11 posts

    hello my daughter of lerion in east anglia in the middle to the left is glitched i can not interact with Y so i cant start the mission
    how can i fix this ????

  • Ima4nDAl0reI92
    12 posts

    Ubisoft emailed me this morning about the case I have with them about this issue and they told me that others have reported the same issue and that it’s been sent to the development team. So now it’s just a matter of waiting on them to patch it

  • BIG_UNIT2015
    2 posts

    No still haven’t found a fix hopefully they fix it soon

  • TheKingsNoose
    4 posts

    @ubi-litten

    Was a few days ago (not the best example)
    undefined

  • TheKingsNoose
    4 posts

    @tbtheg234
    It's a known bug, no fix as of yet.

  • PolarCoded
    1 posts

    My fight with one of the Daughters of Lerion Cordelia seems to be glitched. I was able to attempt the fight twice before the prompt on the body disappeared. I’ve tried loading saves from an hour before the first attempt but no luck. Any suggestions would be very appreciated.

  • IbrahemHosni_95
    2 posts

    @polarcoded I have the same problem as well. It wont respawn when I arrive at the location

  • Zer00nEZer0
    1 posts

    I have nearly the same issue except with the third daughter Cornelia. The first two I have already killed.
    Have tried it three times with different powerlevel but couldn't get her. Now at powerlevel 203 I thought to give it another try but can not 'activate' that corpse anymore. Is there something new to this issue?

  • ValtyrNine
    87 posts

    This also happened to me. The body became uninteractable and I was no longer able to start the fight. The only way I found to fix it was to reload an earlier save that the one that was bugged.

  • ThisWhit3Guy
    1 posts

    Anyone hear back about a fix for this? The sister here is the only one I have left and I'd like to complete this.

  • R4Z0RW0LF
    8 posts

    Cannot interact with NPCs on (Xbox one X). Most notably the Berkcrow Bog sister there just isnt an interact button. I have tried reloading to a previous save and restarting my game but nothing. I also noticed that during seiges some npcs are invincible and can still kill you.

  • jeffertson1987
    11 posts

    I have the same problem with cordelia playing on xbox already got the other 2 please fix this

  • metalmetalrob
    1 posts

    I've seen a few similar posts about this battle, as well as the other two sisters having similar issues with the fights not starting.
    The icon is showing on the map and compass, but there's no prompt to trigger the battle.
    So, I'm reporting that I'm also having an issue in hopes that it get addressed sooner as more bug reports are submitted.
    Kinda annoying being that I've already defeated the other two sisters, lost this battle once, and now I can't restart it in order to progress and finish the mini quest line.
    Hope to see this fixed soon as I've been grinding my face off to get strong enough to defeat them and am now stuck on the last one with no option to complete it.

  • Andresteia26
    1 posts

    Same... I have thos bug to... 😥

Suggested Topics

Community Details

80
Online
191.2k
Users
32.0k
Topics
160.9k
Posts